aboutsummaryrefslogtreecommitdiffstats
path: root/community/wireshark/APKBUILD
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2018-01-19 10:52:05 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-01-19 14:17:24 +0000
commite8031ee227e1029614e4b9e5b6484bfc5b147cff (patch)
treed5ca72b4e5d114beacd38fba34d49a47d4db5135 /community/wireshark/APKBUILD
parent3d85c601d909ddbde9ddf470256ecf88ec7ca3e0 (diff)
downloadaports-e8031ee227e1029614e4b9e5b6484bfc5b147cff.tar.bz2
aports-e8031ee227e1029614e4b9e5b6484bfc5b147cff.tar.xz
community/wireshark: enable RTP streams playback
Enable check() (cherry picked from commit 9e81be5f331abefc06aa5f2dec67f906d45e13d2)
Diffstat (limited to 'community/wireshark/APKBUILD')
-rw-r--r--community/wireshark/APKBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/community/wireshark/APKBUILD b/community/wireshark/APKBUILD
index e336d6106a..3272754b2c 100644
--- a/community/wireshark/APKBUILD
+++ b/community/wireshark/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=wireshark
pkgver=2.4.3
-pkgrel=0
+pkgrel=1
pkgdesc="A network protocol analyzer - GTK version"
url="http://www.wireshark.org"
arch="all"
@@ -12,12 +12,11 @@ license="GPL2+"
depends=""
makedepends="bison flex perl-dev glib glib-dev libpcap-dev libcap-dev
gtk+3.0-dev c-ares-dev pcre-dev gnutls-dev libgcrypt-dev libressl-dev
- libnl3-dev qt5-qtbase-dev qt5-qttools-dev lua5.2-dev bash"
+ libnl3-dev qt5-qtbase-dev qt5-qttools-dev lua5.2-dev bash portaudio-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-gtk $pkgname-common tshark"
source="http://www.wireshark.org/download/src/$pkgname-$pkgver.tar.xz
fix-udpdump.patch
"
-
builddir="$srcdir"/$pkgname-$pkgver
# secfixes:
@@ -106,6 +105,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make -j1 DESTDIR="$pkgdir" install