aboutsummaryrefslogtreecommitdiffstats
path: root/community/wireshark/APKBUILD
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-05-13 14:04:57 -0300
committerShiz <hi@shiz.me>2017-05-14 03:31:05 +0200
commitf6afaa861224ce3d821a888f83fbf119cc4b5d34 (patch)
tree7d23131809777ebad619f3243dfe8e2351e5b4b6 /community/wireshark/APKBUILD
parente2d4157e82019ee7cb9b746d2a4509abe1fcf2de (diff)
downloadaports-f6afaa861224ce3d821a888f83fbf119cc4b5d34.tar.bz2
aports-f6afaa861224ce3d821a888f83fbf119cc4b5d34.tar.xz
community/wireshark: modernize abuild
Diffstat (limited to 'community/wireshark/APKBUILD')
-rw-r--r--community/wireshark/APKBUILD20
1 files changed, 3 insertions, 17 deletions
diff --git a/community/wireshark/APKBUILD b/community/wireshark/APKBUILD
index a183109f87..645f7624a7 100644
--- a/community/wireshark/APKBUILD
+++ b/community/wireshark/APKBUILD
@@ -13,7 +13,6 @@ depends=""
makedepends="bison flex perl-dev glib glib-dev libpcap-dev libcap-dev
gtk+3.0-dev c-ares-dev pcre-dev gnutls-dev libgcrypt-dev libressl-dev
libnl3-dev qt5-qtbase-dev qt5-qttools-dev bash"
-install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-gtk $pkgname-common tshark"
source="http://www.wireshark.org/download/src/$pkgname-$pkgver.tar.bz2
fix-androiddump.patch
@@ -43,18 +42,6 @@ builddir="$srcdir"/$pkgname-$pkgver
# - CVE-2016-6512
# - CVE-2016-6513
-prepare() {
- cd "$builddir"
- for i in $source; do
- case "$i" in
- *.patch)
- msg "Applying $i"
- patch -p1 -i "$srcdir"/$i || return 1
- ;;
- esac
- done
-}
-
build() {
cd "$builddir"
# configure script searches for uic and uic-qt4 but not uic-qt5
@@ -68,14 +55,13 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--with-ssl \
- --with-gnutls \
- || return 1
- make || return 1
+ --with-gnutls
+ make
}
package() {
cd "$builddir"
- make -j1 DESTDIR="$pkgdir" install || return 1
+ make -j1 DESTDIR="$pkgdir" install
}
common() {