aboutsummaryrefslogtreecommitdiffstats
path: root/community/wireshark/APKBUILD
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2020-01-01 15:02:06 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2020-01-01 16:33:56 +0100
commit1f6aefc41b1a12d505bdea22f58d437145a8f0e7 (patch)
treea826eac2dfb64f1b70e43bbac1222156a1be85b3 /community/wireshark/APKBUILD
parentf2f3fbcad97266ad64b896f7eec936a8437d70af (diff)
downloadaports-1f6aefc41b1a12d505bdea22f58d437145a8f0e7.tar.bz2
aports-1f6aefc41b1a12d505bdea22f58d437145a8f0e7.tar.xz
community/wireshark: move install scripts to -common subpackage
The dumpcap binary is owned by the wireshark group. Unfortunately, this binary is shipped by wireshark-common not wireshark itself. As such, the post-install scripts creating and advertising this group must also be part of the subpackage.
Diffstat (limited to 'community/wireshark/APKBUILD')
-rw-r--r--community/wireshark/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/community/wireshark/APKBUILD b/community/wireshark/APKBUILD
index 21e0f52137..85add765aa 100644
--- a/community/wireshark/APKBUILD
+++ b/community/wireshark/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=wireshark
pkgver=3.0.7
-pkgrel=2
+pkgrel=3
pkgdesc="A network protocol analyzer"
url="https://www.wireshark.org"
arch="all"
@@ -16,7 +16,6 @@ makedepends="bash bison c-ares-dev cmake flex glib glib-dev gnutls-dev
checkdepends="py3-pytest py3-pytest-xdist"
subpackages="$pkgname-dev $pkgname-doc $pkgname-common tshark"
pkggroups="wireshark"
-install="$pkgname.pre-install $pkgname.pre-upgrade $pkgname.post-install"
# Use mirror in the meantime
# source="https://www.wireshark.org/download/src/wireshark-$pkgver.tar.xz
source="https://1.as.dl.wireshark.org/src/wireshark-$pkgver.tar.xz
@@ -233,6 +232,8 @@ package() {
common() {
local i
pkgdesc="network protoccol analyzer - common files"
+ install="$subpkgname.pre-install $subpkgname.pre-upgrade $subpkgname.post-install"
+
mkdir -p "$subpkgdir"/usr/lib "$subpkgdir"/usr/share \
"$subpkgdir"/usr/bin
mv "$pkgdir"/usr/share/wireshark "$subpkgdir"/usr/share/