aboutsummaryrefslogtreecommitdiffstats
path: root/community/wkhtmltopdf
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2018-12-10 19:43:34 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-12-10 19:43:34 +0000
commit10a2b3a8cd75ab13660bef4a97f351e031fba917 (patch)
tree8d8549f106640e8849e24441a9106da06c58e95f /community/wkhtmltopdf
parent549536685bceb308bcca2f3f3781b31c8f241b4f (diff)
downloadaports-10a2b3a8cd75ab13660bef4a97f351e031fba917.tar.bz2
aports-10a2b3a8cd75ab13660bef4a97f351e031fba917.tar.xz
community/wkhtmltopdf: moved to community
ref: #9743
Diffstat (limited to 'community/wkhtmltopdf')
-rw-r--r--community/wkhtmltopdf/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/community/wkhtmltopdf/APKBUILD b/community/wkhtmltopdf/APKBUILD
new file mode 100644
index 0000000000..ae1a38b9a0
--- /dev/null
+++ b/community/wkhtmltopdf/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=wkhtmltopdf
+pkgver=0.12.5
+pkgrel=0
+pkgdesc="Simple shell utility to convert html to pdf"
+url="http://wkhtmltopdf.org/"
+arch="all"
+license="GPL-3.0-or-later"
+makedepends="$depends_dev qt5-qtbase-dev qt5-qtwebkit-dev qt5-qtsvg-dev
+ qt5-qtxmlpatterns-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/wkhtmltopdf/wkhtmltopdf/archive/$pkgver.tar.gz"
+options="!check" # no test suite
+_builddir="$srcdir"/wkhtmltopdf-$pkgver
+
+build() {
+ cd "$_builddir"
+ qmake-qt5 -makefile && make
+}
+
+package() {
+ cd "$_builddir"
+ make install INSTALL_ROOT="$pkgdir"/usr
+}
+
+sha512sums="3f982a6964085b36f62988b618d88d4339f03ad8d2e733c1fcba5e2e7cb545ccc99313ce35474605df818f91c289a87ddd952f21974fdbe846f990bf03fc2fdb wkhtmltopdf-0.12.5.tar.gz"