aboutsummaryrefslogtreecommitdiffstats
path: root/community/wlroots
diff options
context:
space:
mode:
authorDanct12 <danct12@disroot.org>2019-10-10 08:12:04 +0700
committerKevin Daudt <kdaudt@alpinelinux.org>2019-10-11 10:30:51 +0000
commit3354521ff02971cf3310949cc6e5e1ba6f403ca4 (patch)
tree820717b394e925153777ff6302e5f09242c3c13d /community/wlroots
parent55dab27b11a66504c161bfbcb6965e706c02c23d (diff)
downloadaports-3354521ff02971cf3310949cc6e5e1ba6f403ca4.tar.bz2
aports-3354521ff02971cf3310949cc6e5e1ba6f403ca4.tar.xz
community/wlroots: upgrade to 0.8.1
Signed-off-by: Danct12 <danct12@disroot.org> Closes GH-11872
Diffstat (limited to 'community/wlroots')
-rw-r--r--community/wlroots/APKBUILD8
-rw-r--r--community/wlroots/meson-disabler-workaround.patch24
2 files changed, 29 insertions, 3 deletions
diff --git a/community/wlroots/APKBUILD b/community/wlroots/APKBUILD
index 33ec6593cf..1036a62886 100644
--- a/community/wlroots/APKBUILD
+++ b/community/wlroots/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Henrik Riomar <henrik.riomar@gmail.com>
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=wlroots
-pkgver=0.7.0
+pkgver=0.8.1
pkgrel=0
pkgdesc="A modular Wayland compositor library"
url="https://github.com/swaywm/wlroots"
@@ -25,7 +25,8 @@ makedepends="
xcb-util-wm-dev
"
subpackages="$pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/swaywm/$pkgname/archive/$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/swaywm/$pkgname/archive/$pkgver.tar.gz
+ meson-disabler-workaround.patch"
build() {
meson \
@@ -41,4 +42,5 @@ package() {
DESTDIR="$pkgdir" ninja -C build install
}
-sha512sums="20e7e81bb945cc683c793f1258e83dbeea5e933faa066125f16a24aa7151000c620f9f47cad21540f8bea7d053d181cb89a2803c30fac1b1b9f3345065b9ba9c wlroots-0.7.0.tar.gz"
+sha512sums="da41513de48e00303b31fde620463389103215011c6cc49b9a2420a1529889722aa54f26a211179c528709edb6b90ba2efdae5e4bcef18147d9516f3a94e365a wlroots-0.8.1.tar.gz
+6163fb91ee1ab24acb3188f5abf866e4f55a3dac0a366dcd1050a0a72d1f4cad78df09b162a9128659cf00180c3174462de5150827f448be8b1d1becdd0894de meson-disabler-workaround.patch"
diff --git a/community/wlroots/meson-disabler-workaround.patch b/community/wlroots/meson-disabler-workaround.patch
new file mode 100644
index 0000000000..37d0609fbe
--- /dev/null
+++ b/community/wlroots/meson-disabler-workaround.patch
@@ -0,0 +1,24 @@
+From 3a62a43ef758ec4d973032a9aaeb6ed8d1be630e Mon Sep 17 00:00:00 2001
+From: Simon Ser <contact@emersion.fr>
+Date: Tue, 8 Oct 2019 19:33:19 +0300
+Subject: [PATCH] build: workaround for meson disabler object not working with
+ if not
+
+---
+ examples/meson.build | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/examples/meson.build b/examples/meson.build
+index 8a60e1edd..869384c29 100644
+--- a/examples/meson.build
++++ b/examples/meson.build
+@@ -20,7 +20,8 @@ foreach dep : ['libpng', 'libavutil', 'libavcodec', 'libavformat']
+ endif
+ endforeach
+
+-if not cc.has_header('libavutil/hwcontext_drm.h', dependencies: libavutil)
++# Check if libavutil is found because of https://github.com/mesonbuild/meson/issues/6010
++if libavutil.found() and not cc.has_header('libavutil/hwcontext_drm.h', dependencies: libavutil)
+ libavutil = disabler()
+ endif
+