aboutsummaryrefslogtreecommitdiffstats
path: root/community/woff2/dont-set-rpath.patch
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-01 01:31:09 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-03 17:35:25 +0000
commit5fd122be81534df7251b7908f8a9e7edc88acd4f (patch)
tree4703a33f18a76f0d4169fbf91ac8a81e876d26d7 /community/woff2/dont-set-rpath.patch
parentb7cdc1d551f335d43dc3dcbcf84a4616d847ab2e (diff)
downloadaports-5fd122be81534df7251b7908f8a9e7edc88acd4f.tar.bz2
aports-5fd122be81534df7251b7908f8a9e7edc88acd4f.tar.xz
community/woff2: new aport
Web Open Font Format 2 reference implementation https://github.com/google/woff2 To be used on webkit2gtk
Diffstat (limited to 'community/woff2/dont-set-rpath.patch')
-rw-r--r--community/woff2/dont-set-rpath.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/woff2/dont-set-rpath.patch b/community/woff2/dont-set-rpath.patch
new file mode 100644
index 0000000000..dbc76e1af6
--- /dev/null
+++ b/community/woff2/dont-set-rpath.patch
@@ -0,0 +1,30 @@
+From: Jeremy Bicha <jeremy@bicha.net>
+Date: Thu, 7 Dec 2017 13:40:57 -0500
+Subject: [PATCH] Don't set rpath
+
+https://github.com/google/woff2/pull/106
+---
+ CMakeLists.txt | 10 ----------
+ 1 file changed, 10 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index ecfbb83..da8ecf1 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -21,16 +21,6 @@ option(NOISY_LOGGING "Noisy logging" ON)
+ # Version information
+ set(WOFF2_VERSION 1.0.2)
+
+-# When building shared libraries it is important to set the correct rpath
+-# See https://cmake.org/Wiki/CMake_RPATH_handling#Always_full_RPATH
+-set(CMAKE_SKIP_BUILD_RPATH FALSE)
+-set(CMAKE_BUILD_WITH_INSTALL_RPATH FALSE)
+-set(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
+-list(FIND CMAKE_PLATFORM_IMPLICIT_LINK_DIRECTORIES "${CMAKE_INSTALL_LIBDIR}" isSystemDir)
+-if ("${isSystemDir}" STREQUAL "-1")
+- set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_LIBDIR}")
+-endif()
+-
+ # Find Brotli dependencies
+ set(CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
+ find_package(BrotliDec)