aboutsummaryrefslogtreecommitdiffstats
path: root/community/xbps/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-15 01:21:10 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-04-15 01:21:35 +0200
commit6020727d4b626472aac1a38a7ca0ed6959f9a85f (patch)
treee57be71eaf26b849eb4c9963a56744c688b727ca /community/xbps/APKBUILD
parent50cf88b61df8a5172b3731f8def875301bbb18d7 (diff)
downloadaports-6020727d4b626472aac1a38a7ca0ed6959f9a85f.tar.bz2
aports-6020727d4b626472aac1a38a7ca0ed6959f9a85f.tar.xz
community/xbps: move from testing
Diffstat (limited to 'community/xbps/APKBUILD')
-rw-r--r--community/xbps/APKBUILD68
1 files changed, 68 insertions, 0 deletions
diff --git a/community/xbps/APKBUILD b/community/xbps/APKBUILD
new file mode 100644
index 0000000000..c4eeca802c
--- /dev/null
+++ b/community/xbps/APKBUILD
@@ -0,0 +1,68 @@
+# Contributor: André Klitzing <aklitzing@gmail.com>
+# Maintainer: André Klitzing <aklitzing@gmail.com>
+pkgname=xbps
+pkgver=0.51
+pkgrel=0
+pkgdesc="The X Binary Package System"
+arch="all"
+url="https://github.com/voidlinux/xbps"
+license="BSD"
+depends="ca-certificates"
+makedepends="zlib-dev libarchive-dev libressl-dev"
+subpackages="$pkgname-dev $pkgname-doc
+ $pkgname-bash-completion:bashcomp:noarch
+ $pkgname-zsh-completion:zshcomp:noarch"
+options="!check"
+source="$pkgname-$pkgver.tar.gz::https://github.com/voidlinux/$pkgname/archive/$pkgver.tar.gz
+ fix-build-with-misleading-indentation.patch
+ configure-fix-vasprintf-test.patch
+ moving-_unused-macro-to-_unused_attr.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --bindir=/usr/bin \
+ --localstatedir=/var/lib/xbps
+ make
+}
+
+package() {
+ cd "$builddir"
+
+ make DESTDIR="$pkgdir/" install
+
+ install -D -m 644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ install -D -m 644 COPYING.3RDPARTY \
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING.3RDPARTY"
+}
+
+bashcomp() {
+ pkgdesc="Bash completions for $pkgname"
+ depends=""
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+
+ _submv usr/share/bash-completion/completions
+}
+
+zshcomp() {
+ pkgdesc="ZSH completions for $pkgname"
+ depends=""
+ install_if="$pkgname=$pkgver-r$pkgrel zsh"
+
+ _submv usr/share/zsh/site-functions
+}
+
+_submv() {
+ local path="$1"
+ mkdir -p "$subpkgdir"/${path%/*}
+ mv "$pkgdir"/$path "$subpkgdir"/${path%/*}/
+}
+
+sha512sums="243dbef97bd94b05af1a79605f20050d00c6dfaffa8dbc56ea0b3b2d218a627fb45f157f9f82b6eb080f58a7445de9e7bf75d669f0be4caae262af5c5ac92262 xbps-0.51.tar.gz
+1e3e07152bbef6e7b10a462012c517beb2da207887ff1148c0b1509973efc520924236fd1e9ce9d5c0904cd403984caa52b5612f9037c1e24008711b68690221 fix-build-with-misleading-indentation.patch
+2de97a2fc9041ee456e58798d302028d428770fde775c21564a8ae8a7ba57393d7ff5e64680f8c62456a377df7528249278197030708050bb776470570e28416 configure-fix-vasprintf-test.patch
+f4048531c35f86b08c85348b8e684edc576302f2da78a53214194532fada3246ba8310c19bf8bcc139da7c29843363c77002ccb37cd529e566be2ed39b484d6e moving-_unused-macro-to-_unused_attr.patch"