aboutsummaryrefslogtreecommitdiffstats
path: root/community/xbps
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-23 11:40:32 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-24 22:15:10 -0300
commit30b76cda7d84b25df7a6a3323056986837c0c077 (patch)
treea3a22b7349076804d462dff03e3787d85fd81c02 /community/xbps
parentb20dcba3c85ac8fff7ea390b6312301fdda6718b (diff)
downloadaports-30b76cda7d84b25df7a6a3323056986837c0c077.tar.bz2
aports-30b76cda7d84b25df7a6a3323056986837c0c077.tar.xz
community/xbps: upgrade to 0.55
Diffstat (limited to 'community/xbps')
-rw-r--r--community/xbps/0f338597015271ee504100c32fd2c4926efdb423.patch472
-rw-r--r--community/xbps/APKBUILD23
-rw-r--r--community/xbps/disable-Werror.patch13
-rw-r--r--community/xbps/openssl-1.1.patch126
4 files changed, 4 insertions, 630 deletions
diff --git a/community/xbps/0f338597015271ee504100c32fd2c4926efdb423.patch b/community/xbps/0f338597015271ee504100c32fd2c4926efdb423.patch
deleted file mode 100644
index 6d056cc3d5..0000000000
--- a/community/xbps/0f338597015271ee504100c32fd2c4926efdb423.patch
+++ /dev/null
@@ -1,472 +0,0 @@
-From 0f338597015271ee504100c32fd2c4926efdb423 Mon Sep 17 00:00:00 2001
-From: Foxlet <foxlet@furcode.co>
-Date: Tue, 17 Jul 2018 22:24:26 -0400
-Subject: [PATCH] Fix namespace violation
-
----
- bin/xbps-alternatives/main.c | 2 +-
- bin/xbps-create/main.c | 4 +--
- bin/xbps-install/main.c | 4 +--
- bin/xbps-install/state_cb.c | 2 +-
- bin/xbps-pkgdb/check.c | 6 ++---
- bin/xbps-pkgdb/check_pkg_unneeded.c | 2 +-
- bin/xbps-query/list.c | 38 ++++++++++++++---------------
- bin/xbps-query/ownedby.c | 10 ++++----
- bin/xbps-query/search.c | 8 +++---
- bin/xbps-reconfigure/main.c | 2 +-
- bin/xbps-remove/clean-cache.c | 4 +--
- bin/xbps-remove/main.c | 2 +-
- bin/xbps-rindex/index-clean.c | 4 +--
- bin/xbps-rindex/remove-obsoletes.c | 2 +-
- bin/xbps-uchroot/main.c | 4 +--
- configure | 2 +-
- lib/package_orphans.c | 2 +-
- lib/plist_fetch.c | 6 ++---
- lib/rpool.c | 6 ++---
- lib/transaction_conflicts.c | 2 +-
- 20 files changed, 56 insertions(+), 56 deletions(-)
-
-diff --git a/bin/xbps-alternatives/main.c b/bin/xbps-alternatives/main.c
-index c722a74b..94ab31e8 100644
---- a/bin/xbps-alternatives/main.c
-+++ b/bin/xbps-alternatives/main.c
-@@ -55,7 +55,7 @@ usage(bool fail)
- }
-
- static int
--state_cb(const struct xbps_state_cb_data *xscd, void *cbd _unused)
-+state_cb(const struct xbps_state_cb_data *xscd, void *cbd UNUSED)
- {
- bool slog = false;
-
-diff --git a/bin/xbps-create/main.c b/bin/xbps-create/main.c
-index aac9676a..2c211215 100644
---- a/bin/xbps-create/main.c
-+++ b/bin/xbps-create/main.c
-@@ -199,7 +199,7 @@ process_one_alternative(const char *altgrname, const char *val)
-
-
- static void
--process_dict_of_arrays(const char *key _unused, const char *val)
-+process_dict_of_arrays(const char *key UNUSED, const char *val)
- {
- char *altgrname, *args, *p, *saveptr;
-
-@@ -302,7 +302,7 @@ entry_is_conf_file(const char *file)
- }
-
- static int
--ftw_cb(const char *fpath, const struct stat *sb, const struct dirent *dir _unused)
-+ftw_cb(const char *fpath, const struct stat *sb, const struct dirent *dir UNUSED)
- {
- struct xentry *xe = NULL;
- xbps_dictionary_t fileinfo = NULL;
-diff --git a/bin/xbps-install/main.c b/bin/xbps-install/main.c
-index b57f2fe9..da20da1a 100644
---- a/bin/xbps-install/main.c
-+++ b/bin/xbps-install/main.c
-@@ -68,7 +68,7 @@ usage(bool fail)
- }
-
- static void
--unpack_progress_cb(const struct xbps_unpack_cb_data *xpd, void *cbdata _unused)
-+unpack_progress_cb(const struct xbps_unpack_cb_data *xpd, void *cbdata UNUSED)
- {
- if (xpd->entry == NULL || xpd->entry_total_count <= 0)
- return;
-@@ -80,7 +80,7 @@ unpack_progress_cb(const struct xbps_unpack_cb_data *xpd, void *cbdata _unused)
- }
-
- static int
--repo_import_key_cb(struct xbps_repo *repo, void *arg _unused, bool *done _unused)
-+repo_import_key_cb(struct xbps_repo *repo, void *arg UNUSED, bool *done UNUSED)
- {
- int rv;
-
-diff --git a/bin/xbps-install/state_cb.c b/bin/xbps-install/state_cb.c
-index 5189b9a9..a2063cea 100644
---- a/bin/xbps-install/state_cb.c
-+++ b/bin/xbps-install/state_cb.c
-@@ -32,7 +32,7 @@
- #include "defs.h"
-
- int
--state_cb(const struct xbps_state_cb_data *xscd, void *cbdata _unused)
-+state_cb(const struct xbps_state_cb_data *xscd, void *cbdata UNUSED)
- {
- xbps_dictionary_t pkgd;
- const char *instver, *newver;
-diff --git a/bin/xbps-pkgdb/check.c b/bin/xbps-pkgdb/check.c
-index ed393398..6ae11db7 100644
---- a/bin/xbps-pkgdb/check.c
-+++ b/bin/xbps-pkgdb/check.c
-@@ -36,11 +36,11 @@
- #include "defs.h"
-
- static int
--pkgdb_cb(struct xbps_handle *xhp _unused,
-+pkgdb_cb(struct xbps_handle *xhp UNUSED,
- xbps_object_t obj,
-- const char *key _unused,
-+ const char *key UNUSED,
- void *arg,
-- bool *done _unused)
-+ bool *done UNUSED)
- {
- const char *pkgver;
- char *pkgname;
-diff --git a/bin/xbps-pkgdb/check_pkg_unneeded.c b/bin/xbps-pkgdb/check_pkg_unneeded.c
-index d2249304..2b137b3f 100644
---- a/bin/xbps-pkgdb/check_pkg_unneeded.c
-+++ b/bin/xbps-pkgdb/check_pkg_unneeded.c
-@@ -43,7 +43,7 @@
- * and remove them if that was true.
- */
- int
--check_pkg_unneeded(struct xbps_handle *xhp _unused, const char *pkgname, void *arg)
-+check_pkg_unneeded(struct xbps_handle *xhp UNUSED, const char *pkgname, void *arg)
- {
- xbps_array_t replaces;
- xbps_dictionary_t pkgd = arg;
-diff --git a/bin/xbps-query/list.c b/bin/xbps-query/list.c
-index ddda8be8..f08334c3 100644
---- a/bin/xbps-query/list.c
-+++ b/bin/xbps-query/list.c
-@@ -38,11 +38,11 @@ struct list_pkgver_cb {
- };
-
- int
--list_pkgs_in_dict(struct xbps_handle *xhp _unused,
-+list_pkgs_in_dict(struct xbps_handle *xhp UNUSED,
- xbps_object_t obj,
-- const char *key _unused,
-+ const char *key UNUSED,
- void *arg,
-- bool *loop_done _unused)
-+ bool *loop_done UNUSED)
- {
- struct list_pkgver_cb *lpc = arg;
- const char *pkgver, *short_desc, *state_str;
-@@ -88,11 +88,11 @@ list_pkgs_in_dict(struct xbps_handle *xhp _unused,
- }
-
- int
--list_manual_pkgs(struct xbps_handle *xhp _unused,
-+list_manual_pkgs(struct xbps_handle *xhp UNUSED,
- xbps_object_t obj,
-- const char *key _unused,
-- void *arg _unused,
-- bool *loop_done _unused)
-+ const char *key UNUSED,
-+ void *arg UNUSED,
-+ bool *loop_done UNUSED)
- {
- const char *pkgver;
- bool automatic = false;
-@@ -107,11 +107,11 @@ list_manual_pkgs(struct xbps_handle *xhp _unused,
- }
-
- int
--list_hold_pkgs(struct xbps_handle *xhp _unused,
-+list_hold_pkgs(struct xbps_handle *xhp UNUSED,
- xbps_object_t obj,
-- const char *key _unused,
-- void *arg _unused,
-- bool *loop_done _unused)
-+ const char *key UNUSED,
-+ void *arg UNUSED,
-+ bool *loop_done UNUSED)
- {
- const char *pkgver;
-
-@@ -124,11 +124,11 @@ list_hold_pkgs(struct xbps_handle *xhp _unused,
- }
-
- int
--list_repolock_pkgs(struct xbps_handle *xhp _unused,
-+list_repolock_pkgs(struct xbps_handle *xhp UNUSED,
- xbps_object_t obj,
-- const char *key _unused,
-- void *arg _unused,
-- bool *loop_done _unused)
-+ const char *key UNUSED,
-+ void *arg UNUSED,
-+ bool *loop_done UNUSED)
- {
- const char *pkgver;
-
-@@ -171,7 +171,7 @@ list_pkgs_pkgdb(struct xbps_handle *xhp)
- }
-
- static int
--repo_list_uri_cb(struct xbps_repo *repo, void *arg _unused, bool *done _unused)
-+repo_list_uri_cb(struct xbps_repo *repo, void *arg UNUSED, bool *done UNUSED)
- {
- const char *signedby = NULL;
- uint16_t pubkeysize = 0;
-@@ -219,11 +219,11 @@ struct fflongest {
- };
-
- static int
--_find_longest_pkgver_cb(struct xbps_handle *xhp _unused,
-+_find_longest_pkgver_cb(struct xbps_handle *xhp UNUSED,
- xbps_object_t obj,
-- const char *key _unused,
-+ const char *key UNUSED,
- void *arg,
-- bool *loop_done _unused)
-+ bool *loop_done UNUSED)
- {
- struct fflongest *ffl = arg;
- const char *pkgver;
-diff --git a/bin/xbps-query/ownedby.c b/bin/xbps-query/ownedby.c
-index fc8684dc..11f76a99 100644
---- a/bin/xbps-query/ownedby.c
-+++ b/bin/xbps-query/ownedby.c
-@@ -97,9 +97,9 @@ match_files_by_pattern(xbps_dictionary_t pkg_filesd,
- static int
- ownedby_pkgdb_cb(struct xbps_handle *xhp,
- xbps_object_t obj,
-- const char *obj_key _unused,
-+ const char *obj_key UNUSED,
- void *arg,
-- bool *done _unused)
-+ bool *done UNUSED)
- {
- xbps_dictionary_t pkgmetad;
- xbps_array_t files_keys;
-@@ -129,9 +129,9 @@ ownedby_pkgdb_cb(struct xbps_handle *xhp,
- static int
- repo_match_cb(struct xbps_handle *xhp,
- xbps_object_t obj,
-- const char *key _unused,
-+ const char *key UNUSED,
- void *arg,
-- bool *done _unused)
-+ bool *done UNUSED)
- {
- xbps_dictionary_t filesd;
- xbps_array_t files_keys;
-@@ -163,7 +163,7 @@ repo_match_cb(struct xbps_handle *xhp,
- }
-
- static int
--repo_ownedby_cb(struct xbps_repo *repo, void *arg, bool *done _unused)
-+repo_ownedby_cb(struct xbps_repo *repo, void *arg, bool *done UNUSED)
- {
- xbps_array_t allkeys;
- struct ffdata *ffd = arg;
-diff --git a/bin/xbps-query/search.c b/bin/xbps-query/search.c
-index 4b7ef054..41e1211d 100644
---- a/bin/xbps-query/search.c
-+++ b/bin/xbps-query/search.c
-@@ -94,11 +94,11 @@ print_results(struct xbps_handle *xhp, struct search_data *sd)
- }
-
- static int
--search_array_cb(struct xbps_handle *xhp _unused,
-+search_array_cb(struct xbps_handle *xhp UNUSED,
- xbps_object_t obj,
-- const char *key _unused,
-+ const char *key UNUSED,
- void *arg,
-- bool *done _unused)
-+ bool *done UNUSED)
- {
- xbps_object_t obj2;
- struct search_data *sd = arg;
-@@ -210,7 +210,7 @@ search_array_cb(struct xbps_handle *xhp _unused,
- }
-
- static int
--search_repo_cb(struct xbps_repo *repo, void *arg, bool *done _unused)
-+search_repo_cb(struct xbps_repo *repo, void *arg, bool *done UNUSED)
- {
- xbps_array_t allkeys;
- struct search_data *sd = arg;
-diff --git a/bin/xbps-reconfigure/main.c b/bin/xbps-reconfigure/main.c
-index 814959a8..1508c375 100644
---- a/bin/xbps-reconfigure/main.c
-+++ b/bin/xbps-reconfigure/main.c
-@@ -52,7 +52,7 @@ usage(bool fail)
- }
-
- static int
--state_cb(const struct xbps_state_cb_data *xscd, void *cbd _unused)
-+state_cb(const struct xbps_state_cb_data *xscd, void *cbd UNUSED)
- {
- bool slog = false;
-
-diff --git a/bin/xbps-remove/clean-cache.c b/bin/xbps-remove/clean-cache.c
-index dacc9a59..b3e00622 100644
---- a/bin/xbps-remove/clean-cache.c
-+++ b/bin/xbps-remove/clean-cache.c
-@@ -38,8 +38,8 @@
-
- static int
- cleaner_cb(struct xbps_handle *xhp, xbps_object_t obj,
-- const char *key _unused, void *arg,
-- bool *done _unused)
-+ const char *key UNUSED, void *arg,
-+ bool *done UNUSED)
- {
- xbps_dictionary_t repo_pkgd;
- const char *binpkg, *rsha256;
-diff --git a/bin/xbps-remove/main.c b/bin/xbps-remove/main.c
-index 25554e8c..838e610b 100644
---- a/bin/xbps-remove/main.c
-+++ b/bin/xbps-remove/main.c
-@@ -64,7 +64,7 @@ usage(bool fail)
- }
-
- static int
--state_cb_rm(const struct xbps_state_cb_data *xscd, void *cbdata _unused)
-+state_cb_rm(const struct xbps_state_cb_data *xscd, void *cbdata UNUSED)
- {
- bool slog = false;
-
-diff --git a/bin/xbps-rindex/index-clean.c b/bin/xbps-rindex/index-clean.c
-index 364d57ed..27cedd6e 100644
---- a/bin/xbps-rindex/index-clean.c
-+++ b/bin/xbps-rindex/index-clean.c
-@@ -47,9 +47,9 @@ struct CleanerCbInfo {
- static int
- idx_cleaner_cb(struct xbps_handle *xhp,
- xbps_object_t obj,
-- const char *key _unused,
-+ const char *key UNUSED,
- void *arg,
-- bool *done _unused)
-+ bool *done UNUSED)
- {
- struct CleanerCbInfo *info = arg;
- const char *arch, *pkgver, *sha256;
-diff --git a/bin/xbps-rindex/remove-obsoletes.c b/bin/xbps-rindex/remove-obsoletes.c
-index f426fe7c..80cf2fff 100644
---- a/bin/xbps-rindex/remove-obsoletes.c
-+++ b/bin/xbps-rindex/remove-obsoletes.c
-@@ -65,7 +65,7 @@ remove_pkg(const char *repodir, const char *file)
- }
-
- static int
--cleaner_cb(struct xbps_handle *xhp, xbps_object_t obj, const char *key _unused, void *arg, bool *done _unused)
-+cleaner_cb(struct xbps_handle *xhp, xbps_object_t obj, const char *key UNUSED, void *arg, bool *done UNUSED)
- {
- struct xbps_repo *repo = ((struct xbps_repo **)arg)[0], *stage = ((struct xbps_repo **)arg)[1];
- const char *binpkg;
-diff --git a/bin/xbps-uchroot/main.c b/bin/xbps-uchroot/main.c
-index 0ee13253..c232de8e 100644
---- a/bin/xbps-uchroot/main.c
-+++ b/bin/xbps-uchroot/main.c
-@@ -109,8 +109,8 @@ die(const char *fmt, ...)
- }
-
- static int
--ftw_cb(const char *fpath, const struct stat *sb _unused, int type,
-- struct FTW *ftwbuf _unused)
-+ftw_cb(const char *fpath, const struct stat *sb UNUSED, int type,
-+ struct FTW *ftwbuf UNUSED)
- {
- int sverrno = 0;
-
-diff --git a/configure b/configure
-index 32cc5569..ebef990a 100755
---- a/configure
-+++ b/configure
-@@ -192,7 +192,7 @@ echo "CPPFLAGS += -DXBPS_SYSCONF_PATH=\\\"${ETCDIR}\\\"" >>$CONFIG_MK
- echo "CPPFLAGS += -DXBPS_SYSDEFCONF_PATH=\\\"${SHAREDIR}/xbps.d\\\"" >>$CONFIG_MK
- echo "CPPFLAGS += -DXBPS_VERSION=\\\"${VERSION}\\\"" >>$CONFIG_MK
- echo "CPPFLAGS += -DXBPS_META_PATH=\\\"${DBDIR}\\\"" >>$CONFIG_MK
--echo "CPPFLAGS += -D_unused=\"__attribute__((__unused__))\"" >>$CONFIG_MK
-+echo "CPPFLAGS += -DUNUSED=\"__attribute__((__unused__))\"" >>$CONFIG_MK
-
- if [ -d .git ]; then
- _gitrev=$(git rev-parse --short HEAD)
-diff --git a/lib/package_orphans.c b/lib/package_orphans.c
-index 4a31fe1d..b908c049 100644
---- a/lib/package_orphans.c
-+++ b/lib/package_orphans.c
-@@ -60,7 +60,7 @@
- */
-
- xbps_array_t
--xbps_find_pkg_orphans(struct xbps_handle *xhp, xbps_array_t orphans_user _unused)
-+xbps_find_pkg_orphans(struct xbps_handle *xhp, xbps_array_t orphans_user UNUSED)
- {
- xbps_array_t rdeps, reqby, array = NULL;
- xbps_dictionary_t pkgd, deppkgd;
-diff --git a/lib/plist_fetch.c b/lib/plist_fetch.c
-index a1535515..fedd8ce8 100644
---- a/lib/plist_fetch.c
-+++ b/lib/plist_fetch.c
-@@ -46,7 +46,7 @@ struct fetch_archive {
- };
-
- static int
--fetch_archive_open(struct archive *a _unused, void *client_data)
-+fetch_archive_open(struct archive *a UNUSED, void *client_data)
- {
- struct fetch_archive *f = client_data;
-
-@@ -59,7 +59,7 @@ fetch_archive_open(struct archive *a _unused, void *client_data)
- }
-
- static ssize_t
--fetch_archive_read(struct archive *a _unused, void *client_data, const void **buf)
-+fetch_archive_read(struct archive *a UNUSED, void *client_data, const void **buf)
- {
- struct fetch_archive *f = client_data;
-
-@@ -68,7 +68,7 @@ fetch_archive_read(struct archive *a _unused, void *client_data, const void **bu
- }
-
- static int
--fetch_archive_close(struct archive *a _unused, void *client_data)
-+fetch_archive_close(struct archive *a UNUSED, void *client_data)
- {
- struct fetch_archive *f = client_data;
-
-diff --git a/lib/rpool.c b/lib/rpool.c
-index 9acc1181..94af7298 100644
---- a/lib/rpool.c
-+++ b/lib/rpool.c
-@@ -120,7 +120,7 @@ xbps_rpool_get_repo(const char *url)
- }
-
- void
--xbps_rpool_release(struct xbps_handle *xhp _unused)
-+xbps_rpool_release(struct xbps_handle *xhp UNUSED)
- {
- struct xbps_repo *repo;
-
-@@ -195,7 +195,7 @@ find_pkg_cb(struct xbps_repo *repo, void *arg, bool *done)
- }
-
- static int
--find_pkg_revdeps_cb(struct xbps_repo *repo, void *arg, bool *done _unused)
-+find_pkg_revdeps_cb(struct xbps_repo *repo, void *arg, bool *done UNUSED)
- {
- struct rpool_fpkg *rpf = arg;
- xbps_array_t revdeps = NULL;
-@@ -216,7 +216,7 @@ find_pkg_revdeps_cb(struct xbps_repo *repo, void *arg, bool *done _unused)
- }
-
- static int
--find_best_pkg_cb(struct xbps_repo *repo, void *arg, bool *done _unused)
-+find_best_pkg_cb(struct xbps_repo *repo, void *arg, bool *done UNUSED)
- {
- struct rpool_fpkg *rpf = arg;
- xbps_dictionary_t pkgd;
-diff --git a/lib/transaction_conflicts.c b/lib/transaction_conflicts.c
-index 09975cee..387895a4 100644
---- a/lib/transaction_conflicts.c
-+++ b/lib/transaction_conflicts.c
-@@ -148,7 +148,7 @@ pkg_conflicts_trans(struct xbps_handle *xhp, xbps_array_t array,
-
- static int
- pkgdb_conflicts_cb(struct xbps_handle *xhp, xbps_object_t obj,
-- const char *key _unused, void *arg, bool *done _unused)
-+ const char *key UNUSED, void *arg, bool *done UNUSED)
- {
- xbps_array_t pkg_cflicts, trans_cflicts, pkgs = arg;
- xbps_dictionary_t pkgd;
diff --git a/community/xbps/APKBUILD b/community/xbps/APKBUILD
index b6d4077d26..0e3bbd0ae0 100644
--- a/community/xbps/APKBUILD
+++ b/community/xbps/APKBUILD
@@ -1,12 +1,12 @@
# Contributor: André Klitzing <aklitzing@gmail.com>
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=xbps
-pkgver=0.53
-pkgrel=1
+pkgver=0.55
+pkgrel=0
pkgdesc="The X Binary Package System"
arch="all"
url="https://github.com/voidlinux/xbps"
-license="BSD"
+license="BSD-2-Clause AND (BSD-3-Clause AND ISC AND BSD-2-Clause-NetBSD)"
depends="ca-certificates"
makedepends="zlib-dev libarchive-dev openssl-dev"
subpackages="$pkgname-dev $pkgname-doc
@@ -14,15 +14,9 @@ subpackages="$pkgname-dev $pkgname-doc
$pkgname-zsh-completion:zshcomp:noarch"
options="!check"
source="$pkgname-$pkgver.tar.gz::https://github.com/void-linux/$pkgname/archive/$pkgver.tar.gz
- 0f338597015271ee504100c32fd2c4926efdb423.patch
- disable-Werror.patch
- openssl-1.1.patch
"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
-
./configure \
--prefix=/usr \
--sysconfdir=/etc \
@@ -32,13 +26,7 @@ build() {
}
package() {
- cd "$builddir"
-
make DESTDIR="$pkgdir/" install
-
- install -D -m 644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
- install -D -m 644 COPYING.3RDPARTY \
- "$pkgdir/usr/share/licenses/$pkgname/COPYING.3RDPARTY"
}
bashcomp() {
@@ -63,7 +51,4 @@ _submv() {
mv "$pkgdir"/$path "$subpkgdir"/${path%/*}/
}
-sha512sums="f40a479196e95cd1c01962230cd3e61f424474ceb454c3d7a31d59b636a0f17138023ae2822bb1666765f15618e3fa7e4fa48786c5530eb975f637b6abf6418f xbps-0.53.tar.gz
-5ae4fa6c5fc8d115b01d74c85121e13933b17a09404d53923a316ce7cc30325227019db33a2efe891ed2be5f61600e3003c37f07c24639ef32786d5b8d4d9c2b 0f338597015271ee504100c32fd2c4926efdb423.patch
-a761edd8fd358b500337fcef79f6163ef642fc387f97d952fec0838baa786d585f21e34cd066cba1918f474bccd7decbad2587b91f125b75e308b2dfe8f4721a disable-Werror.patch
-c61d64f618ee21bdf120512ada3d67babeded06830384b800754e586fd66d16772984d6fe325e4674098a1e07caf737e8293848008d068591656808f267fafcb openssl-1.1.patch"
+sha512sums="3188d62f83d844c26702e1018f261c74462c1d658cd1cd45f74becbf3e879d3e0684d425921c1ae1bca57914af2cf6b0a872836b54fa7abf8d370546b89756f3 xbps-0.55.tar.gz"
diff --git a/community/xbps/disable-Werror.patch b/community/xbps/disable-Werror.patch
deleted file mode 100644
index a572b0580e..0000000000
--- a/community/xbps/disable-Werror.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/configure b/configure
-index 9bff5d5..cc5d2ce 100755
---- a/configure
-+++ b/configure
-@@ -266,7 +266,7 @@ fi
- #
- # Check for some compiler warning flags.
- #
--for f in all extra error shadow "format=2" missing-prototypes \
-+for f in all extra shadow "format=2" missing-prototypes \
- missing-declarations nested-externs vla no-overlength-strings \
- unsafe-loop-optimizations undef sign-compare \
- missing-include-dirs old-style-definition \
diff --git a/community/xbps/openssl-1.1.patch b/community/xbps/openssl-1.1.patch
deleted file mode 100644
index 677be08539..0000000000
--- a/community/xbps/openssl-1.1.patch
+++ /dev/null
@@ -1,126 +0,0 @@
-From b4eebafa6d634c4e0e00267ae69703e506ac101d Mon Sep 17 00:00:00 2001
-From: wuhanck <wuhanck@hotmail.com>
-Date: Thu, 24 Jan 2019 18:39:07 +0800
-Subject: [PATCH] upgrade to openssl 1.1.x.
-
----
- configure | 2 +-
- lib/fetch/common.c | 2 +-
- lib/pubkey2fp.c | 29 ++++++++++++++++++-----------
- 3 files changed, 20 insertions(+), 13 deletions(-)
-
-diff --git a/configure b/configure
-index ebef990a..b6e642a2 100755
---- a/configure
-+++ b/configure
-@@ -678,7 +678,7 @@ fi
- # libssl with pkg-config support is required.
- #
- printf "Checking for libssl via pkg-config ... "
--if $PKGCONFIG_BIN --exists 'libssl < 1.1' && ! $PKGCONFIG_BIN --exists libtls ; then
-+if $PKGCONFIG_BIN --exists 'libssl < 1.2' && ! $PKGCONFIG_BIN --exists libtls ; then
- echo "found OpenSSL version $($PKGCONFIG_BIN --modversion libssl)."
- elif $PKGCONFIG_BIN --exists libssl libtls; then
- echo "found LibreSSL version $($PKGCONFIG_BIN --modversion libssl)."
-diff --git a/lib/fetch/common.c b/lib/fetch/common.c
-index 94fb2651..b3d8f2f0 100644
---- a/lib/fetch/common.c
-+++ b/lib/fetch/common.c
-@@ -895,7 +895,7 @@ fetch_ssl_verify_altname(STACK_OF(GENERAL_NAME) *altnames,
-
- for (i = 0; i < sk_GENERAL_NAME_num(altnames); ++i) {
- name = sk_GENERAL_NAME_value(altnames, i);
-- ns = (const char *)ASN1_STRING_data(name->d.ia5);
-+ ns = (const char *)ASN1_STRING_get0_data(name->d.ia5);
- nslen = (size_t)ASN1_STRING_length(name->d.ia5);
-
- if (name->type == GEN_DNS && ip == NULL &&
-diff --git a/lib/pubkey2fp.c b/lib/pubkey2fp.c
-index 2cfe7178..c1a46e88 100644
---- a/lib/pubkey2fp.c
-+++ b/lib/pubkey2fp.c
-@@ -65,12 +65,13 @@ fp2str(unsigned const char *fp, unsigned int len)
- char *
- xbps_pubkey2fp(struct xbps_handle *xhp, xbps_data_t pubkey)
- {
-- EVP_MD_CTX mdctx;
-+ EVP_MD_CTX *mdctx = NULL;
- EVP_PKEY *pPubKey = NULL;
- RSA *pRsa = NULL;
- BIO *bio = NULL;
- const void *pubkeydata;
- unsigned char md_value[EVP_MAX_MD_SIZE];
-+ const BIGNUM *n, *e;
- unsigned char *nBytes = NULL, *eBytes = NULL, *pEncoding = NULL;
- unsigned int md_len = 0;
- char *hexfpstr = NULL;
-@@ -79,6 +80,8 @@ xbps_pubkey2fp(struct xbps_handle *xhp, xbps_data_t pubkey)
- ERR_load_crypto_strings();
- OpenSSL_add_all_algorithms();
-
-+ mdctx = EVP_MD_CTX_new();
-+ assert(mdctx);
- pubkeydata = xbps_data_data_nocopy(pubkey);
- bio = BIO_new_mem_buf(__UNCONST(pubkeydata), xbps_data_size(pubkey));
- assert(bio);
-@@ -91,7 +94,7 @@ xbps_pubkey2fp(struct xbps_handle *xhp, xbps_data_t pubkey)
- goto out;
- }
-
-- if (EVP_PKEY_type(pPubKey->type) != EVP_PKEY_RSA) {
-+ if (EVP_PKEY_base_id(pPubKey) != EVP_PKEY_RSA) {
- xbps_dbg_printf(xhp, "only RSA public keys are currently supported\n");
- goto out;
- }
-@@ -103,19 +106,20 @@ xbps_pubkey2fp(struct xbps_handle *xhp, xbps_data_t pubkey)
- goto out;
- }
-
-+ RSA_get0_key(pRsa, &n, &e, NULL);
- // reading the modulus
-- nLen = BN_num_bytes(pRsa->n);
-+ nLen = BN_num_bytes(n);
- nBytes = (unsigned char*) malloc(nLen);
- if (nBytes == NULL)
- goto out;
-- BN_bn2bin(pRsa->n, nBytes);
-+ BN_bn2bin(n, nBytes);
-
- // reading the public exponent
-- eLen = BN_num_bytes(pRsa->e);
-+ eLen = BN_num_bytes(e);
- eBytes = (unsigned char*) malloc(eLen);
- if (eBytes == NULL)
- goto out;
-- BN_bn2bin(pRsa->e, eBytes);
-+ BN_bn2bin(e, eBytes);
-
- encodingLength = 11 + 4 + eLen + 4 + nLen;
- // correct depending on the MSB of e and N
-@@ -135,18 +139,21 @@ xbps_pubkey2fp(struct xbps_handle *xhp, xbps_data_t pubkey)
- /*
- * Compute the RSA fingerprint (MD5).
- */
-- EVP_MD_CTX_init(&mdctx);
-- EVP_DigestInit_ex(&mdctx, EVP_md5(), NULL);
-- EVP_DigestUpdate(&mdctx, pEncoding, encodingLength);
-- if (EVP_DigestFinal_ex(&mdctx, md_value, &md_len) == 0)
-+ EVP_MD_CTX_init(mdctx);
-+ EVP_DigestInit_ex(mdctx, EVP_md5(), NULL);
-+ EVP_DigestUpdate(mdctx, pEncoding, encodingLength);
-+ if (EVP_DigestFinal_ex(mdctx, md_value, &md_len) == 0)
- goto out;
-- EVP_MD_CTX_cleanup(&mdctx);
-+ EVP_MD_CTX_free(mdctx);
-+ mdctx = NULL;
- /*
- * Convert result to a compatible OpenSSH hex fingerprint.
- */
- hexfpstr = fp2str(md_value, md_len);
-
- out:
-+ if (mdctx)
-+ EVP_MD_CTX_free(mdctx);
- if (bio)
- BIO_free_all(bio);
- if (pRsa)