aboutsummaryrefslogtreecommitdiffstats
path: root/community/xcb-util-xrm
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-07-01 00:48:32 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2018-07-01 00:48:32 +0200
commitc411b17d8961acfe839aeed054466837ecde582a (patch)
tree83fdfbfed9d02fde7caefcae1a65fac08048fb39 /community/xcb-util-xrm
parent5580b83a3d84186e0054d32cd454b46d170f9b63 (diff)
downloadaports-c411b17d8961acfe839aeed054466837ecde582a.tar.bz2
aports-c411b17d8961acfe839aeed054466837ecde582a.tar.xz
community/xcb-util-xrm: cleanup
* Refactor depends * Use the configure options used by the newapkbuild autotools template
Diffstat (limited to 'community/xcb-util-xrm')
-rw-r--r--community/xcb-util-xrm/APKBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/community/xcb-util-xrm/APKBUILD b/community/xcb-util-xrm/APKBUILD
index 16cea1fc2e..27fba75955 100644
--- a/community/xcb-util-xrm/APKBUILD
+++ b/community/xcb-util-xrm/APKBUILD
@@ -7,20 +7,26 @@ pkgdesc="Utility functions for the X resource manager"
url="https://github.com/Airblader/xcb-util-xrm"
arch="all"
license="MIT"
-makedepends="autoconf automake bsd-compat-headers libtool libx11-dev libxcb-dev util-macros xcb-util-dev"
-source="https://github.com/Airblader/xcb-util-xrm/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
+makedepends="m4 bsd-compat-headers libx11-dev libxcb-dev util-macros xcb-util-dev"
+source="https://github.com/Airblader/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
subpackages="$pkgname-dev"
builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
- ./configure --prefix="/usr"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir/" install
+ make DESTDIR="$pkgdir" install
}
sha512sums="d8a427ed6d1f1568ce58db9b89284e4fafcc7b7929c31bccf70e5ccd91f3f6cb9c87ff25c4e64d95b0c6215cfecde6c0ee2b3a18759817aea3169ba87602c5de xcb-util-xrm-1.3.tar.gz"