aboutsummaryrefslogtreecommitdiffstats
path: root/community/xcmsdb/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-24 19:02:11 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-24 23:29:30 -0300
commit338ac300b16944f20da1699fe6130558822115a0 (patch)
treefb3d72f62ca60a19e9920e51871edccdcb55d3a5 /community/xcmsdb/APKBUILD
parentbee1704100f04269a8d0c68813c927b32d0debf1 (diff)
downloadaports-338ac300b16944f20da1699fe6130558822115a0.tar.bz2
aports-338ac300b16944f20da1699fe6130558822115a0.tar.xz
community/xcmsdb: move from main
Diffstat (limited to 'community/xcmsdb/APKBUILD')
-rw-r--r--community/xcmsdb/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/xcmsdb/APKBUILD b/community/xcmsdb/APKBUILD
new file mode 100644
index 0000000000..f81774e36f
--- /dev/null
+++ b/community/xcmsdb/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xcmsdb
+pkgver=1.0.5
+pkgrel=0
+pkgdesc="Device Color Characterization utility for X Color Management System"
+url="http://xorg.freedesktop.org/"
+arch="all"
+license="custom"
+subpackages="$pkgname-doc"
+depends=
+makedepends="libx11-dev"
+source="https://www.x.org/releases/individual/app/$pkgname-$pkgver.tar.bz2"
+
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+sha512sums="e47bfce87d7531e7809c300e01120c3e8d6001130d9a6c9f6de5bc19651d8712d273a6f54452223bd8c4bff4612b5ecae8db45eddb022da945ed6e14c9c84ae4 xcmsdb-1.0.5.tar.bz2"