aboutsummaryrefslogtreecommitdiffstats
path: root/community/xdg-dbus-proxy/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-09-09 15:43:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-09-10 05:38:11 +0000
commit91ba9be2ce5c4fd00cdc91795c018b8429a67663 (patch)
treef32f6269cfb011f8f87997df0e2da4333846f1f1 /community/xdg-dbus-proxy/APKBUILD
parent58c10f30a1d3f9d44fb660350ce834314608aaa2 (diff)
downloadaports-91ba9be2ce5c4fd00cdc91795c018b8429a67663.tar.bz2
aports-91ba9be2ce5c4fd00cdc91795c018b8429a67663.tar.xz
community/xdg-dbus-proxy: new aport
Filtering proxy for D-Bus connections https://github.com/flatpak/xdg-dbus-proxy/ Needed by webkit2gtk j# ../../main/s390x-use-elf-gdb_fpregset_t.patch
Diffstat (limited to 'community/xdg-dbus-proxy/APKBUILD')
-rw-r--r--community/xdg-dbus-proxy/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/xdg-dbus-proxy/APKBUILD b/community/xdg-dbus-proxy/APKBUILD
new file mode 100644
index 0000000000..a9d7fa0272
--- /dev/null
+++ b/community/xdg-dbus-proxy/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname="xdg-dbus-proxy"
+pkgver="0.1.1"
+pkgrel=0
+pkgdesc="Filtering proxy for D-Bus connections"
+url="https://github.com/flatpak/xdg-dbus-proxy/"
+arch="all"
+license="LGPL-2.1-or-later"
+depends="dbus"
+makedepends="glib-dev docbook-xsl libxslt"
+subpackages="$pkgname-doc"
+source="https://github.com/flatpak/xdg-dbus-proxy/releases/download/$pkgver/xdg-dbus-proxy-$pkgver.tar.xz
+ musl-fix.patch" # https://github.com/flatpak/flatpak/issues/618
+builddir="$srcdir/xdg-dbus-proxy-$pkgver"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="30917de338c596f9728eece0858675f82e7d410cea862840e6818209beeaf2f42d85d59e9019d667fcb30db0987e439b36ecd81168ef4c3f998c560e12ddd348 xdg-dbus-proxy-0.1.1.tar.xz
+aa3d8494e7d59079f14a8352b2062e8b67409ce452d1eeadebbbcf444a876ebbafd722146fbaf6c9258d19991ed50988655a8314993b1fe83f5c7b63e0847878 musl-fix.patch"