aboutsummaryrefslogtreecommitdiffstats
path: root/community/xdg-desktop-portal
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-09-09 21:49:51 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-09-11 15:14:40 -0300
commit252d5710720e605b8761a84fca6be6091d08a90c (patch)
treef4ba53feb6f0ef1e4e510d1439f0bd530ce6ae72 /community/xdg-desktop-portal
parenta6792fa4f4e318dc11aeb44081526bac3b100e29 (diff)
downloadaports-252d5710720e605b8761a84fca6be6091d08a90c.tar.bz2
aports-252d5710720e605b8761a84fca6be6091d08a90c.tar.xz
community/xdg-desktop-portal: move from testing
Diffstat (limited to 'community/xdg-desktop-portal')
-rw-r--r--community/xdg-desktop-portal/APKBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/community/xdg-desktop-portal/APKBUILD b/community/xdg-desktop-portal/APKBUILD
new file mode 100644
index 0000000000..2f949024d4
--- /dev/null
+++ b/community/xdg-desktop-portal/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=xdg-desktop-portal
+pkgver=1.4.2
+pkgrel=1
+pkgdesc="Desktop integration portal"
+url="https://github.com/flatpak/xdg-desktop-portal"
+arch="all"
+license="LGPL-2.1-or-later"
+depends="bubblewrap"
+makedepends="gettext-dev glib-dev json-glib-dev fontconfig-dev
+ geoclue-dev xmlto flatpak-dev pipewire-dev fuse-dev"
+checkdepends="dbus"
+subpackages="$pkgname-lang $pkgname-doc"
+source="https://github.com/flatpak/xdg-desktop-portal/releases/download/${pkgver}/xdg-desktop-portal-${pkgver}.tar.xz"
+
+prepare() {
+ default_prepare
+
+ sed 's|/usr/bin/sh|/bin/sh|' \
+ -i compile \
+ -i missing \
+ -i install-sh \
+ -i depcomp \
+ -i config.sub \
+ -i config.guess
+}
+
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+
+ # We don't need this
+ rm -rf "$pkgdir"/usr/lib/systemd
+
+ mkdir -p "$pkgdir"/usr/lib
+ mv "$pkgdir"/usr/share/pkgconfig "$pkgdir"/usr/lib
+}
+
+sha512sums="9a19dc8f6899a24f8827ce36447316ce74f293abed469be24adfaa16d18deac0b7c5d77f744eed9b540b54cd23145281dacb6811dc52b34180b21d6dc02efc5a xdg-desktop-portal-1.4.2.tar.xz"