aboutsummaryrefslogtreecommitdiffstats
path: root/community/xfburn
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-11-03 15:34:59 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-11-03 11:53:46 -0300
commite21011be383e003a96ac4ec35522bcd5cccd0a8e (patch)
tree489b24dc6a87e69fae35b09bd65c9842dd2ac007 /community/xfburn
parenta9c2e74d38005132f3d2c16c3d6f969973559fcf (diff)
downloadaports-e21011be383e003a96ac4ec35522bcd5cccd0a8e.tar.bz2
aports-e21011be383e003a96ac4ec35522bcd5cccd0a8e.tar.xz
community/xfburn: use https
Remove unused patches and configuration options.
Diffstat (limited to 'community/xfburn')
-rw-r--r--community/xfburn/APKBUILD6
-rw-r--r--community/xfburn/fix_empty_dir_segfault.patch48
-rw-r--r--community/xfburn/xfburn-0.4.3-desktop-file.patch19
-rw-r--r--community/xfburn/xfburn-0.4.3-if-with-several-statements.patch54
4 files changed, 2 insertions, 125 deletions
diff --git a/community/xfburn/APKBUILD b/community/xfburn/APKBUILD
index 667788ef7d..83694cb896 100644
--- a/community/xfburn/APKBUILD
+++ b/community/xfburn/APKBUILD
@@ -4,7 +4,7 @@ pkgver=0.6.0
pkgrel=0
pkgdesc="a simple CD/DVD burning tool based on libburnia libraries"
options="!check" # No testsuite
-url="http://goodies.xfce.org/projects/applications/xfburn"
+url="https://goodies.xfce.org/projects/applications/xfburn"
arch="all !s390x" # librsvg
license="GPL-2.0-or-later"
depends="desktop-file-utils hicolor-icon-theme"
@@ -18,9 +18,7 @@ build() {
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --enable-gstreamer \
- --enable-thunar-vfs \
- --enable-dbus
+ --enable-gstreamer
make
}
diff --git a/community/xfburn/fix_empty_dir_segfault.patch b/community/xfburn/fix_empty_dir_segfault.patch
deleted file mode 100644
index 93418ae413..0000000000
--- a/community/xfburn/fix_empty_dir_segfault.patch
+++ /dev/null
@@ -1,48 +0,0 @@
---- ./xfburn/xfburn-data-composition.c 2011-02-17 16:37:03.000000000 +0100
-+++ ./xfburn/xfburn-data-composition_patched.c 2011-02-17 16:40:40.000000000 +0100
-@@ -1874,26 +1874,29 @@
- g_error ("Failed adding %s as a node to the image: code %X!", src, r);
- }
-
-- basename = g_path_get_basename (src);
-+ /* Check names only for items not manually created (#613563) */
-+ if (type != DATA_COMPOSITION_TYPE_DIRECTORY || src != NULL) {
-+ basename = g_path_get_basename (src);
-+
-+ /* check if the file has been renamed */
-+ if (strcmp (basename, name) != 0) {
-+ /* rename the iso_node */
-+ r = iso_node_set_name (node, name);
-+
-+ if (r == 0) {
-+ /* The first string is the renamed name, the second one the original name */
-+ xfce_warn (_("Duplicate filename '%s' for '%s'"), name, src);
-+
-+ g_free (basename);
-+ g_free (name);
-+ g_free (src);
-
-- /* check if the file has been renamed */
-- if (strcmp (basename, name) != 0) {
-- /* rename the iso_node */
-- r = iso_node_set_name (node, name);
--
-- if (r == 0) {
-- /* The first string is the renamed name, the second one the original name */
-- xfce_warn (_("Duplicate filename '%s' for '%s'"), name, src);
--
-- g_free (basename);
-- g_free (name);
-- g_free (src);
--
-- continue;
-+ continue;
-+ }
- }
-+ g_free (basename);
- }
-
-- g_free (basename);
- g_free (name);
- g_free (src);
-
diff --git a/community/xfburn/xfburn-0.4.3-desktop-file.patch b/community/xfburn/xfburn-0.4.3-desktop-file.patch
deleted file mode 100644
index 7669b5fb8a..0000000000
--- a/community/xfburn/xfburn-0.4.3-desktop-file.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- xfburn-0.4.3.orig/xfburn.desktop.in 2009-08-13 01:12:26.000000000 +0200
-+++ xfburn-0.4.3/xfburn.desktop.in 2012-09-28 22:12:14.840869423 +0200
-@@ -6,7 +6,7 @@
- Exec=xfburn
- TryExec=xfburn
- Icon=media-cdrom
--MimeType=application/x-cd-image
-+MimeType=application/x-cd-image;
- Terminal=false
- Categories=X-XFCE;GTK;DiscBurning;Archiving;AudioVideo;
- StartupNotify=true
-@@ -14,7 +14,6 @@
- Actions=BurnImage;
-
- [Desktop Action BurnImage]
--MimeType=application/x-cd-image
- Icon=media-cdrom
- Exec=xfburn -i %f
- _Name=Burn Image (xfburn)
diff --git a/community/xfburn/xfburn-0.4.3-if-with-several-statements.patch b/community/xfburn/xfburn-0.4.3-if-with-several-statements.patch
deleted file mode 100644
index 18de28f589..0000000000
--- a/community/xfburn/xfburn-0.4.3-if-with-several-statements.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-same as http://git.xfce.org/apps/xfburn/commit/?id=e1d6bfc2 but against 0.4.3
-https://bugzilla.xfce.org/show_bug.cgi?id=7103
-
-diff -dur xfburn-0.4.3.orig/xfburn/xfburn-data-composition.c xfburn-0.4.3/xfburn/xfburn-data-composition.c
---- xfburn-0.4.3.orig/xfburn/xfburn-data-composition.c 2009-12-04 08:46:43.000000000 +0100
-+++ xfburn-0.4.3/xfburn/xfburn-data-composition.c 2012-09-28 21:59:01.975954901 +0200
-@@ -1075,7 +1075,9 @@
-
- /* ensure that we can only drop on top of folders, not files */
- if (insertion) {
-+ gdk_threads_enter ();
- gtk_tree_model_get (model, insertion, DATA_COMPOSITION_COLUMN_TYPE, &parent_type, -1);
-+ gdk_threads_leave ();
-
- if (parent_type == DATA_COMPOSITION_TYPE_FILE) {
- DBG ("Parent is file, and we're dropping into %d", position);
-@@ -1116,9 +1118,7 @@
- } else {
- tree_path = gtk_tree_path_new_first ();
- }
-- gdk_threads_leave ();
-
-- gdk_threads_enter ();
- if (file_exists_on_same_level (model, tree_path, FALSE, name)) {
- xfce_err (_("A file with the same name is already present in the composition."));
-
-@@ -1821,10 +1821,11 @@
-
- if (thread_add_file_to_list (composition, model, full_path, &iter, &iter_where_insert, position)) {
- if (position == GTK_TREE_VIEW_DROP_INTO_OR_BEFORE
-- || position == GTK_TREE_VIEW_DROP_INTO_OR_AFTER)
-+ || position == GTK_TREE_VIEW_DROP_INTO_OR_AFTER) {
- gdk_threads_enter ();
- gtk_tree_view_expand_row (GTK_TREE_VIEW (widget), priv->path_where_insert, FALSE);
- gdk_threads_leave ();
-+ }
- }
-
- } else {
-diff -dur xfburn-0.4.3.orig/xfburn/xfburn-utils.h xfburn-0.4.3/xfburn/xfburn-utils.h
---- xfburn-0.4.3.orig/xfburn/xfburn-utils.h 2009-12-04 08:30:28.000000000 +0100
-+++ xfburn-0.4.3/xfburn/xfburn-utils.h 2012-09-28 21:59:01.976954907 +0200
-@@ -27,6 +27,11 @@
-
- #include "xfburn-global.h"
-
-+/*
-+#define XFBURN_GDK_ENTER() { DBG("gdk-thread-enter"); gdk_threads_enter(); }
-+#define XFBURN_GDK_LEAVE() { DBG("gdk-thread-leave"); gdk_threads_leave(); }
-+*/
-+
- void xfburn_busy_cursor (GtkWidget *);
- void xfburn_default_cursor (GtkWidget *);
-