aboutsummaryrefslogtreecommitdiffstats
path: root/community/xfce4-appfinder/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-04-23 19:44:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-23 19:44:46 +0000
commit27d1e194717b1696b3169ad43df027876247b91a (patch)
tree8416dc507bc2aed5f47588d345abe1ef22a6c60f /community/xfce4-appfinder/APKBUILD
parent0090cfe5db52bd764631d9b1d55e6e74c7cf2ae8 (diff)
downloadaports-27d1e194717b1696b3169ad43df027876247b91a.tar.bz2
aports-27d1e194717b1696b3169ad43df027876247b91a.tar.xz
main/{xfce*} => community/
Move everything xfce to community
Diffstat (limited to 'community/xfce4-appfinder/APKBUILD')
-rw-r--r--community/xfce4-appfinder/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/community/xfce4-appfinder/APKBUILD b/community/xfce4-appfinder/APKBUILD
new file mode 100644
index 0000000000..7d52f24ee4
--- /dev/null
+++ b/community/xfce4-appfinder/APKBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xfce4-appfinder
+pkgver=4.12.0
+pkgrel=1
+pkgdesc="Xfce application finder"
+url="https://xfce.org/"
+arch="all"
+license="GPL-2.0+"
+depends="hicolor-icon-theme"
+makedepends="thunar-dev gtk+-dev libxfce4ui-dev garcon-dev"
+subpackages="$pkgname-lang"
+install=
+replaces="xfce-utils"
+source="http://archive.xfce.org/src/xfce/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+sha512sums="025d38f9f2d57d1bcc37d38f4956742593cbee820ccf7d375138ca3eb0a9614090e3b969aba9d80b546eac43d2a9fd6c530ff829f0e4f59621ca068159e9adaf xfce4-appfinder-4.12.0.tar.bz2"