aboutsummaryrefslogtreecommitdiffstats
path: root/community/xfce4-session/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-04-23 19:44:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-23 19:44:46 +0000
commit27d1e194717b1696b3169ad43df027876247b91a (patch)
tree8416dc507bc2aed5f47588d345abe1ef22a6c60f /community/xfce4-session/APKBUILD
parent0090cfe5db52bd764631d9b1d55e6e74c7cf2ae8 (diff)
downloadaports-27d1e194717b1696b3169ad43df027876247b91a.tar.bz2
aports-27d1e194717b1696b3169ad43df027876247b91a.tar.xz
main/{xfce*} => community/
Move everything xfce to community
Diffstat (limited to 'community/xfce4-session/APKBUILD')
-rw-r--r--community/xfce4-session/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/community/xfce4-session/APKBUILD b/community/xfce4-session/APKBUILD
new file mode 100644
index 0000000000..a11696b76c
--- /dev/null
+++ b/community/xfce4-session/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xfce4-session
+pkgver=4.12.1
+pkgrel=3
+pkgdesc="A session manager for Xfce"
+url="https://xfce.org/"
+arch="all"
+license="GPL-2.0+"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+depends="hicolor-icon-theme iceauth dbus-x11"
+makedepends="libxfce4ui-dev xfconf-dev libwnck-dev libice-dev xfce4-panel-dev"
+install=
+source="http://archive.xfce.org/src/xfce/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2
+ busybox-shutdown.patch"
+
+build() {
+ cd "$builddir"
+
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib/xfce4 \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-legacy-sm
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ # tips doesnt work and i dont like them.
+ # just remove to save space
+ rm -f "$pkgdir"/etc/xdg/autostart/xfce4-tips-autostart.desktop \
+ "$pkgdir"/usr/bin/xfce4-tips
+}
+
+sha512sums="d7f37dbff59acb316965ab2224674ac3b5b7cfd7262acd4426b582001cee313945acb8883be21553dd6d7a046934bbbe116f451e6d5fd35b6fa5444da94605df xfce4-session-4.12.1.tar.bz2
+745aea2738980b0e8960701af40246b9c3e17ad0c0eb55d1c4629feb7cde472218573c2b27de492c774ae0a5eb503c73088a65df76bde65c9f923edcce03920f busybox-shutdown.patch"