aboutsummaryrefslogtreecommitdiffstats
path: root/community/xfce4-whiskermenu-plugin
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-04-23 19:44:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-23 19:44:46 +0000
commit27d1e194717b1696b3169ad43df027876247b91a (patch)
tree8416dc507bc2aed5f47588d345abe1ef22a6c60f /community/xfce4-whiskermenu-plugin
parent0090cfe5db52bd764631d9b1d55e6e74c7cf2ae8 (diff)
downloadaports-27d1e194717b1696b3169ad43df027876247b91a.tar.bz2
aports-27d1e194717b1696b3169ad43df027876247b91a.tar.xz
main/{xfce*} => community/
Move everything xfce to community
Diffstat (limited to 'community/xfce4-whiskermenu-plugin')
-rw-r--r--community/xfce4-whiskermenu-plugin/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/xfce4-whiskermenu-plugin/APKBUILD b/community/xfce4-whiskermenu-plugin/APKBUILD
new file mode 100644
index 0000000000..14384e35b2
--- /dev/null
+++ b/community/xfce4-whiskermenu-plugin/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xfce4-whiskermenu-plugin
+pkgver=2.1.5
+pkgrel=0
+pkgdesc="alternate application launcher for Xfce"
+url="https://gottcode.org/xfce4-whiskermenu-plugin/"
+arch="all"
+license="GPL-2.0"
+options="!check" # No test suite
+depends=""
+makedepends="cmake libxfce4ui-dev libxfce4util-dev exo-dev garcon-dev xfce4-panel-dev"
+subpackages="$pkgname-doc $pkgname-lang"
+source="http://mirror.netcologne.de/xfce/src/panel-plugins/xfce4-whiskermenu-plugin/${pkgver%.*}/xfce4-whiskermenu-plugin-$pkgver.tar.bz2"
+builddir="$srcdir"/xfce4-whiskermenu-plugin-$pkgver
+
+build() {
+ cd "$builddir"
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_BUILD_TYPE=Release \
+ .
+ make
+}
+
+package() {
+ cd "$builddir"
+ make install LIBDIR=lib DESTDIR="$pkgdir"
+}
+
+sha512sums="54e308b516ef1694f9649578cb8297f830132e456e1f498183074386956873f7f9f6ea8a0167d506086a87ae17acfbfd8a2b34eb6f0acb97f896872f8799b1f1 xfce4-whiskermenu-plugin-2.1.5.tar.bz2"