aboutsummaryrefslogtreecommitdiffstats
path: root/community/xgamma
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-24 19:00:51 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-24 23:29:30 -0300
commit97e7dbae26d35c5848114ff1640d288391e04f92 (patch)
treea6f5c977dfd6a7f98fefb79ebf59e11a243f88d4 /community/xgamma
parentfdc53cd5e07aa4566cb1374b89299d8c0989429d (diff)
downloadaports-97e7dbae26d35c5848114ff1640d288391e04f92.tar.bz2
aports-97e7dbae26d35c5848114ff1640d288391e04f92.tar.xz
community/xgamma: move from main
Diffstat (limited to 'community/xgamma')
-rw-r--r--community/xgamma/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/xgamma/APKBUILD b/community/xgamma/APKBUILD
new file mode 100644
index 0000000000..d195b89b6f
--- /dev/null
+++ b/community/xgamma/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xgamma
+pkgver=1.0.6
+pkgrel=0
+pkgdesc="Alter a monitor's gamma correction through the X server"
+url="http://xorg.freedesktop.org/"
+arch="all"
+license="custom"
+subpackages="$pkgname-doc"
+depends=
+makedepends="libx11-dev libxxf86vm-dev"
+source="https://www.x.org/releases/individual/app/$pkgname-$pkgver.tar.bz2"
+
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+sha512sums="2d41798e15ac8c6f6731a2da29589207d936eaee1223ce6f3ca948e67d63c5c8b955d11c7db092dcd8c66a6209bd15c1de3dc1446dad4b4277134f010c6fc47a xgamma-1.0.6.tar.bz2"