aboutsummaryrefslogtreecommitdiffstats
path: root/community/xgamma
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-24 19:01:04 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-24 23:29:30 -0300
commitbee1704100f04269a8d0c68813c927b32d0debf1 (patch)
tree018aae33ae2bef12188d17cb583b8c8df2db7de4 /community/xgamma
parent97e7dbae26d35c5848114ff1640d288391e04f92 (diff)
downloadaports-bee1704100f04269a8d0c68813c927b32d0debf1.tar.bz2
aports-bee1704100f04269a8d0c68813c927b32d0debf1.tar.xz
community/xgamma: modernize
Diffstat (limited to 'community/xgamma')
-rw-r--r--community/xgamma/APKBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/community/xgamma/APKBUILD b/community/xgamma/APKBUILD
index d195b89b6f..64c118eea2 100644
--- a/community/xgamma/APKBUILD
+++ b/community/xgamma/APKBUILD
@@ -7,25 +7,19 @@ url="http://xorg.freedesktop.org/"
arch="all"
license="custom"
subpackages="$pkgname-doc"
-depends=
makedepends="libx11-dev libxxf86vm-dev"
-source="https://www.x.org/releases/individual/app/$pkgname-$pkgver.tar.bz2"
-
-builddir="$srcdir/$pkgname-$pkgver"
+source="https://www.x.org/releases/individual/app/xgamma-$pkgver.tar.bz2"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --mandir=/usr/share/man \
- || return 1
- make || return 1
+ --mandir=/usr/share/man
+ make
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
sha512sums="2d41798e15ac8c6f6731a2da29589207d936eaee1223ce6f3ca948e67d63c5c8b955d11c7db092dcd8c66a6209bd15c1de3dc1446dad4b4277134f010c6fc47a xgamma-1.0.6.tar.bz2"