aboutsummaryrefslogtreecommitdiffstats
path: root/community/xmlsec
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2018-12-21 18:12:11 +0100
committerAndy Postnikov <apostnikov@gmail.com>2018-12-27 22:30:00 +0200
commitcb878459e4c26088bf0eee4837cc39171b1cec87 (patch)
tree90d64fade1b4bbdd063a72fea1c2d23021328af8 /community/xmlsec
parent72f21fab069dab518c848a2ee515c22b93e7cb79 (diff)
downloadaports-cb878459e4c26088bf0eee4837cc39171b1cec87.tar.bz2
aports-cb878459e4c26088bf0eee4837cc39171b1cec87.tar.xz
community/xmlsec: upgrade to 1.2.27
Resolves #9110
Diffstat (limited to 'community/xmlsec')
-rw-r--r--community/xmlsec/APKBUILD11
-rw-r--r--community/xmlsec/libressl-2.7.patch26
2 files changed, 5 insertions, 32 deletions
diff --git a/community/xmlsec/APKBUILD b/community/xmlsec/APKBUILD
index da40115898..759a06bc52 100644
--- a/community/xmlsec/APKBUILD
+++ b/community/xmlsec/APKBUILD
@@ -1,19 +1,19 @@
# Contributor: Sander Maijers <S.N.Maijers+Alpine@gmail.com>
# Maintainer: Sander Maijers <S.N.Maijers+Alpine@gmail.com>
pkgname='xmlsec'
-pkgver=1.2.25
-pkgrel=4
+pkgver=1.2.27
+pkgrel=0
pkgdesc="Provides a C based implementation for XML Signature Syntax and Processing and XML Encryption Syntax and Processing."
url="https://github.com/lsh123/xmlsec/"
arch="all"
license="MIT"
makedepends="${depends_dev} libxml2-dev libxslt-dev openssl-dev nss-dev
autoconf automake libtool"
+checkdepends="nss-tools"
install=
options="libtool"
subpackages="$pkgname-nss $pkgname-dev $pkgname-doc"
-source="https://github.com/lsh123/xmlsec/archive/xmlsec-${pkgver//./_}.tar.gz
- libressl-2.7.patch"
+source="https://github.com/lsh123/xmlsec/archive/xmlsec-${pkgver//./_}.tar.gz"
builddir="${srcdir}/${pkgname}-${pkgname}-${pkgver//./_}"
prepare() {
@@ -58,5 +58,4 @@ nss() {
mv "$pkgdir"/usr/lib/libxmlsec1-$lib.so* "$subpkgdir"/usr/lib/
}
-sha512sums="3f05d76c70eecbcb38b466fc191a13ff692a39e36ab04c7d667f726b9e59e8896ce469e147f907fb044b154d0d5f00b89f6c0fc6d84a90b715efe6c80e0e123d xmlsec-1_2_25.tar.gz
-2ca8e2b844ba880d18bbd383c6ef5f4fdc650a3533daff3cc118e1f30e0929a98c5b1fca825274d810e14808a8fb3dd3557d4f944c118ae393fbd86a5f9d69bd libressl-2.7.patch"
+sha512sums="261528086adc379942861b5950e5b34ffa52a49d0fedcb46bece50c920fd56af4f0472494419bfa5e3cb40abda335b3e9c11466c42273f125b50d204b4604798 xmlsec-1_2_27.tar.gz"
diff --git a/community/xmlsec/libressl-2.7.patch b/community/xmlsec/libressl-2.7.patch
deleted file mode 100644
index 9a8240204d..0000000000
--- a/community/xmlsec/libressl-2.7.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/configure.ac b/configure.ac
-index 3278200..0fe3a76 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -489,7 +489,7 @@ if test "z$OPENSSL_FOUND" = "zyes" -a "z$OPENSSL_VERSION" = "z" ; then
- if test "z$OPENSSL_VERSION" = "z" ; then
- AC_EGREP_CPP(yes,[
- #include <openssl/opensslv.h>
-- #if OPENSSL_VERSION_NUMBER == 0x20000000L && defined(LIBRESSL_VERSION_NUMBER)
-+ #if OPENSSL_VERSION_NUMBER == 0x20000000L && defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x2070000fL
- yes
- #endif
- ],[
-diff --git a/include/xmlsec/openssl/crypto.h b/include/xmlsec/openssl/crypto.h
-index 96cc65b..353a2dd 100644
---- a/include/xmlsec/openssl/crypto.h
-+++ b/include/xmlsec/openssl/crypto.h
-@@ -43,7 +43,7 @@ XMLSEC_CRYPTO_EXPORT const xmlChar* xmlSecOpenSSLGetDefaultTrustedCertsFolde
- * What version of the openssl API do we have? (also see configure.ac)
- *
- *******************************************************************/
--#if OPENSSL_VERSION_NUMBER == 0x20000000L && defined(LIBRESSL_VERSION_NUMBER)
-+#if OPENSSL_VERSION_NUMBER == 0x20000000L && defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x2070000fL
- /* Libressl decided to take over OpenSSL version 2.0.0, likely will create
- * issues down the road...
- */