aboutsummaryrefslogtreecommitdiffstats
path: root/community/xpra
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-11-07 09:15:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-11-07 09:16:24 +0000
commit2fede04b90d6267174762594d21ebc80bbaae4ea (patch)
tree5f95a31fa794401868d6a1601c30fece80c12ef9 /community/xpra
parent5e4fa9c724ca1c6734a57daa1725002c3f3cdc46 (diff)
downloadaports-2fede04b90d6267174762594d21ebc80bbaae4ea.tar.bz2
aports-2fede04b90d6267174762594d21ebc80bbaae4ea.tar.xz
community/xpra: fix build on 32bit non-x86
Simply drop setting -mfpmath=387 complie flag
Diffstat (limited to 'community/xpra')
-rw-r--r--community/xpra/APKBUILD9
-rw-r--r--community/xpra/avoid-x86-only-compile-flags.patch17
2 files changed, 23 insertions, 3 deletions
diff --git a/community/xpra/APKBUILD b/community/xpra/APKBUILD
index 1dd4b7b69f..719ae3aec7 100644
--- a/community/xpra/APKBUILD
+++ b/community/xpra/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=xpra
pkgver=3.0.2
-pkgrel=0
+pkgrel=1
pkgdesc="Xpra is 'screen for X' & allows you to run X programs, usually on a remote host over SSH or encrypted tcp"
url="https://xpra.org"
# !armhf !armv7: Requires dependencies to be rebuilt
@@ -65,7 +65,9 @@ makedepends="
"
subpackages="$pkgname-openrc $pkgname-doc $pkgname-tests::noarch $pkgname-webclient::noarch"
options="!check"
-source="https://xpra.org/src/xpra-$pkgver.tar.xz"
+source="https://xpra.org/src/xpra-$pkgver.tar.xz
+ avoid-x86-only-compile-flags.patch
+ "
build() {
# https://www.xpra.org/trac/ticket/1080
@@ -101,4 +103,5 @@ webclient() {
cp -rf usr/share/xpra/www "$subpkgdir"/usr/share/xpra/
}
-sha512sums="115f606ff5886d99a906f318cb1a7a4a86e80ebf23e4336e67938267d92ef624de577cc8fc06c6ce541b7c44a0cef58d930b5928f32e24dfc67c72127c7b623c xpra-3.0.2.tar.xz"
+sha512sums="115f606ff5886d99a906f318cb1a7a4a86e80ebf23e4336e67938267d92ef624de577cc8fc06c6ce541b7c44a0cef58d930b5928f32e24dfc67c72127c7b623c xpra-3.0.2.tar.xz
+249028f61d20ee8c8378f9cebe13c6e0f288c7635eb66be44e20fef9af023266e1266a893cd4ce56dd7714ac1eb851be59cea5733fb8fc787e4b92e4f10c2a16 avoid-x86-only-compile-flags.patch"
diff --git a/community/xpra/avoid-x86-only-compile-flags.patch b/community/xpra/avoid-x86-only-compile-flags.patch
new file mode 100644
index 0000000000..0f6c5871aa
--- /dev/null
+++ b/community/xpra/avoid-x86-only-compile-flags.patch
@@ -0,0 +1,17 @@
+diff --git a/setup.py b/setup.py
+index 57c2d63..c896c62 100755
+--- a/setup.py
++++ b/setup.py
+@@ -1737,9 +1737,9 @@ membuffers_c = [memalign_c, buffers_c, xxhash_c]
+ if modules_ENABLED:
+ add_packages("xpra.buffers")
+ buffers_pkgconfig = pkgconfig(optimize=3)
+- if BITS==32:
+- #this may well be sub-optimal:
+- add_to_keywords(buffers_pkgconfig, "extra_compile_args", "-mfpmath=387")
++# if BITS==32:
++# #this may well be sub-optimal:
++# add_to_keywords(buffers_pkgconfig, "extra_compile_args", "-mfpmath=387")
+ if cython_ENABLED:
+ cython_add(Extension("xpra.buffers.membuf",
+ ["xpra/buffers/membuf.pyx"]+membuffers_c, **buffers_pkgconfig))