aboutsummaryrefslogtreecommitdiffstats
path: root/community/xrefresh/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-24 19:04:38 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-24 23:54:15 -0300
commite402c6a5cc6bcc65194e19524ede21938714d9e5 (patch)
tree8112f38cd3d094bb6a4ee9af9d4ff7501c9bc59a /community/xrefresh/APKBUILD
parentd03ae81672936c01621f13b69998cf1adc251e9f (diff)
downloadaports-e402c6a5cc6bcc65194e19524ede21938714d9e5.tar.bz2
aports-e402c6a5cc6bcc65194e19524ede21938714d9e5.tar.xz
community/xrefresh: move from main
Diffstat (limited to 'community/xrefresh/APKBUILD')
-rw-r--r--community/xrefresh/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/xrefresh/APKBUILD b/community/xrefresh/APKBUILD
new file mode 100644
index 0000000000..b19c8e2b61
--- /dev/null
+++ b/community/xrefresh/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xrefresh
+pkgver=1.0.6
+pkgrel=0
+pkgdesc="refresh all or part of an X screen"
+url="http://xorg.freedesktop.org"
+arch="all"
+license="MIT"
+subpackages="$pkgname-doc"
+depends=
+makedepends="libx11-dev"
+source="https://www.x.org/releases/individual/app/$pkgname-$pkgver.tar.bz2"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="361e97fecfc2706d5eeab69df0d4dd4baa55b6783cfddabf51d8561b7c930d71ce6c217e0512c6564208d69b04f89c69ea8c0bfb2e4f6cc25b062b55e4db3674 xrefresh-1.0.6.tar.bz2"