aboutsummaryrefslogtreecommitdiffstats
path: root/community/xsetmode
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-24 19:03:46 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-24 23:54:15 -0300
commit6249f1b7881d2c63c2b6549c79b8f65b394333eb (patch)
treee602b14fa5de89f6582072e632ca2492aa3001ca /community/xsetmode
parent931d5d47a3a905f537d0a7a9cee37a3a287c4ef4 (diff)
downloadaports-6249f1b7881d2c63c2b6549c79b8f65b394333eb.tar.bz2
aports-6249f1b7881d2c63c2b6549c79b8f65b394333eb.tar.xz
community/xsetmode: move from main
Diffstat (limited to 'community/xsetmode')
-rw-r--r--community/xsetmode/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/xsetmode/APKBUILD b/community/xsetmode/APKBUILD
new file mode 100644
index 0000000000..5c36bbc8f2
--- /dev/null
+++ b/community/xsetmode/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xsetmode
+pkgver=1.0.0
+pkgrel=4
+pkgdesc="set the mode for an X Input device"
+url="http://xorg.freedesktop.org/"
+arch="all"
+license="custom"
+subpackages="$pkgname-doc"
+depends=
+makedepends="libxi-dev libx11-dev"
+source="https://www.x.org/releases/individual/app/$pkgname-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+sha512sums="a3c1c5e85a0cec35a7db10a57eece07691c0bec79b93987ec4417ebf71544ddffbb4832f78ef524bfcd149beb9852295a2de6a2ccec481cd6eea5633e090abfb xsetmode-1.0.0.tar.bz2"