aboutsummaryrefslogtreecommitdiffstats
path: root/community/xsetroot
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-24 19:02:55 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-24 23:29:30 -0300
commit22de55c60502db6c90cc14bc06e7b79cfce96936 (patch)
tree3c9c4213d91505d38b0ee5b1bc9eb5dea3997733 /community/xsetroot
parent993da571b08066cb67f9193df330207c802e3f1d (diff)
downloadaports-22de55c60502db6c90cc14bc06e7b79cfce96936.tar.bz2
aports-22de55c60502db6c90cc14bc06e7b79cfce96936.tar.xz
community/xsetroot: move from main
Diffstat (limited to 'community/xsetroot')
-rw-r--r--community/xsetroot/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/xsetroot/APKBUILD b/community/xsetroot/APKBUILD
new file mode 100644
index 0000000000..30e27d6d80
--- /dev/null
+++ b/community/xsetroot/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xsetroot
+pkgver=1.1.2
+pkgrel=0
+pkgdesc="X.Org xsetroot application"
+url="http://xorg.freedesktop.org"
+arch="all"
+license="MIT"
+subpackages="$pkgname-doc"
+depends=""
+makedepends="libx11-dev libxmu-dev libxcursor-dev xbitmaps util-macros"
+source="https://www.x.org/releases/individual/app/$pkgname-$pkgver.tar.bz2"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make -C "$builddir" check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="0b9df1b72305e5c24f1e1664578aa4411a5ffcdc5d318458117594e641f01c34700205b0d16c08abf4a8106d36128ccdbe1ea1f1035fce9018d6b52801a8b72b xsetroot-1.1.2.tar.bz2"