aboutsummaryrefslogtreecommitdiffstats
path: root/community/xxhash
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-14 23:52:58 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-15 14:32:52 -0300
commite2d17670742435b2474980d0011b15bb1018c37d (patch)
tree24d54463d789369c625ade1087507e1d4e916f82 /community/xxhash
parente2bce14c748aacb867713cb81a91fad6e8e7f7f6 (diff)
downloadaports-e2d17670742435b2474980d0011b15bb1018c37d.tar.bz2
aports-e2d17670742435b2474980d0011b15bb1018c37d.tar.xz
community/xxhash: use XXH_FORCE_MEMORY_ACCESS
Diffstat (limited to 'community/xxhash')
-rw-r--r--community/xxhash/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/community/xxhash/APKBUILD b/community/xxhash/APKBUILD
index 346ffc7f82..2c71800d9d 100644
--- a/community/xxhash/APKBUILD
+++ b/community/xxhash/APKBUILD
@@ -6,7 +6,7 @@ _pkgname=xxHash
pkgver=0.7.0
_pypkg=python-xxhash
_pyver=1.3.0
-pkgrel=0
+pkgrel=1
pkgdesc="Extremely fast non-cryptographic hash algorithm"
url="http://www.xxhash.com"
arch="all"
@@ -21,6 +21,7 @@ builddir="$srcdir/"$_pkgname-$pkgver
_pybuilddir="$srcdir/"$_pypkg-$_pyver
build() {
+ export CFLAGS="$CFLAGS -DXXH_FORCE_MEMORY_ACCESS=1"
sed -i 's|--leak-check=yes|-v --leak-check=full --show-leak-kinds=all|' Makefile
make