aboutsummaryrefslogtreecommitdiffstats
path: root/community/yelp-tools
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-11-19 14:50:33 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-11-19 15:12:33 +0000
commit6956d360f25458ab11442058c0c793c5529898e2 (patch)
tree8da4074dee42059a3da5174c875e39391f3797b9 /community/yelp-tools
parent66aaa088a428332cd4b26ffcbbce63adc21fe5a9 (diff)
downloadaports-6956d360f25458ab11442058c0c793c5529898e2.tar.bz2
aports-6956d360f25458ab11442058c0c793c5529898e2.tar.xz
community/yelp-*: move from main
Diffstat (limited to 'community/yelp-tools')
-rw-r--r--community/yelp-tools/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/community/yelp-tools/APKBUILD b/community/yelp-tools/APKBUILD
new file mode 100644
index 0000000000..e99975eab2
--- /dev/null
+++ b/community/yelp-tools/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Alan Lacerda <alacerda@alpinelinux.org>
+# Maintainer: Alan Lacerda <alacerda@alpinelinux.org>
+pkgname=yelp-tools
+pkgver=3.16.1
+pkgrel=0
+pkgdesc="Small programs that help you create, edit, manage, and publish your Mallard or DocBook documentation."
+url="https://wiki.gnome.org/Apps/Yelp/Tools"
+arch="noarch"
+license="GPL/LGPL"
+depends=""
+depends_dev=""
+makedepends="gawk yelp-xsl itstool libxml2-utils libxslt"
+install=""
+subpackages=""
+source="https://download.gnome.org/sources/yelp-tools/${pkgver%.*}/yelp-tools-$pkgver.tar.xz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums="2430db2d69241d217fe0af5c1458aa30 yelp-tools-3.16.1.tar.xz"
+sha256sums="b4f66c145af1c6448dc51037d305d6844da13dc31d07729b8e29005ee4fef89c yelp-tools-3.16.1.tar.xz"
+sha512sums="5fbb2b5b907bdffc7ccf0a108a80c7fe1e5486be6774b3d799f10e3444e286fcf8055629fe7df22ae8ef5784e52133df1b8dca6ee13fa3c2191080e14546d956 yelp-tools-3.16.1.tar.xz"