aboutsummaryrefslogtreecommitdiffstats
path: root/community/yelp-tools
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-07-28 01:43:43 +0000
committerJakub Jirutka <jakub@jirutka.cz>2017-07-28 23:17:11 +0200
commitd2121e936b7d5f1415617901e55dd5c7bda5b970 (patch)
treed2eb18722aae7165e599fc430b2410739a3de219 /community/yelp-tools
parent73b14537fb81d1de728f1790e3fcc97d7d8b88f3 (diff)
downloadaports-d2121e936b7d5f1415617901e55dd5c7bda5b970.tar.bz2
aports-d2121e936b7d5f1415617901e55dd5c7bda5b970.tar.xz
community/yelp-tools: modernize APKBUILD
Diffstat (limited to 'community/yelp-tools')
-rw-r--r--community/yelp-tools/APKBUILD33
1 files changed, 8 insertions, 25 deletions
diff --git a/community/yelp-tools/APKBUILD b/community/yelp-tools/APKBUILD
index 3dc17dee57..c70437f54a 100644
--- a/community/yelp-tools/APKBUILD
+++ b/community/yelp-tools/APKBUILD
@@ -3,43 +3,26 @@
pkgname=yelp-tools
pkgver=3.18.0
pkgrel=0
-pkgdesc="Small programs that help you create, edit, manage, and publish your Mallard or DocBook documentation."
+pkgdesc="Small programs that help you create, edit, manage, and publish your Mallard or DocBook documentation"
url="https://wiki.gnome.org/Apps/Yelp/Tools"
arch="noarch"
license="GPL/LGPL"
-depends=""
-depends_dev=""
makedepends="gawk yelp-xsl itstool libxml2-utils libxslt"
-install=""
-subpackages=""
-source="https://download.gnome.org/sources/yelp-tools/${pkgver%.*}/yelp-tools-$pkgver.tar.xz"
-
-_builddir="$srcdir/$pkgname-$pkgver"
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+source="https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
- --prefix=/usr \
- || return 1
- make || return 1
+ --prefix=/usr
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="${pkgdir}" install || return 1
+ cd "$builddir"
+ make DESTDIR="${pkgdir}" install
}
-md5sums="ceca436ff2ab3900dde718c0f0286f3f yelp-tools-3.18.0.tar.xz"
-sha256sums="c6c1d65f802397267cdc47aafd5398c4b60766e0a7ad2190426af6c0d0716932 yelp-tools-3.18.0.tar.xz"
sha512sums="75957b06bdade966a33a41ecc68dfa3eb3b3e3550dc8c6664ee694c4b043c8b45a2403dd23c9810347ed7234ceb5389a34133554de012a7e0afc5db891525fb8 yelp-tools-3.18.0.tar.xz"