aboutsummaryrefslogtreecommitdiffstats
path: root/community/yelp-tools
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-01 12:31:16 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-01 21:09:12 +0000
commit7ad8566fb4a75bec6d0883c17f620a08d7b8384e (patch)
tree56cbc5dac5c74f4ac5bdc785651f858e7173ce5f /community/yelp-tools
parentd9a7d17cd19489dbf3de9f1e0ad9e6e2accd1817 (diff)
downloadaports-7ad8566fb4a75bec6d0883c17f620a08d7b8384e.tar.bz2
aports-7ad8566fb4a75bec6d0883c17f620a08d7b8384e.tar.xz
community/yelp-tools: run autoreconf in prepare() not build()
Closes GH-8362
Diffstat (limited to 'community/yelp-tools')
-rw-r--r--community/yelp-tools/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/community/yelp-tools/APKBUILD b/community/yelp-tools/APKBUILD
index 7a83872fba..4dbf407085 100644
--- a/community/yelp-tools/APKBUILD
+++ b/community/yelp-tools/APKBUILD
@@ -10,8 +10,12 @@ license="GPL-2.0-or-later"
makedepends="autoconf-archive automake gawk yelp-xsl itstool libxml2-utils libxslt"
source="https://download.gnome.org/sources/yelp-tools/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
-build() {
+prepare() {
+ default_prepare
autoreconf --force --install --verbose
+}
+
+build() {
./configure \
--build=$CBUILD \
--host=$CHOST \