aboutsummaryrefslogtreecommitdiffstats
path: root/community/yubico-c
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-04-29 00:15:59 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-04-29 00:15:59 +0200
commita6c38746492018053059742ec37860eab33a515e (patch)
tree13ce795fdf0de6658bbd9061089ffcd9085417cf /community/yubico-c
parent397b9a65ad6c7cd0981d651a5e9c6bb15a2a69c8 (diff)
downloadaports-a6c38746492018053059742ec37860eab33a515e.tar.bz2
aports-a6c38746492018053059742ec37860eab33a515e.tar.xz
community/yubico-c: move from testing
Diffstat (limited to 'community/yubico-c')
-rw-r--r--community/yubico-c/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/community/yubico-c/APKBUILD b/community/yubico-c/APKBUILD
new file mode 100644
index 0000000000..a3e7af4fac
--- /dev/null
+++ b/community/yubico-c/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=yubico-c
+pkgver=1.13
+pkgrel=0
+pkgdesc="YubiKey C low-level library"
+url="https://developers.yubico.com/yubico-c/"
+arch="all"
+license="BSD-2-Clause"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
+source="https://developers.yubico.com/$pkgname/Releases/libyubikey-$pkgver.tar.gz"
+builddir="$srcdir/libyubikey-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+tools() {
+ pkgdesc="$pkgdesc (CLI tools)"
+
+ mkdir -p "$subpkgdir"/usr/
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+}
+
+sha512sums="28f45cb9817c30a70d168ae507d3f8014051058d730eed92b31d92e96784138dea291bda4275511c5f92a6427cb4249d76c802b8abb867cec50e62fb770950f2 libyubikey-1.13.tar.gz"