aboutsummaryrefslogtreecommitdiffstats
path: root/community/yubico-pam
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-03-01 23:44:41 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-03-02 01:24:45 -0300
commitc2f9bbeaa0076931d6f83f2b6d5df3f6f513fd96 (patch)
treedf3e6184f42ac76f6351b67c9806262b86d27400 /community/yubico-pam
parent84c17434ff10895762264f6843b1889bd9769091 (diff)
downloadaports-c2f9bbeaa0076931d6f83f2b6d5df3f6f513fd96.tar.bz2
aports-c2f9bbeaa0076931d6f83f2b6d5df3f6f513fd96.tar.xz
community/yubico-pam: move from testing
Diffstat (limited to 'community/yubico-pam')
-rw-r--r--community/yubico-pam/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/yubico-pam/APKBUILD b/community/yubico-pam/APKBUILD
new file mode 100644
index 0000000000..379fbb9298
--- /dev/null
+++ b/community/yubico-pam/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=yubico-pam
+pkgver=2.26
+pkgrel=1
+pkgdesc="Yubico Pluggable Authentication Module (PAM)"
+url="https://developers.yubico.com/yubico-pam"
+arch="all"
+license="BSD-2-Clause"
+makedepends="linux-pam-dev yubico-c-dev yubico-c-client-dev ykpers-dev"
+options="!check" # need yubikey plugged in on live machine
+subpackages="$pkgname-doc"
+source="https://developers.yubico.com/yubico-pam/Releases/pam_yubico-$pkgver.tar.gz"
+builddir="$srcdir/pam_yubico-$pkgver"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --with-pam-dir=/lib/security
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="4adba37f07e1fe1a2c4b534246ef0e862be76e3b1ce0ed6f11f15436f537cd5963f00abf48f6faa7e65b025ff6924dbaf918db1675b1e2cb89a802d2f2d6a4ec pam_yubico-2.26.tar.gz"