aboutsummaryrefslogtreecommitdiffstats
path: root/community/zenity
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-11-16 14:04:05 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-11-16 14:04:05 +0000
commit6d609cbf93eb119011771914f80d435a39d524ad (patch)
treee7282c09a48c42ef3519bb74abf5fd80305ada76 /community/zenity
parent78f76330d65c03e779ac1f139780b90bdb58534c (diff)
downloadaports-6d609cbf93eb119011771914f80d435a39d524ad.tar.bz2
aports-6d609cbf93eb119011771914f80d435a39d524ad.tar.xz
community/zenity: move from main
Diffstat (limited to 'community/zenity')
-rw-r--r--community/zenity/APKBUILD51
-rw-r--r--community/zenity/zenity-2.32.1-libnotify-0.7.patch27
2 files changed, 78 insertions, 0 deletions
diff --git a/community/zenity/APKBUILD b/community/zenity/APKBUILD
new file mode 100644
index 0000000000..46232bca27
--- /dev/null
+++ b/community/zenity/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=zenity
+pkgver=3.18.1.1
+pkgrel=0
+pkgdesc="A GTK+-based xdialog replacement"
+url="http://www.gnome.org/"
+arch="all"
+license="GPL2+"
+depends=
+makedepends="gtk+3.0-dev intltool libxml2-utils libnotify-dev itstool"
+install=""
+subpackages="$pkgname-lang $pkgname-doc"
+case $pkgver in
+*.*.*.*) _v=${pkgver%.*.*};;
+*.*.*) _v=${pkgver%.*};;
+*.*) _v=$pkgver;;
+esac
+source="http://ftp.gnome.org/pub/GNOME/sources/${pkgname}/${_v}/${pkgname}-${pkgver}.tar.xz
+ "
+
+_builddir="${srcdir}/${pkgname}-${pkgver}"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="b1604dd12eefd6f7a0976cfeec3a6690 zenity-3.18.1.1.tar.xz"
+sha256sums="e6317a03f58b528e2e3330fef5acea39506ec08a7c2aeec5c4f1e7505d43a80a zenity-3.18.1.1.tar.xz"
+sha512sums="fdadf8ed4e135d24401bcd17121f10681e12572391d843f6510347a6c9c568e23e0ff7fb3f80f0bbc0ffd6698b149faac547c1b99ac423229e6f491e2751e06a zenity-3.18.1.1.tar.xz"
diff --git a/community/zenity/zenity-2.32.1-libnotify-0.7.patch b/community/zenity/zenity-2.32.1-libnotify-0.7.patch
new file mode 100644
index 0000000000..8b7fee738e
--- /dev/null
+++ b/community/zenity/zenity-2.32.1-libnotify-0.7.patch
@@ -0,0 +1,27 @@
+--- ./src/notification.c
++++ ./src/notification.c
+@@ -30,6 +30,9 @@
+
+ #ifdef HAVE_LIBNOTIFY
+ #include <libnotify/notify.h>
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
+ #endif
+
+ #include "zenity.h"
+@@ -184,10 +187,14 @@
+ icon = freeme = g_filename_to_uri (icon_file, NULL, NULL);
+ }
+
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ /* notify_notification_new_with_status_icon was removed */
++#else
+ notif = notify_notification_new_with_status_icon (
+ message[0] /* title */,
+ message[1] /* summary */,
+ icon, status_icon);
++#endif
+
+ g_strfreev (message);
+ g_free (freeme);