aboutsummaryrefslogtreecommitdiffstats
path: root/community/zfs-auto-snapshot
diff options
context:
space:
mode:
authorHenrik Riomar <henrik.riomar@gmail.com>2020-01-13 22:54:06 +0100
committerHenrik Riomar <henrik.riomar@gmail.com>2020-01-13 22:54:06 +0100
commitb2d5012ef28fc77dfb93f4b36d76dfc0edfb4758 (patch)
treecf87e2b4fe8e490fbe530fde8c26f3582c95633b /community/zfs-auto-snapshot
parent491217be0f20e2be367e0c9117f18f25d6edf6f3 (diff)
downloadaports-b2d5012ef28fc77dfb93f4b36d76dfc0edfb4758.tar.bz2
aports-b2d5012ef28fc77dfb93f4b36d76dfc0edfb4758.tar.xz
community/zfs-auto-snapshot: move from testing
Diffstat (limited to 'community/zfs-auto-snapshot')
-rw-r--r--community/zfs-auto-snapshot/0001-alpine.patch40
-rw-r--r--community/zfs-auto-snapshot/APKBUILD27
2 files changed, 67 insertions, 0 deletions
diff --git a/community/zfs-auto-snapshot/0001-alpine.patch b/community/zfs-auto-snapshot/0001-alpine.patch
new file mode 100644
index 0000000000..3befcf4386
--- /dev/null
+++ b/community/zfs-auto-snapshot/0001-alpine.patch
@@ -0,0 +1,40 @@
+--- zfs-auto-snapshot-upstream-1.2.4/Makefile
++++ zfs-auto-snapshot-upstream-1.2.4-alpine/Makefile
+@@ -3,16 +3,16 @@
+ all:
+
+ install:
+- install -d $(DESTDIR)/etc/cron.d
+- install -d $(DESTDIR)/etc/cron.daily
+- install -d $(DESTDIR)/etc/cron.hourly
+- install -d $(DESTDIR)/etc/cron.weekly
+- install -d $(DESTDIR)/etc/cron.monthly
+- install -m 0644 etc/zfs-auto-snapshot.cron.frequent $(DESTDIR)/etc/cron.d/zfs-auto-snapshot
+- install etc/zfs-auto-snapshot.cron.hourly $(DESTDIR)/etc/cron.hourly/zfs-auto-snapshot
+- install etc/zfs-auto-snapshot.cron.daily $(DESTDIR)/etc/cron.daily/zfs-auto-snapshot
+- install etc/zfs-auto-snapshot.cron.weekly $(DESTDIR)/etc/cron.weekly/zfs-auto-snapshot
+- install etc/zfs-auto-snapshot.cron.monthly $(DESTDIR)/etc/cron.monthly/zfs-auto-snapshot
++ install -d $(DESTDIR)/etc/periodic/15min
++ install -d $(DESTDIR)/etc/periodic/daily
++ install -d $(DESTDIR)/etc/periodic/hourly
++ install -d $(DESTDIR)/etc/periodic/weekly
++ install -d $(DESTDIR)/etc/periodic/monthly
++ install -m 0755 etc/zfs-auto-snapshot.cron.frequent $(DESTDIR)/etc/periodic/15min/zfs-auto-snapshot
++ install etc/zfs-auto-snapshot.cron.hourly $(DESTDIR)/etc/periodic/hourly/zfs-auto-snapshot
++ install etc/zfs-auto-snapshot.cron.daily $(DESTDIR)/etc/periodic/daily/zfs-auto-snapshot
++ install etc/zfs-auto-snapshot.cron.weekly $(DESTDIR)/etc/periodic/weekly/zfs-auto-snapshot
++ install etc/zfs-auto-snapshot.cron.monthly $(DESTDIR)/etc/periodic/monthly/zfs-auto-snapshot
+ install -d $(DESTDIR)$(PREFIX)/share/man/man8
+ install src/zfs-auto-snapshot.8 $(DESTDIR)$(PREFIX)/share/man/man8/zfs-auto-snapshot.8
+ install -d $(DESTDIR)$(PREFIX)/sbin
+--- zfs-auto-snapshot-upstream-1.2.4/etc/zfs-auto-snapshot.cron.frequent
++++ zfs-auto-snapshot-upstream-1.2.4-alpine/etc/zfs-auto-snapshot.cron.frequent
+@@ -1,3 +1,6 @@
+-PATH="/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin"
++#!/bin/sh
+
+-*/15 * * * * root which zfs-auto-snapshot > /dev/null || exit 0 ; zfs-auto-snapshot --quiet --syslog --label=frequent --keep=4 //
++# Only call zfs-auto-snapshot if it's available
++which zfs-auto-snapshot > /dev/null || exit 0
++
++exec zfs-auto-snapshot --quiet --syslog --label=frequent --keep=4 //
diff --git a/community/zfs-auto-snapshot/APKBUILD b/community/zfs-auto-snapshot/APKBUILD
new file mode 100644
index 0000000000..433f13df51
--- /dev/null
+++ b/community/zfs-auto-snapshot/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Henrik Riomar <henrik.riomar@gmail.com>
+# Maintainer: Henrik Riomar <henrik.riomar@gmail.com>
+pkgname=zfs-auto-snapshot
+pkgver=1.2.4
+pkgrel=1
+pkgdesc="ZFS Automatic Snapshot Service for Linux"
+url="https://github.com/zfsonlinux/zfs-auto-snapshot"
+arch="noarch !armhf !armv7" # limited by zfs
+license="GPL-2.0-or-later"
+depends="zfs"
+checkdepends="checkbashisms"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/zfsonlinux/zfs-auto-snapshot/archive/upstream/$pkgver.tar.gz
+ 0001-alpine.patch
+ "
+builddir="$srcdir/$pkgname-upstream-$pkgver"
+
+check() {
+ checkbashisms src/zfs-auto-snapshot.sh
+}
+
+package() {
+ make install PREFIX="/usr" DESTDIR="$pkgdir"
+}
+
+sha512sums="26382303fce8b90dfb40f69fcab92308e88c17c147b4a566c5d32f2e9aa241d64f5da56ad82b4becb824ba01a470037a724460d35676a1d46de9c578c02a57d9 zfs-auto-snapshot-1.2.4.tar.gz
+76733b98a168fa0a09452809aad5e1079cf789e5c96f5ced590b3e8d609c26b2fedc38ca0b406544825cd509f259df8e917d4b1355f8bea9942b0ca0ba872eba 0001-alpine.patch"