aboutsummaryrefslogtreecommitdiffstats
path: root/community/zxing-cpp/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-11-01 11:00:11 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-01 07:31:04 -0300
commitd9a0b8c73e7e829998eef85bf9f63d94a1fda2cb (patch)
tree2e668c0cb88f30bd136681da5090b32caad056ed /community/zxing-cpp/APKBUILD
parentd44a428354898bd88f7367c2867cded5cab2c1b6 (diff)
downloadaports-d9a0b8c73e7e829998eef85bf9f63d94a1fda2cb.tar.bz2
aports-d9a0b8c73e7e829998eef85bf9f63d94a1fda2cb.tar.xz
community/zxing-cpp: move from testing
Diffstat (limited to 'community/zxing-cpp/APKBUILD')
-rw-r--r--community/zxing-cpp/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/zxing-cpp/APKBUILD b/community/zxing-cpp/APKBUILD
new file mode 100644
index 0000000000..39d27fe517
--- /dev/null
+++ b/community/zxing-cpp/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=zxing-cpp
+pkgver=1.0.7
+pkgrel=0
+arch="all"
+url="https://github.com/nu-book/zxing-cpp"
+pkgdesc="C++ port of ZXing"
+license="Apache-2.0"
+makedepends="cmake"
+source="$pkgname-$pkgver.tar.gz::https://github.com/nu-book/zxing-cpp/archive/v$pkgver.tar.gz"
+subpackages="$pkgname-dev"
+options="!check" # No tests
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBRARY=ON
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="e6597157099e478c2afad413e8dc3347369aef6e1a76cff331c4d71f178be97dde23e8fe89c7147eab034e2aecf1660a66e2a951f60c32d2fb67635033c1a0c8 zxing-cpp-1.0.7.tar.gz"