aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-02-25 07:13:06 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-02-25 08:40:33 +0000
commit1a4fb600a6af6e163257ad422b00f890a8f62b66 (patch)
tree5be3f5587b3fc8b4bdec41125bc53b9eb4a41e90 /community
parent5db940af6587abdb7e3ca4d226ed0fec79773a88 (diff)
downloadaports-1a4fb600a6af6e163257ad422b00f890a8f62b66.tar.bz2
aports-1a4fb600a6af6e163257ad422b00f890a8f62b66.tar.xz
community/chromium: fix build on aarch64
Diffstat (limited to 'community')
-rw-r--r--community/chromium/APKBUILD8
-rw-r--r--community/chromium/aarch64-fixes.patch37
-rw-r--r--community/chromium/chromium-71.0.3578.98-skia-aarch64-buildfix.patch21
3 files changed, 64 insertions, 2 deletions
diff --git a/community/chromium/APKBUILD b/community/chromium/APKBUILD
index fa2f4034a2..27f8d90179 100644
--- a/community/chromium/APKBUILD
+++ b/community/chromium/APKBUILD
@@ -5,7 +5,7 @@ pkgver=72.0.3626.109
pkgrel=0
pkgdesc="chromium web browser"
url="http://www.chromium.org/"
-arch="x86_64 armv7" # aarch64 temp disable due to build failure
+arch="x86_64 armv7 aarch64"
license="BSD"
depends="xdg-utils"
depends_dev=""
@@ -108,6 +108,8 @@ source="https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
gcc-fno-delete-null-pointer-checks.patch
gcc-arm.patch
musl-arm-limits.patch
+ chromium-71.0.3578.98-skia-aarch64-buildfix.patch
+ aarch64-fixes.patch
"
builddir="$srcdir"/$pkgname-$pkgver
@@ -353,4 +355,6 @@ db7f676d3476820c29f234b1f8f17a74e82b72d67fc727c715307734fd238e3cb0f99d8b5320d45f
9bfc532fd1e84e30362ac41fcd68253e17ee4cb5e986ceb5bb122e3235e4617e295ce9dddfdfbbd0b9d3e67267096152da2a19e3bb4bb9111c7fdb22fa398872 gcc8-alignof.patch
bb0f3dc1ade429a398d487ae190a278948533398c4a1085aeb35ff57fefb90a1e598008ba839423ca0acd30ba4c992950f395dba3b9994d3c7187fe68b9a93d7 gcc-fno-delete-null-pointer-checks.patch
9f4a555b98ca47063fd5a90d119686de09d5c8ecdec2ef936f42cf45d3ba012e91a6455d3d550b3c90da15ca9b085238afd442a21ce47bea571ff356b74620f8 gcc-arm.patch
-3bcffb36f28a01d8bb91f1c1ee1e327caebb1e139d4e8772ad15460ee69cb5ea3307a235dc83184a9e09b687882d9617f3a3ce1a7b07cbd6e11b0a5d6a6ace81 musl-arm-limits.patch"
+3bcffb36f28a01d8bb91f1c1ee1e327caebb1e139d4e8772ad15460ee69cb5ea3307a235dc83184a9e09b687882d9617f3a3ce1a7b07cbd6e11b0a5d6a6ace81 musl-arm-limits.patch
+d4d46ea95ed8d47cd4b09f27d99df61cc6b72b4cb92b865310f245259d5adf02cd136888cd44ad12aeba3fd4d638982437fdf230e817d0188cc5ea76fec82cd1 chromium-71.0.3578.98-skia-aarch64-buildfix.patch
+229a0c04ebd7465fabe3268959c386e63ac9e272a0506bb65785f6f9532a9f88bee436287fbcfc63e5fd9d85fb4f68f73a79475b6e6cc53dc58d715d40cd0ed2 aarch64-fixes.patch"
diff --git a/community/chromium/aarch64-fixes.patch b/community/chromium/aarch64-fixes.patch
new file mode 100644
index 0000000000..589cabe0bb
--- /dev/null
+++ b/community/chromium/aarch64-fixes.patch
@@ -0,0 +1,37 @@
+diff --git a/third_party/swiftshader/third_party/llvm-7.0/BUILD.gn b/third_party/swiftshader/third_party/llvm-7.0/BUILD.gn
+index 744b0eb..32ff5a8 100644
+--- ./third_party/swiftshader/third_party/llvm-7.0/BUILD.gn
++++ ./third_party/swiftshader/third_party/llvm-7.0/BUILD.gn
+@@ -55,7 +55,10 @@ config("swiftshader_llvm_private_config") {
+ }
+
+ if (is_clang) {
+- cflags += [ "-Wno-header-hygiene" ]
++ cflags += [
++ "-Wno-header-hygiene",
++ "-Wno-error=header-hygiene",
++ ]
+ if (target_cpu == "x86" || target_cpu == "x64") {
+ cflags += [ "-msse2" ]
+ }
+@@ -70,7 +73,6 @@ config("swiftshader_llvm_private_config") {
+ "-Wno-unused-private-field",
+ "-Wno-unused-result",
+ "-Wno-unused-variable",
+- "-Wno-error=header-hygiene",
+ ]
+
+ defines = [
+diff --git a/third_party/swiftshader/third_party/llvm-7.0/configs/linux/include/llvm/Config/config.h b/third_party/swiftshader/third_party/llvm-7.0/configs/linux/include/llvm/Config/config.h
+index ff20611..ec22982 100644
+--- ./third_party/swiftshader/third_party/llvm-7.0/configs/linux/include/llvm/Config/config.h
++++ ./third_party/swiftshader/third_party/llvm-7.0/configs/linux/include/llvm/Config/config.h
+@@ -122,7 +122,7 @@
+ /* #undef HAVE_MALLCTL */
+
+ /* Define to 1 if you have the `mallinfo' function. */
+-#define HAVE_MALLINFO 1
++// #define HAVE_MALLINFO 1
+
+ /* Define to 1 if you have the <malloc.h> header file. */
+ #define HAVE_MALLOC_H 1
diff --git a/community/chromium/chromium-71.0.3578.98-skia-aarch64-buildfix.patch b/community/chromium/chromium-71.0.3578.98-skia-aarch64-buildfix.patch
new file mode 100644
index 0000000000..15260a53b9
--- /dev/null
+++ b/community/chromium/chromium-71.0.3578.98-skia-aarch64-buildfix.patch
@@ -0,0 +1,21 @@
+diff -up chromium-71.0.3578.98/third_party/skia/src/opts/SkRasterPipeline_opts.h.aarch64fix chromium-71.0.3578.98/third_party/skia/src/opts/SkRasterPipeline_opts.h
+--- third_party/skia/src/opts/SkRasterPipeline_opts.h.aarch64fix 2018-12-14 11:17:43.249121756 -0500
++++ third_party/skia/src/opts/SkRasterPipeline_opts.h 2018-12-14 11:20:07.770030234 -0500
+@@ -658,7 +658,7 @@ SI F approx_powf(F x, F y) {
+ }
+
+ SI F from_half(U16 h) {
+-#if defined(SK_CPU_ARM64) && !defined(SK_BUILD_FOR_GOOGLE3) // Temporary workaround for some Google3 builds.
++#if defined(JUMPER_IS_NEON) && defined(__aarch64__) && !defined(SK_BUILD_FOR_GOOGLE3) // Temporary workaround for some Google3 builds.
+ return vcvt_f32_f16(h);
+
+ #elif defined(JUMPER_IS_HSW) || defined(JUMPER_IS_AVX512)
+@@ -678,7 +678,7 @@ SI F from_half(U16 h) {
+ }
+
+ SI U16 to_half(F f) {
+-#if defined(SK_CPU_ARM64) && !defined(SK_BUILD_FOR_GOOGLE3) // Temporary workaround for some Google3 builds.
++#if defined(JUMPER_IS_NEON) && defined(__aarch64__) && !defined(SK_BUILD_FOR_GOOGLE3) // Temporary workaround for some Google3 builds.
+ return vcvt_f16_f32(f);
+
+ #elif defined(JUMPER_IS_HSW) || defined(JUMPER_IS_AVX512)