aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-09-22 21:17:45 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2018-09-24 11:49:25 +0200
commit468990bcc2275162cdecac6711e274a7834454ed (patch)
tree76c8c5e98fa839ced9c60fd71cec4558fbc51003 /community
parenta34ec58be621a746d52aaad264c30d3f2f20c836 (diff)
downloadaports-468990bcc2275162cdecac6711e274a7834454ed.tar.bz2
aports-468990bcc2275162cdecac6711e274a7834454ed.tar.xz
enable stripping of go binaries
Stripping go binaries used to be an issue but nowadays it should work as expected. > We don't intentionally do anything that would make stripping a binary > not OK, and strip has worked for the past five years or so. https://groups.google.com/forum/?_escaped_fragment_=topic/golang-dev/ABppMOjYP6w#!topic/golang-dev/ABppMOjYP6w
Diffstat (limited to 'community')
-rw-r--r--community/git-lfs/APKBUILD4
-rw-r--r--community/glide/APKBUILD3
-rw-r--r--community/gogs/APKBUILD3
3 files changed, 3 insertions, 7 deletions
diff --git a/community/git-lfs/APKBUILD b/community/git-lfs/APKBUILD
index b54f4fdaac..89d6e38477 100644
--- a/community/git-lfs/APKBUILD
+++ b/community/git-lfs/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=git-lfs
pkgver=2.5.1
-pkgrel=1
+pkgrel=2
pkgdesc="Git extension for versioning large files"
url="https://git-lfs.github.io/"
arch="all"
@@ -10,8 +10,6 @@ license="MIT"
depends="git"
checkdepends="bash coreutils git-daemon perl-utils"
makedepends="go ronn"
-# Go doesn't play well with strip tool. http://bit.ly/2jlJsSU
-options="!strip"
subpackages="$pkgname-doc"
install="$pkgname.post-install $pkgname.pre-deinstall"
source="$pkgname-$pkgver.tar.gz::https://github.com/git-lfs/$pkgname/archive/v$pkgver.tar.gz
diff --git a/community/glide/APKBUILD b/community/glide/APKBUILD
index 33e62dac94..036b2906d1 100644
--- a/community/glide/APKBUILD
+++ b/community/glide/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Aaron Hurt <ahurt@ena.com>
pkgname="glide"
pkgver=0.13.1
-pkgrel=0
+pkgrel=1
pkgdesc="Vendor Package Management for Golang"
url="https://github.com/Masterminds/glide"
arch="all"
@@ -13,7 +13,6 @@ install=""
subpackages=""
source="$pkgname-$pkgver.tar.gz::https://github.com/Masterminds/glide/archive/v$pkgver.tar.gz"
builddir="$srcdir/go/src/github.com/Masterminds/glide"
-options="!strip"
prepare() {
mkdir -p "$srcdir/go/src/github.com/Masterminds"
diff --git a/community/gogs/APKBUILD b/community/gogs/APKBUILD
index 6d0026ab7a..3b31966851 100644
--- a/community/gogs/APKBUILD
+++ b/community/gogs/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: 7heo <7heo@mail.com>
pkgname=gogs
pkgver=0.11.34
-pkgrel=1
+pkgrel=2
pkgdesc="A self-hosted Git service written in Go"
url="https://gogs.io/"
arch="all"
@@ -12,7 +12,6 @@ makedepends="go perl libcap"
install="$pkgname.pre-install"
pkgusers="gogs"
pkggroups="www-data"
-options="!strip"
source="${pkgname}-${pkgver}.tar.gz::https://github.com/gogits/$pkgname/archive/v$pkgver.tar.gz
$pkgname.initd
$pkgname.confd