aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-05-01 12:28:39 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-05-01 12:28:39 +0000
commit01a9be3a05e460ae8fecc11ef0e9ce130b1a2718 (patch)
treecae6ba4d7056ba493d8e66a4cfcca97bdff1777a /community
parent2c1fc368ef0733f5d0d20a07d17f04cc6281f899 (diff)
downloadaports-01a9be3a05e460ae8fecc11ef0e9ce130b1a2718.tar.bz2
aports-01a9be3a05e460ae8fecc11ef0e9ce130b1a2718.tar.xz
community/libre2: upgrade to 2017.05.01, modernize APKBUILD
Diffstat (limited to 'community')
-rw-r--r--community/libre2/APKBUILD32
1 files changed, 10 insertions, 22 deletions
diff --git a/community/libre2/APKBUILD b/community/libre2/APKBUILD
index 4f9e9c0aae..2835c5a536 100644
--- a/community/libre2/APKBUILD
+++ b/community/libre2/APKBUILD
@@ -2,41 +2,29 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=libre2
_pkgname=re2
-pkgver=2017.04.01
+pkgver=2017.05.01
_pkgver=${pkgver//./-}
pkgrel=0
pkgdesc="an efficient, principled regular expression library"
url="https://code.google.com/p/re2/"
arch="all"
license="custom"
-depends=""
-depends_dev=""
-makedepends="$depends_dev"
-install=""
+makedepends=""
+options="!check"
subpackages="$pkgname-dev $pkgname-doc"
source="https://github.com/google/$_pkgname/archive/$_pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$_pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$_pkgname-$_pkgver
build() {
- cd "$_builddir"
- make || return 1
+ cd "$builddir"
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" prefix=/usr install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" prefix=/usr install
install -Dm644 LICENSE \
- "$pkgdir"/usr/share/licenses/$pkgname/LICENSE || return 1
+ "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
-sha512sums="59aa92582b2bbd44311ea92aa6bbeb5d3e8d9b115b7fb83f911b6e5680a650c2b22759d935298e1b1b3f5c44014bcc2defb22b136473ad9ed7c4ea006834a700 2017-04-01.tar.gz"
+sha512sums="219fc73e91096244956394b083c67983627597bdf9bfe42b29b5b088c2036979c09fdf71e7c8248297d033e433342a214cd7c368352bc6e488abd13bcd1a8df1 2017-05-01.tar.gz"