aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-04-28 12:37:09 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-04-28 12:37:09 +0000
commit07c5e8c6fc77dd833bbd310e514006c2d003c52a (patch)
tree113f811d34ee7b14fdcc7d21a13d15ad04638e91 /community
parenta1006e9da688f473b26f2394f33197843f14f5c7 (diff)
downloadaports-07c5e8c6fc77dd833bbd310e514006c2d003c52a.tar.bz2
aports-07c5e8c6fc77dd833bbd310e514006c2d003c52a.tar.xz
community/perl-test-postgresql: upgrade to 1.23, modernize APKBUILD
Diffstat (limited to 'community')
-rw-r--r--community/perl-test-postgresql/APKBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/community/perl-test-postgresql/APKBUILD b/community/perl-test-postgresql/APKBUILD
index 62bef332d7..aaa9a42096 100644
--- a/community/perl-test-postgresql/APKBUILD
+++ b/community/perl-test-postgresql/APKBUILD
@@ -3,38 +3,43 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-test-postgresql
_pkgreal=Test-PostgreSQL
-pkgver=1.22
+pkgver=1.23
pkgrel=0
pkgdesc="PostgreSQL runner for tests"
url="http://search.cpan.org/dist/Test-PostgreSQL/"
arch="noarch"
license="Artistic-2"
cpandepends="perl-class-accessor-lite"
-cpanmakedepends="perl-test-sharedfork perl-dbd-pg perl-dbi perl-test-pod
-perl-moo perl-type-tiny perl-function-parameters perl-file-which perl-tie-hash-method"
+cpanmakedepends="perl-test-sharedfork perl-dbd-pg perl-dbi
+ perl-test-pod perl-moo perl-type-tiny perl-function-parameters
+ perl-file-which perl-tie-hash-method"
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/T/TJ/TJC/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+check() {
+ cd "$builddir"
+ make test
+}
prepare() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="0d9e3a46e1953a044d8b55be4cb82e5264f42c854ed04d8483a2c15862da394f5a60809d16774588da9a273e39c6a76541b7fc8201c80e856e4a684b5e0acb65 Test-PostgreSQL-1.22.tar.gz"
+sha512sums="a835d55d7ddc66255f09ae15fd66d3f40b70fa7a4da7f70ffaa8400639c893e942dbbc427086441e15859fc18736d121ab03cc2d2043d48ae5123530e1a31fb7 Test-PostgreSQL-1.23.tar.gz"