aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-04-03 15:18:58 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-04-03 15:20:01 +0200
commit30d0d0c694dc81ea99b750d6b88e19c3c45f57be (patch)
tree4fe0bbeda63960fb85a6fd46b6d793a975846052 /community
parent48d9ebf65fd57f1c2257c88017886d8777a3826f (diff)
downloadaports-30d0d0c694dc81ea99b750d6b88e19c3c45f57be.tar.bz2
aports-30d0d0c694dc81ea99b750d6b88e19c3c45f57be.tar.xz
community/chromium: upgrade to 57.0.2987.133
Diffstat (limited to 'community')
-rw-r--r--community/chromium/APKBUILD24
-rw-r--r--community/chromium/default-pthread-stacksize.patch23
-rw-r--r--community/chromium/musl-fixes.patch40
-rw-r--r--community/chromium/no-mallinfo.patch38
-rw-r--r--community/chromium/unset-madv_free.patch8
5 files changed, 76 insertions, 57 deletions
diff --git a/community/chromium/APKBUILD b/community/chromium/APKBUILD
index 6009e229f6..2d4a677a3a 100644
--- a/community/chromium/APKBUILD
+++ b/community/chromium/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=chromium
-pkgver=56.0.2924.87
-pkgrel=2
+pkgver=57.0.2987.133
+pkgrel=0
pkgdesc="chromium web browser"
url="http://www.chromium.org/"
arch="x86_64"
@@ -82,7 +82,6 @@ source="https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
chromium-widevine.patch
default-pthread-stacksize.patch
- gcc6.patch
gn_bootstrap.patch
last-commit-position.patch
musl-fixes.patch
@@ -138,6 +137,7 @@ build() {
libjpeg
libpng
libwebp
+ libxml
libxslt
snappy
yasm
@@ -145,8 +145,8 @@ build() {
for _lib in ${use_system} libjpeg_turbo; do
msg "Removing buildscripts for system provided $_lib"
find -type f -path "*third_party/$_lib/*" \
- \! -path "*third_party/$LIB/chromium/*" \
- \! -path "*third_party/$LIB/google/*" \
+ \! -path "*third_party/$_lib/chromium/*" \
+ \! -path "*third_party/$_lib/google/*" \
\! -regex '.*\.\(gn\|gni\|isolate\|py\)' \
-delete
done
@@ -193,7 +193,6 @@ build() {
symbol_level=0 \
linux_link_cups=true \
linux_link_gsettings=true \
- linux_link_libpci=true \
linux_link_libspeechd=false \
linux_use_bundled_binutils=false \
linux_use_bundled_gold=false \
@@ -276,13 +275,13 @@ package() {
cd "$builddir"
local bin pak
# paxmark inside chroot too
- paxmark -m out/Release/chrome || return 1
paxmark -m out/Release/mksnapshot || return 1
for bin in chrome natives_blob.bin snapshot_blob.bin; do
install -Dm755 out/Release/$bin \
"$pkgdir"/usr/lib/$pkgname/$bin || return 1
done
+ paxmark -m "$pkgdir"/usr/lib/$pkgname/chrome || return 1
install -Dm4755 "$builddir"/out/Release/chrome_sandbox \
"$pkgdir"/usr/lib/$pkgname/chrome-sandbox || return 1
@@ -343,20 +342,19 @@ chromedriver() {
mv "$pkgdir"/usr/bin/chromedriver "$subpkgdir"/usr/bin || return 1
}
-sha512sums="1c154004a9bca73e2491c73520a5f7d5c50c5b9d66e8e2660bf46585dd9b6ad3db706a9d824356f319794fa790bc3918ae6199843bcba717b9e74efbf26882c9 chromium-56.0.2924.87.tar.xz
+sha512sums="b53fb357d3f11b45a46b3fe52a10b0d20cf8f3fedc8454ceca6b8d1ea9c526493cfeeb4472766e3f23ceba5cd53b089a2639d6a166fbfa91db05153571b59039 chromium-57.0.2987.133.tar.xz
b9a810416dd7a8ffc3a5ced85ad9acebda1665bd08a57eec7b189698cc5f74d2c3fd69044e20fcb83297a43214b2772a1312b2c6122ea0eb716abacf39524d60 chromium-launcher.sh
f6d962b9e4c22dd42183df3db5d3202dab33eccecafb1bf63ca678147289581262db1e5e64cbe8f9c212beefb0a6717bb8d311e497f56b55fe95b8bab2db493f chromium.conf
e182c998a43d22d1c76a86c561619afd1fca8c2be668265ad5e2f81a3806f7a154272cc027a2f8b370fb69446892c69e5967a4be76082325c14245ee7915234c chromium.desktop
2d8237a940ea691bd10b08315429677a587f7ef9692a0cca53bfd066eae82998a6c71f402a8669e9de39f94d7f3280745d1628ea6eac5d76ca7116844d4e0dac google-api.keys
55921cc33d623e0751e94d4fef2ddd69afb57381da6115995b1f318e2398978b9173e80f6ffbc6e6c0c0c55a04e934e0e34a46c32e03947cc31f0f5a226e7725 chromium-widevine.patch
-0f296d24ca6de1bf340a67f294b53304c44e7b46b6bb0936e10ae33786d5b3b6b523914e1f9eb7bc0995623c2404c8e1d5d27596cbfbc3cc36ca00fb92bc17e7 default-pthread-stacksize.patch
-08300afd0bbcdc62bc96c52b11a40fb51b31ef2fb874873438a40ce70d80eb91779e1e0d9b64e020b28c3744f14630d576020cf73d626b720e51e474912a0127 gcc6.patch
+be4d857b634dba6267bd6f75cbb5bea34935ab017537ca96c705b3ff1b4108c1f7e35000c44eeaffc98cfe2a242f9aea6096d6696006f7e5ae86758c1d726265 default-pthread-stacksize.patch
0a15b178fadffdc31f1f7bc814b95817cbcea9dd90b1ed84f7bab2d840f36453573742bd8501d79edecfa38c0ec2147843aef03c7b2c9bcfd0e3d22b72c25c4b gn_bootstrap.patch
8fbfd67a0b6bbdf08364e810bd85b4a80dda9af73fefe3aba8010d9b33022d458a785c628515bbda9c743b8a0293d57cfe18fcc5aa2313c845c6fb948c2335f9 last-commit-position.patch
-88f70ac8453c744c8735c1ccd3cf638e2c03f73295454e6b224b1dfe9f4576f3674f1803f87aa729e1fb836fafa62ec41c6d46ed706566b2aa38eca277ad5570 musl-fixes.patch
+52ff4dec19fd9aaa2763a66fd5a38e73be24d5aef05735ec2caaa5519168e7fce3cc112e91249c42d863d3320affb00c293cb830f29d273e809167a6d333463a musl-fixes.patch
ce8276bb35a8d72cf58868a6331e85286b350a1aad694525ebf637499819219dd4d87ab67dd3b938830a6bd3e7172fc9bcd9c8971820d0ed95c0d141867a24fe musl-sandbox.patch
fef119b4e23269cc6252e940e23029a312c9852b8d2115ee155ef9a4f5788b6b7dc8c1cab2e32fb4f25c2956a4dd2305375cbd1847c58d7159d15907d6b17a5d no-execinfo.patch
a57858e45cfbb7e97f77b3b308502e377543d61d3d0085798ed73bc53da456828f5e010308d0de05fee4fe52071362d074f5af205f98f41d67222d997857d626 no-getcontext.patch
-7eac76f78b734404510d6e850b3eb55d10ae74ed48072dd318a751cc6fd806363eb82544602f5b6724548a34b418658b9fb0941c88ced0dc4f0ee77cfb172d0d no-mallinfo.patch
+b5436f3f2fe8fa28f7019516edd3e7cbada40299e50640e3ca136abdfcb81d32a2f59011d5aea0add1997df30fd699694cdf65ae4b80862e0f5229b446f47c24 no-mallinfo.patch
d60407a8faadfd2a8294570163b4d1b1112c8a70a6f8e778fc3aff25d20613a2e26c66cd87e69c54953cc1b984e4038015ad04797b0495df13932541b05398fe resolver.patch
-5eafc0b92d6aa3a4a94bce544461d57121a9405784e2687b9ed382371a7c10e4db5fd6325057344a66b7df32dca963bc12b7f67b256f1f1295bf6519400b0b8e unset-madv_free.patch"
+27dd7916be3324294a0a913c43c856e9c00be767a2aec4f3da2455fb84e74ebb0017d1aa586b40dd9d989ada6b60fc531522f503d57e04324726a2171bf3a85e unset-madv_free.patch"
diff --git a/community/chromium/default-pthread-stacksize.patch b/community/chromium/default-pthread-stacksize.patch
index fca919b1f3..2b14c7bd43 100644
--- a/community/chromium/default-pthread-stacksize.patch
+++ b/community/chromium/default-pthread-stacksize.patch
@@ -4,3 +4,26 @@
- return 0;
+ // use 2mb to avoid running out of space
+ return (2 * 1024 * 1024);
+--- chrome/browser/chrome_browser_main_posix.cc.orig
++++ chrome/browser/chrome_browser_main_posix.cc
+@@ -276,12 +276,20 @@
+ g_shutdown_pipe_read_fd = pipefd[0];
+ g_shutdown_pipe_write_fd = pipefd[1];
+ #if !defined(ADDRESS_SANITIZER) && !defined(KEEP_SHADOW_STACKS)
++# if defined(__GLIBC__)
+ const size_t kShutdownDetectorThreadStackSize = PTHREAD_STACK_MIN * 2;
++# else
++ const size_t kShutdownDetectorThreadStackSize = PTHREAD_STACK_MIN * 2 * 8; // match up musls 2k PTHREAD_STACK_MIN with glibcs 16k
++# endif
+ #else
+ // ASan instrumentation and -finstrument-functions (used for keeping the
+ // shadow stacks) bloat the stack frames, so we need to increase the stack
+ // size to avoid hitting the guard page.
++# if defined(__GLIBC__)
+ const size_t kShutdownDetectorThreadStackSize = PTHREAD_STACK_MIN * 4;
++# else
++ const size_t kShutdownDetectorThreadStackSize = PTHREAD_STACK_MIN * 4 * 8; // match up musls 2k PTHREAD_STACK_MIN with glibcs 16k
++# endif
+ #endif
+ // TODO(viettrungluu,willchan): crbug.com/29675 - This currently leaks, so
+ // if you change this, you'll probably need to change the suppression.
diff --git a/community/chromium/musl-fixes.patch b/community/chromium/musl-fixes.patch
index 4282a17f33..4f6c0ee957 100644
--- a/community/chromium/musl-fixes.patch
+++ b/community/chromium/musl-fixes.patch
@@ -126,26 +126,6 @@
#endif
#if HAVE_UNISTD_H
#include <unistd.h>
---- ./third_party/WebKit/Source/platform/heap/StackFrameDepth.cpp.orig
-+++ ./third_party/WebKit/Source/platform/heap/StackFrameDepth.cpp
-@@ -68,7 +68,7 @@
- // FIXME: On Mac OSX and Linux, this method cannot estimate stack size
- // correctly for the main thread.
-
--#if defined(__GLIBC__) || OS(ANDROID) || OS(FREEBSD)
-+#if OS(LINUX) || OS(ANDROID) || OS(FREEBSD)
- // pthread_getattr_np() can fail if the thread is not invoked by
- // pthread_create() (e.g., the main thread of webkit_unit_tests).
- // If so, a conservative size estimate is returned.
-@@ -135,7 +135,7 @@
- }
-
- void* StackFrameDepth::getStackStart() {
--#if defined(__GLIBC__) || OS(ANDROID) || OS(FREEBSD)
-+#if OS(LINUX) || OS(ANDROID) || OS(FREEBSD)
- pthread_attr_t attr;
- int error;
- #if OS(FREEBSD)
--- ./chrome/browser/metrics/chrome_browser_main_extra_parts_metrics.cc.orig
+++ ./chrome/browser/metrics/chrome_browser_main_extra_parts_metrics.cc
@@ -40,7 +40,7 @@
@@ -217,3 +197,23 @@ index a80ea16..55a2abf 100644
#include <arpa/inet.h>
#include <stdint.h>
#endif
+--- ./third_party/WebKit/Source/wtf/StackUtil.cpp.orig
++++ ./third_party/WebKit/Source/wtf/StackUtil.cpp
+@@ -28,7 +28,7 @@
+ // FIXME: On Mac OSX and Linux, this method cannot estimate stack size
+ // correctly for the main thread.
+
+-#if defined(__GLIBC__) || OS(ANDROID) || OS(FREEBSD)
++#if OS(LINUX) || OS(ANDROID) || OS(FREEBSD)
+ // pthread_getattr_np() can fail if the thread is not invoked by
+ // pthread_create() (e.g., the main thread of webkit_unit_tests).
+ // If so, a conservative size estimate is returned.
+@@ -95,7 +95,7 @@
+ }
+
+ void* getStackStart() {
+-#if defined(__GLIBC__) || OS(ANDROID) || OS(FREEBSD)
++#if OS(LINUX) || OS(ANDROID) || OS(FREEBSD)
+ pthread_attr_t attr;
+ int error;
+ #if OS(FREEBSD)
diff --git a/community/chromium/no-mallinfo.patch b/community/chromium/no-mallinfo.patch
index ceaf009295..306c64b622 100644
--- a/community/chromium/no-mallinfo.patch
+++ b/community/chromium/no-mallinfo.patch
@@ -1,16 +1,16 @@
---- base/trace_event/malloc_dump_provider.cc.orig 2016-11-16 02:19:56.753320143 +0100
-+++ base/trace_event/malloc_dump_provider.cc 2016-11-16 02:13:58.286196506 +0100
-@@ -224,7 +224,7 @@
- resident_size = all_heap_info.committed_size;
- allocated_objects_size = all_heap_info.allocated_size;
- allocated_objects_count = all_heap_info.block_count;
+--- base/trace_event/malloc_dump_provider.cc.orig
++++ base/trace_event/malloc_dump_provider.cc
+@@ -187,7 +187,7 @@
+ resident_size = main_heap_info.committed_size;
+ allocated_objects_size = main_heap_info.allocated_size;
+ allocated_objects_count = main_heap_info.block_count;
-#else
+#elif defined(OS_LINUX) && defined(__GLIBC__)
struct mallinfo info = mallinfo();
DCHECK_GE(info.arena + info.hblkhd, info.uordblks);
-
---- content/child/content_child_helpers.cc.orig 2016-05-08 08:05:37.415219394 +0200
-+++ content/child/content_child_helpers.cc 2016-05-08 08:06:27.110142484 +0200
+
+--- content/child/content_child_helpers.cc.orig
++++ content/child/content_child_helpers.cc
@@ -24,7 +24,7 @@ namespace content {
// though, this provides only a partial and misleading value.
// Unfortunately some telemetry benchmark rely on it and these need to
@@ -20,13 +20,11 @@
size_t GetMemoryUsageKB() {
struct mallinfo minfo = mallinfo();
uint64_t mem_usage =
-diff --git a/content/renderer/render_thread_impl.cc b/content/renderer/render_thread_impl.cc
-index d569350..6edcffe 100644
---- content/renderer/render_thread_impl.cc
+--- content/renderer/render_thread_impl.cc.orig
+++ content/renderer/render_thread_impl.cc
-@@ -1821,6 +1821,49 @@ static size_t GetMallocUsage() {
+@@ -1712,6 +1712,49 @@
}
-
+
} // namespace
+#elif defined(OS_LINUX) && !defined(__GLIBC__)
+namespace {
@@ -72,12 +70,12 @@ index d569350..6edcffe 100644
+
+} // namespace
#endif
-
- // TODO(tasak): Once it is possible to use memory-infra without tracing,
-@@ -1839,7 +1882,7 @@ void RenderThreadImpl::RecordPurgeAndSuspendMetrics() const {
- blink_stats.partitionAllocTotalAllocatedBytes / 1024);
- UMA_HISTOGRAM_MEMORY_KB("PurgeAndSuspend.Memory.BlinkGCKB",
- blink_stats.blinkGCTotalAllocatedBytes / 1024);
+
+ void RenderThreadImpl::GetRendererMemoryMetrics(
+@@ -1722,7 +1765,7 @@
+ memory_metrics->partition_alloc_kb =
+ blink_stats.partitionAllocTotalAllocatedBytes / 1024;
+ memory_metrics->blink_gc_kb = blink_stats.blinkGCTotalAllocatedBytes / 1024;
-#if defined(OS_LINUX) || defined(OS_ANDROID)
+#if (defined(OS_LINUX) && defined(__GLIBC__)) || defined(OS_ANDROID)
struct mallinfo minfo = mallinfo();
diff --git a/community/chromium/unset-madv_free.patch b/community/chromium/unset-madv_free.patch
index f748179fc9..613d37c585 100644
--- a/community/chromium/unset-madv_free.patch
+++ b/community/chromium/unset-madv_free.patch
@@ -1,10 +1,10 @@
---- third_party/WebKit/Source/wtf/allocator/PageAllocator.cpp
-+++ third_party/WebKit/Source/wtf/allocator/PageAllocator.cpp
-@@ -41,6 +41,11 @@
+--- base/allocator/partition_allocator/page_allocator.cc.orig
++++ base/allocator/partition_allocator/page_allocator.cc
+@@ -17,6 +17,11 @@
#include <errno.h>
#include <sys/mman.h>
-+#if OS(LINUX) && defined(MADV_FREE)
++#if defined(OS_LINUX) && defined(MADV_FREE)
+// Added in Linux 4.5, but it breaks the sandbox.
+#undef MADV_FREE
+#endif