aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-11-04 11:25:28 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2016-11-04 11:25:35 +0100
commit72b0c99da28921f07ee1b785d8d08086c84e1968 (patch)
treebd374e30fe65e2da22162c5d39ead954473c4a1e /community
parent173f86aa76c1e509fdf26560ac16b8b6e07c54ef (diff)
downloadaports-72b0c99da28921f07ee1b785d8d08086c84e1968.tar.bz2
aports-72b0c99da28921f07ee1b785d8d08086c84e1968.tar.xz
community/geary: upgrade to 0.11.2
Diffstat (limited to 'community')
-rw-r--r--community/geary/APKBUILD32
-rw-r--r--community/geary/fix-compiler-warnings.patch72
2 files changed, 86 insertions, 18 deletions
diff --git a/community/geary/APKBUILD b/community/geary/APKBUILD
index e020a78596..5ae9c14857 100644
--- a/community/geary/APKBUILD
+++ b/community/geary/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=geary
-pkgver=0.10.0
+pkgver=0.11.2
pkgrel=0
pkgdesc="A lightweight email program designed around conversations"
url="http://yorba.org/geary/"
@@ -16,22 +16,15 @@ makedepends="$depends_dev cmake vala gtk+3.0-dev gmime-dev libgee-dev
install=""
subpackages="$pkgname-lang"
-source="https://download.gnome.org/sources/geary/${pkgver%.*}/geary-$pkgver.tar.xz"
+source="https://download.gnome.org/sources/geary/${pkgver%.*}/geary-$pkgver.tar.xz
+ fix-compiler-warnings.patch"
-_builddir="$srcdir"/geary-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/geary-$pkgver
build() {
- cd "$_builddir"
- cmake . \
+ cd "$builddir"
+ mkdir build && cd build
+ cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
-DGSETTINGS_COMPILE=OFF \
@@ -43,7 +36,7 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"/build
make DESTDIR="$pkgdir" install || return 1
# webkit JIT has problems with hardened kernel
@@ -51,6 +44,9 @@ package() {
}
-md5sums="c9735cb5eb53384c0c9d40ff815ed232 geary-0.10.0.tar.xz"
-sha256sums="46197a5a1b8b040adcee99082dbfd9fff9ca804e3bf0055a2e90b13214bdbca5 geary-0.10.0.tar.xz"
-sha512sums="9126acb3608f7aac9236f7d38f5ca549fe04427e244bbff093d06095e09d0ae642ed8e5722325f152a40d3c642a5f31035fca1685749fbe311c4bf3965ee3256 geary-0.10.0.tar.xz"
+md5sums="028591291715c80ac033808b73bff2e6 geary-0.11.2.tar.xz
+2ed8bb57adfa5e2940206071458b74ee fix-compiler-warnings.patch"
+sha256sums="5c9e20ecd53672a42e22a436b9d3b6b9e9bf81ddf77163414a1c55986f9b4631 geary-0.11.2.tar.xz
+8dec82733c51c53d0e8dcc1578930fbc1b39a16ea78b0c89debf83745b1f7711 fix-compiler-warnings.patch"
+sha512sums="cbfb7461d3125c94e24a32c1cf6baad417d07ac274f1f1f1df4ef7f07b6c6b872a32a35e69bf33c6c6b8960ac4cf8135984ca33f4d4c8861e4c0a1f22525ba88 geary-0.11.2.tar.xz
+807117393973160b28d67ced02b0a660d3fcb94c5fa85a130119e5584ade72b9624d0cdf73928bb26a724b39b5dd9bac7d4295de94153ccf38e94e3371dafec8 fix-compiler-warnings.patch"
diff --git a/community/geary/fix-compiler-warnings.patch b/community/geary/fix-compiler-warnings.patch
new file mode 100644
index 0000000000..12188d432d
--- /dev/null
+++ b/community/geary/fix-compiler-warnings.patch
@@ -0,0 +1,72 @@
+From f2d392bed5ea3cec6c097895ba54ba840e3e3480 Mon Sep 17 00:00:00 2001
+From: Rico Tzschichholz <ricotz@ubuntu.com>
+Date: Fri, 8 Jul 2016 09:56:42 +0200
+Subject: Fix compile warnings with vala git
+
+---
+ src/client/application/geary-application.vala | 4 ++--
+ src/client/components/conversation-find-bar.vala | 2 +-
+ src/client/dialogs/attachment-dialog.vala | 4 ++--
+ src/console/main.vala | 2 +-
+ 4 files changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/src/client/application/geary-application.vala b/src/client/application/geary-application.vala
+index 64038bb..da5ff3e 100644
+--- a/src/client/application/geary-application.vala
++++ b/src/client/application/geary-application.vala
+@@ -36,9 +36,9 @@ public class GearyApplication : Gtk.Application {
+ null
+ };
+
+- private static const string ACTION_ENTRY_COMPOSE = "compose";
++ private const string ACTION_ENTRY_COMPOSE = "compose";
+
+- public static const ActionEntry[] action_entries = {
++ public const ActionEntry[] action_entries = {
+ {ACTION_ENTRY_COMPOSE, activate_compose, "s"},
+ };
+
+diff --git a/src/client/components/conversation-find-bar.vala b/src/client/components/conversation-find-bar.vala
+index 008f4d3..a625896 100644
+--- a/src/client/components/conversation-find-bar.vala
++++ b/src/client/components/conversation-find-bar.vala
+@@ -5,7 +5,7 @@
+ */
+
+ public class ConversationFindBar : Gtk.Layout {
+- private static const string entry_not_found_style =
++ private const string entry_not_found_style =
+ """
+ .geary-not-found {
+ color: white;
+diff --git a/src/client/dialogs/attachment-dialog.vala b/src/client/dialogs/attachment-dialog.vala
+index e391a35..fc29a3d 100644
+--- a/src/client/dialogs/attachment-dialog.vala
++++ b/src/client/dialogs/attachment-dialog.vala
+@@ -5,8 +5,8 @@
+ */
+
+ public class AttachmentDialog : Gtk.FileChooserDialog {
+- private static const int PREVIEW_SIZE = 180;
+- private static const int PREVIEW_PADDING = 3;
++ private const int PREVIEW_SIZE = 180;
++ private const int PREVIEW_PADDING = 3;
+
+ private static string? current_folder = null;
+
+diff --git a/src/console/main.vala b/src/console/main.vala
+index 6ae3fff..7d0ba12 100644
+--- a/src/console/main.vala
++++ b/src/console/main.vala
+@@ -15,7 +15,7 @@ errordomain CommandException {
+ class ImapConsole : Gtk.Window {
+ public const string VERSION = _VERSION;
+
+- private static const int KEEPALIVE_SEC = 60 * 10;
++ private const int KEEPALIVE_SEC = 60 * 10;
+
+ private Gtk.TextView console = new Gtk.TextView();
+ private Gtk.Entry cmdline = new Gtk.Entry();
+--
+cgit v0.12
+