aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-05-01 00:42:12 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-05-01 00:42:12 +0200
commitabfa07f26ff2837922903586b15e137b67b43219 (patch)
tree9cdef6c232e99c8f998d395b9fda0c3ca134bfc9 /community
parent76a668d7dcc10d370ce8187a1461d156559e273a (diff)
downloadaports-abfa07f26ff2837922903586b15e137b67b43219.tar.bz2
aports-abfa07f26ff2837922903586b15e137b67b43219.tar.xz
community/llvm-libunwind: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/llvm-libunwind/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/community/llvm-libunwind/APKBUILD b/community/llvm-libunwind/APKBUILD
new file mode 100644
index 0000000000..3168e5a33c
--- /dev/null
+++ b/community/llvm-libunwind/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=llvm-libunwind
+_pkgname=libunwind
+pkgver=3.9.1
+_llvmver=3.9
+pkgrel=1
+pkgdesc="LLVM version of libunwind library"
+url="http://llvm.org/"
+arch="all"
+license="BSD"
+depends_dev="!libunwind-dev"
+makedepends="cmake llvm$_llvmver-dev"
+subpackages="$pkgname-dev"
+source="http://www.llvm.org/releases/$pkgver/$_pkgname-$pkgver.src.tar.xz"
+builddir="$srcdir/$_pkgname-$pkgver.src"
+options="!check"
+
+build() {
+ local flag; for flag in 0 1; do
+ mkdir -p "$builddir"/build-$flag
+ cd "$builddir"/build-$flag
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ -DCMAKE_VERBOSE_MAKEFILE=ON \
+ -DLIBUNWIND_ENABLE_SHARED=$flag \
+ -DLIBUNWIND_HAS_NODEFAULTLIBS_FLAG=0 \
+ -DLLVM_CONFIG="/usr/bin/llvm-config-$_llvmver"
+ make
+ done
+}
+
+package() {
+ local flag; for flag in 0 1; do
+ make install -C "$builddir"/build-$flag DESTDIR="$pkgdir"
+ done
+
+ cd "$builddir"
+
+ mkdir -p "$pkgdir"/usr/include
+ cp include/*.h "$pkgdir"/usr/include/
+}
+
+sha512sums="a80f5d0660e209f5bf709316b5df2ca63b9f0db49f5f74dfe9c9e580c654f61a15acc071a739fdb84baf5ffa9420b92498f8560331173642d80f6b74e1e2afb7 libunwind-3.9.1.src.tar.xz"