aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-30 00:18:14 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-05-02 01:04:51 +0200
commitc997492ce9d4070c926df759df94f4bc566a1bbc (patch)
tree5430d00829e8608524e08fb710b69691706a9adc /community
parent12c3073e53487779b136d6db3e090d9d46a82dfc (diff)
downloadaports-c997492ce9d4070c926df759df94f4bc566a1bbc.tar.bz2
aports-c997492ce9d4070c926df759df94f4bc566a1bbc.tar.xz
community/php7: upgrade to 7.1.4
This patch is based on https://github.com/alpinelinux/aports/pull/1305, but includes only changes relevant to the upgrade (I'll apply the rest separately).
Diffstat (limited to 'community')
-rw-r--r--community/php7/APKBUILD17
-rw-r--r--community/php7/libressl.patch13
-rw-r--r--community/php7/php7-fpm-version-suffix.patch55
-rw-r--r--community/php7/pid_log.patch76
-rw-r--r--community/php7/tidy-buffio.patch11
5 files changed, 61 insertions, 111 deletions
diff --git a/community/php7/APKBUILD b/community/php7/APKBUILD
index 8590d2a889..65692a2d3d 100644
--- a/community/php7/APKBUILD
+++ b/community/php7/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Valery Kartel <valery.kartel@gmail.com>
pkgname=php7
_pkgreal=php
-pkgver=7.0.18
-pkgrel=1
+pkgver=7.1.4
+pkgrel=0
pkgdesc="The PHP language runtime engine - 7th branch"
url="http://www.php.net/"
arch="all"
@@ -30,11 +30,9 @@ source="http://php.net/distributions/$_pkgreal-$pkgver.tar.bz2
$pkgname-fpm.logrotate
$pkgname-module.conf
install-pear.patch
- tidy-buffio.patch
includedir.patch
fix-asm-constraints-in-aarch64-multiply-macro.patch
- pid_log.patch
- libressl.patch
+ php7-fpm-version-suffix.patch
"
builddir="$srcdir/$_pkgreal-$pkgver"
@@ -54,7 +52,7 @@ for _ext in $_exts; do
done
subpackages="$subpackages $pkgname-common::noarch"
-_apiver="20151012"
+_apiver="20160303"
prepare() {
cd "$builddir"
@@ -145,7 +143,6 @@ _build() {
--enable-wddx=shared \
--enable-zip=shared --with-libzip=shared \
$@ || return 1
- sed -ri "s/^(EXTRA_LDFLAGS[ ]*\=.*)/\1 -lpthread/" Makefile # see #183 (from main/php)
make || return 1
}
@@ -347,13 +344,11 @@ _package_ext() {
> "$subpkgdir"/etc/$pkgname/conf.d/${elo}_${extname}.ini
}
-sha512sums="eccd9d68578373bb27aeb2d3b6d1a202e428bd622daaa069e1d526a81f2a406bf9d1852d73fbf9dc7a4488f514ab50f4a6c87ee6b4ac172c6f2b7f214b1dea56 php-7.0.18.tar.bz2
+sha512sums="a1dd5ffd756176e6ba600dd850510033d0d6f07aff314de69fec0c42437e6a006449e3f4f98679146a2f2645caa65ea351e31a8e1da7c14cc5260856ad40eaff php-7.1.4.tar.bz2
1c708de82d1086f272f484faf6cf6d087af7c31750cc2550b0b94ed723961b363f28a947b015b2dfc0765caea185a75f5d2c2f2b099c948b65c290924f606e4f php7-fpm.initd
cacce7bf789467ff40647b7319e3760c6c587218720538516e8d400baa75651f72165c4e28056cd0c1dc89efecb4d00d0d7823bed80b29136262c825ce816691 php7-fpm.logrotate
fbf9a1572d37370ec0d126502e1d066e045a992484d8fc4f1e2ede330134c1a15f4029f29fa4daebd48eed78b045dc051ced69fbf1f11efc7ad81d884a639a99 php7-module.conf
f1177cbf6b1f44402f421c3d317aab1a2a40d0b1209c11519c1158df337c8945f3a313d689c939768584f3e4edbe52e8bd6103fb6777462326a9d94e8ab1f505 install-pear.patch
-6894c9cba7752a3406e774d9efc0e058c37433493c1c20101e9563bf247c112157a67e306b06b9517b0422eca521f543d637a6cbd2cea7639e43f13d773b3d2b tidy-buffio.patch
199aecdbd3b4035aabf5379c215f82412d3c98b79a1ee186944e7fe1f0ed6f40789ea30e2355149491de6be34fc66c5e486e2a79a7e41ab2ae18706ef3ffe79b includedir.patch
d93d3fc015580cf5f75c6cbca4cd980e054b61e1068495da81a7e61f1af2c9ae14f09964c04928ad338142de78e4844aed885b1ad1865282072999fb045c8ad7 fix-asm-constraints-in-aarch64-multiply-macro.patch
-82231c7b27b4d044272857dc713674884715ed8e36e54be06faa5d2a949ba4bca597628958a9c5683ec51c36e05a00f6be811c7e95112b0314c98528f584a8d6 pid_log.patch
-d04d7cccae789ebf607f4fd107c26b580752353c8636c6c509123285063d274f3fb4aa28e0b31677515435e41a234e9990d45ceb70756ac7f7aa4cb9b11faecb libressl.patch"
+a4c35446745ab0ac806de801f0651fc5d2c98cf60063c3c2d3963a84f1c71ef78e09b7650c08e7231be0fdb93c0c255de38894d7f0e4f4c5a190d17f1a6bc476 php7-fpm-version-suffix.patch"
diff --git a/community/php7/libressl.patch b/community/php7/libressl.patch
deleted file mode 100644
index 79c15c7433..0000000000
--- a/community/php7/libressl.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/aclocal.m4
-+++ b/aclocal.m4
-@@ -2337,9 +2337,7 @@
-
- dnl If pkg-config is found try using it
- if test "$PHP_OPENSSL_DIR" = "yes" && test -x "$PKG_CONFIG" && $PKG_CONFIG --exists openssl; then
-- if $PKG_CONFIG --atleast-version=1.1 openssl; then
-- AC_MSG_ERROR([OpenSSL version >= 1.1 is not supported.])
-- elif $PKG_CONFIG --atleast-version=0.9.8 openssl; then
-+ if $PKG_CONFIG --atleast-version=0.9.8 openssl; then
- found_openssl=yes
- OPENSSL_LIBS=`$PKG_CONFIG --libs openssl`
- OPENSSL_INCS=`$PKG_CONFIG --cflags-only-I openssl`
diff --git a/community/php7/php7-fpm-version-suffix.patch b/community/php7/php7-fpm-version-suffix.patch
new file mode 100644
index 0000000000..e8aee952f3
--- /dev/null
+++ b/community/php7/php7-fpm-version-suffix.patch
@@ -0,0 +1,55 @@
+--- a/sapi/fpm/fpm/fpm_conf.c
++++ b/sapi/fpm/fpm/fpm_conf.c
+@@ -1180,3 +1180,3 @@
+ if (!fpm_global_config.error_log) {
+- fpm_global_config.error_log = strdup("log/php-fpm.log");
++ fpm_global_config.error_log = strdup("log/php7/error.log");
+ }
+@@ -1191,3 +1191,3 @@
+ if (!fpm_global_config.syslog_ident) {
+- fpm_global_config.syslog_ident = strdup("php-fpm");
++ fpm_global_config.syslog_ident = strdup("php-fpm7");
+ }
+@@ -1683,3 +1683,3 @@
+ } else {
+- spprintf(&tmp, 0, "%s/etc/php-fpm.conf", fpm_globals.prefix);
++ spprintf(&tmp, 0, "%s/etc/php7/php-fpm.conf", fpm_globals.prefix);
+ }
+--- a/sapi/fpm/php-fpm.conf.in
++++ b/sapi/fpm/php-fpm.conf.in
+@@ -16,3 +16,3 @@
+ ; Default Value: none
+-;pid = run/php-fpm.pid
++;pid = run/php-fpm7.pid
+
+@@ -22,4 +22,4 @@
+ ; Note: the default prefix is @EXPANDED_LOCALSTATEDIR@
+-; Default Value: log/php-fpm.log
+-;error_log = log/php-fpm.log
++; Default Value: log/php7/error.log
++;error_log = log/php7/error.log
+
+@@ -35,4 +35,4 @@
+ ; which must suit common needs.
+-; Default Value: php-fpm
+-;syslog.ident = php-fpm
++; Default Value: php-fpm7
++;syslog.ident = php-fpm7
+
+--- a/sapi/fpm/www.conf.in
++++ b/sapi/fpm/www.conf.in
+@@ -252,3 +252,3 @@
+ ; Default: not set
+-;access.log = log/$pool.access.log
++;access.log = log/php7/$pool.access.log
+
+@@ -316,3 +316,3 @@
+ ; Note: slowlog is mandatory if request_slowlog_timeout is set
+-;slowlog = log/$pool.log.slow
++;slowlog = log/php7/$pool.slow.log
+
+@@ -410,3 +410,3 @@
+ ;php_flag[display_errors] = off
+-;php_admin_value[error_log] = /var/log/fpm-php.www.log
++;php_admin_value[error_log] = /var/log/php7/$pool.error.log
+ ;php_admin_flag[log_errors] = on
diff --git a/community/php7/pid_log.patch b/community/php7/pid_log.patch
deleted file mode 100644
index bc586dbd69..0000000000
--- a/community/php7/pid_log.patch
+++ /dev/null
@@ -1,76 +0,0 @@
---- a/sapi/fpm/fpm/fpm_conf.c
-+++ b/sapi/fpm/fpm/fpm_conf.c
-@@ -1178,7 +1178,7 @@
- }
-
- if (!fpm_global_config.error_log) {
-- fpm_global_config.error_log = strdup("log/php-fpm.log");
-+ fpm_global_config.error_log = strdup("log/php7/error.log");
- }
-
- #ifdef HAVE_SYSTEMD
-@@ -1189,7 +1189,7 @@
-
- #ifdef HAVE_SYSLOG_H
- if (!fpm_global_config.syslog_ident) {
-- fpm_global_config.syslog_ident = strdup("php-fpm");
-+ fpm_global_config.syslog_ident = strdup("php-fpm7");
- }
-
- if (fpm_global_config.syslog_facility < 0) {
-@@ -1681,7 +1681,7 @@
- if (fpm_globals.prefix == NULL) {
- spprintf(&tmp, 0, "%s/php-fpm.conf", PHP_SYSCONFDIR);
- } else {
-- spprintf(&tmp, 0, "%s/etc/php-fpm.conf", fpm_globals.prefix);
-+ spprintf(&tmp, 0, "%s/etc/php-fpm7.conf", fpm_globals.prefix);
- }
-
- if (!tmp) {
---- a/sapi/fpm/php-fpm.conf.in
-+++ b/sapi/fpm/php-fpm.conf.in
-@@ -14,14 +14,14 @@
- ; Pid file
- ; Note: the default prefix is @EXPANDED_LOCALSTATEDIR@
- ; Default Value: none
--;pid = run/php-fpm.pid
-+;pid = run/php-fpm7.pid
-
- ; Error log file
- ; If it's set to "syslog", log is sent to syslogd instead of being written
- ; in a local file.
- ; Note: the default prefix is @EXPANDED_LOCALSTATEDIR@
- ; Default Value: log/php-fpm.log
--;error_log = log/php-fpm.log
-+;error_log = log/php7/error.log
-
- ; syslog_facility is used to specify what type of program is logging the
- ; message. This lets syslogd specify that messages from different facilities
---- a/sapi/fpm/www.conf.in
-+++ b/sapi/fpm/www.conf.in
-@@ -250,7 +250,7 @@
-
- ; The access log file
- ; Default: not set
--;access.log = log/$pool.access.log
-+;access.log = log/php7/$pool.access.log
-
- ; The access log format.
- ; The following syntax is allowed
-@@ -314,7 +314,7 @@
- ; The log file for slow requests
- ; Default Value: not set
- ; Note: slowlog is mandatory if request_slowlog_timeout is set
--;slowlog = log/$pool.log.slow
-+;slowlog = log/php7/$pool.slow.log
-
- ; The timeout for serving a single request after which a PHP backtrace will be
- ; dumped to the 'slowlog' file. A value of '0s' means 'off'.
-@@ -408,6 +408,6 @@
- ; specified at startup with the -d argument
- ;php_admin_value[sendmail_path] = /usr/sbin/sendmail -t -i -f www@my.domain.com
- ;php_flag[display_errors] = off
--;php_admin_value[error_log] = /var/log/fpm-php.www.log
-+;php_admin_value[error_log] = /var/log/php7/www.error.log
- ;php_admin_flag[log_errors] = on
- ;php_admin_value[memory_limit] = 32M
diff --git a/community/php7/tidy-buffio.patch b/community/php7/tidy-buffio.patch
deleted file mode 100644
index c15f9540a4..0000000000
--- a/community/php7/tidy-buffio.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/ext/tidy/tidy.c
-+++ b/ext/tidy/tidy.c
-@@ -31,7 +31,7 @@
- #include "ext/standard/info.h"
-
- #include "tidy.h"
--#include "buffio.h"
-+#include "tidybuffio.h"
-
- /* compatibility with older versions of libtidy */
- #ifndef TIDY_CALL