aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-29 16:06:34 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-05-02 01:04:51 +0200
commite0390b10a7758e4b6de38035b6867bd9cfe782f4 (patch)
treeb37b4dfc639d4f09a6fb707b63e1b8f20caf8f10 /community
parent687a2f8a9603f64d7b8ee5b0dd7b5b7f2cdc8586 (diff)
downloadaports-e0390b10a7758e4b6de38035b6867bd9cfe782f4.tar.bz2
aports-e0390b10a7758e4b6de38035b6867bd9cfe782f4.tar.xz
community/php7: build recode extension as shared
Diffstat (limited to 'community')
-rw-r--r--community/php7/APKBUILD7
-rw-r--r--community/php7/allow-build-recode-and-imap-together.patch20
2 files changed, 25 insertions, 2 deletions
diff --git a/community/php7/APKBUILD b/community/php7/APKBUILD
index 4c43aa8510..a0e0eed66a 100644
--- a/community/php7/APKBUILD
+++ b/community/php7/APKBUILD
@@ -33,6 +33,7 @@ source="http://php.net/distributions/$_pkgreal-$pkgver.tar.bz2
includedir.patch
fix-asm-constraints-in-aarch64-multiply-macro.patch
php7-fpm-version-suffix.patch
+ allow-build-recode-and-imap-together.patch
"
builddir="$srcdir/$_pkgreal-$pkgver"
@@ -42,7 +43,7 @@ _extension_confd="/etc/$pkgname/conf.d"
_exts="bcmath bz2 calendar ctype curl dba dom enchant exif ftp gd gettext gmp iconv imap intl json
ldap mbstring mcrypt mysqli mysqlnd odbc opcache openssl pcntl pdo pdo_dblib pdo_mysql
- pdo_odbc pdo_pgsql pdo_sqlite pgsql phar:phar posix pspell session shmop simplexml snmp soap
+ pdo_odbc pdo_pgsql pdo_sqlite pgsql phar:phar posix pspell recode session shmop simplexml snmp soap
sockets sqlite3 sysvmsg sysvsem sysvshm tidy wddx xml xmlreader xmlrpc xmlwriter xsl zip zlib
"
subpackages="$pkgname-dev $pkgname-doc $pkgname-apache2 $pkgname-phpdbg $pkgname-embed
@@ -131,6 +132,7 @@ _build() {
--with-pspell=shared \
--without-readline \
--with-libedit \
+ --with-recode=shared \
--enable-session=shared \
--enable-shmop=shared \
--enable-simplexml=shared \
@@ -361,4 +363,5 @@ fbf9a1572d37370ec0d126502e1d066e045a992484d8fc4f1e2ede330134c1a15f4029f29fa4daeb
f1177cbf6b1f44402f421c3d317aab1a2a40d0b1209c11519c1158df337c8945f3a313d689c939768584f3e4edbe52e8bd6103fb6777462326a9d94e8ab1f505 install-pear.patch
199aecdbd3b4035aabf5379c215f82412d3c98b79a1ee186944e7fe1f0ed6f40789ea30e2355149491de6be34fc66c5e486e2a79a7e41ab2ae18706ef3ffe79b includedir.patch
d93d3fc015580cf5f75c6cbca4cd980e054b61e1068495da81a7e61f1af2c9ae14f09964c04928ad338142de78e4844aed885b1ad1865282072999fb045c8ad7 fix-asm-constraints-in-aarch64-multiply-macro.patch
-a4c35446745ab0ac806de801f0651fc5d2c98cf60063c3c2d3963a84f1c71ef78e09b7650c08e7231be0fdb93c0c255de38894d7f0e4f4c5a190d17f1a6bc476 php7-fpm-version-suffix.patch"
+a4c35446745ab0ac806de801f0651fc5d2c98cf60063c3c2d3963a84f1c71ef78e09b7650c08e7231be0fdb93c0c255de38894d7f0e4f4c5a190d17f1a6bc476 php7-fpm-version-suffix.patch
+f8ecae241a90cbc3e98aa4deb3d5d35ef555f51380e29f4e182a8060dffeb84be74f030a14c6b452668471030d78964f52795ca74275db05543ccad20ef1f2cc allow-build-recode-and-imap-together.patch"
diff --git a/community/php7/allow-build-recode-and-imap-together.patch b/community/php7/allow-build-recode-and-imap-together.patch
new file mode 100644
index 0000000000..555092f452
--- /dev/null
+++ b/community/php7/allow-build-recode-and-imap-together.patch
@@ -0,0 +1,20 @@
+Extensions recode and imap can't be loaded together, but they can be build
+together, and that's what we want.
+
+Source: https://src.fedoraproject.org/cgit/rpms/php.git/tree/php-5.3.0-recode.patch?h=f26
+--- a/ext/recode/config9.m4
++++ b/ext/recode/config9.m4
+@@ -4,13 +4,6 @@ dnl
+
+ dnl Check for extensions with which Recode can not work
+ if test "$PHP_RECODE" != "no"; then
+- test "$PHP_IMAP" != "no" && recode_conflict="$recode_conflict imap"
+-
+- if test -n "$MYSQL_LIBNAME"; then
+- PHP_CHECK_LIBRARY($MYSQL_LIBNAME, hash_insert, [
+- recode_conflict="$recode_conflict mysql"
+- ])
+- fi
+
+ if test -n "$recode_conflict"; then
+ AC_MSG_ERROR([recode extension can not be configured together with:$recode_conflict])