aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-05-01 00:32:05 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-05-02 01:04:52 +0200
commite763ccc6cabab59335f50c29fc91f5a990146336 (patch)
tree13f6a24810023d53913cfb54857b43f392763131 /community
parent43a532f8542a757928c8e9d84e83f1ee14a4a2e6 (diff)
downloadaports-e763ccc6cabab59335f50c29fc91f5a990146336.tar.bz2
aports-e763ccc6cabab59335f50c29fc91f5a990146336.tar.xz
community/php7: remove unneeded headers and fix bogus perms
This is copied from Fedora spec.
Diffstat (limited to 'community')
-rw-r--r--community/php7/APKBUILD15
1 files changed, 15 insertions, 0 deletions
diff --git a/community/php7/APKBUILD b/community/php7/APKBUILD
index b9715f7021..8069b29436 100644
--- a/community/php7/APKBUILD
+++ b/community/php7/APKBUILD
@@ -89,6 +89,21 @@ prepare() {
error "Upstreram API version is now $vapi. Expecting $_apiver"
return 1
fi
+
+ # https://bugs.php.net/63362 - Not needed but installed headers.
+ # Drop some Windows specific headers to avoid installation,
+ # before build to ensure they are really not needed.
+ rm -f TSRM/tsrm_win32.h \
+ TSRM/tsrm_config.w32.h \
+ Zend/zend_config.w32.h \
+ ext/mysqlnd/config-win.h \
+ ext/standard/winver.h \
+ main/win32_internal_function_disabled.h \
+ main/win95nt.h
+
+ # Fix some bogus permissions.
+ find . -name \*.[ch] -exec chmod 644 {} \;
+
autoconf
}