aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-25 15:06:23 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-04-25 15:06:52 +0200
commitee8b4a8c062b3e068fd63f98969c8228a43cf5d0 (patch)
treeb0f5a51e51261c0105fc6bd5946dcd7075135315 /community
parentba7e0d18aced2857ebe6fc68eabbf95d9cf0e6e6 (diff)
downloadaports-ee8b4a8c062b3e068fd63f98969c8228a43cf5d0.tar.bz2
aports-ee8b4a8c062b3e068fd63f98969c8228a43cf5d0.tar.xz
community/llvm3.7: disable check() on armhf
It takes tooo long to run them on the armhf builder.
Diffstat (limited to 'community')
-rw-r--r--community/llvm3.7/APKBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/community/llvm3.7/APKBUILD b/community/llvm3.7/APKBUILD
index a3e0bb8ed8..ae6019d2af 100644
--- a/community/llvm3.7/APKBUILD
+++ b/community/llvm3.7/APKBUILD
@@ -25,6 +25,12 @@ source="http://llvm.org/releases/$pkgver/llvm-$pkgver.src.tar.xz
"
builddir="$srcdir/$_pkgname-$pkgver.src"
+# ARM has few failures in test suite that we don't care about currently and
+# also it takes forever to run them on the builder.
+case "$CARCH" in
+ arm*) options="!check";;
+esac
+
# NOTE: It seems that there's no (sane) way how to change includedir, sharedir
# etc. separately, just the CMAKE_INSTALL_PREFIX. Standard CMake variables and
# even LLVM-specific variables, that are related to these paths, actually
@@ -106,11 +112,7 @@ build() {
check() {
cd "$builddir"/build
- # ARM has few failures in test suite that we don't care about currently.
- case "$CARCH" in
- arm*) make check-llvm || true;;
- *) make check-llvm;;
- esac
+ make check-llvm
}
package() {