aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-04-28 13:09:33 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-04-28 13:10:24 +0000
commitfd2f7d89af2ed10eb4bdf11fbee0702d8cdad96a (patch)
treed58f6cce2881a3b9903ed92221ccda2bb9e24fb9 /community
parenta1ca9675abd7c94d042a5997914c988b52d9a504 (diff)
downloadaports-fd2f7d89af2ed10eb4bdf11fbee0702d8cdad96a.tar.bz2
aports-fd2f7d89af2ed10eb4bdf11fbee0702d8cdad96a.tar.xz
community/keepassx: moved from testing
Diffstat (limited to 'community')
-rw-r--r--community/keepassx/APKBUILD42
-rw-r--r--community/keepassx/add_unistd.patch10
-rw-r--r--community/keepassx/musl-fixes.patch10
3 files changed, 62 insertions, 0 deletions
diff --git a/community/keepassx/APKBUILD b/community/keepassx/APKBUILD
new file mode 100644
index 0000000000..9d71ceea9e
--- /dev/null
+++ b/community/keepassx/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Contributor: August Klein <amatcoder@gmail.com>
+# Maintainer: August Klein <amatcoder@gmail.com>
+pkgname=keepassx
+pkgver=2.0.3
+pkgrel=0
+pkgdesc="A password manager"
+url="http://www.keepassx.org"
+arch="all"
+license="GPL2"
+makedepends="cmake qt-dev libxtst-dev libgcrypt-dev"
+source="http://www.keepassx.org/releases/${pkgver}/${pkgname}-${pkgver}.tar.gz
+ musl-fixes.patch
+ "
+builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$builddir"
+ mkdir build
+ default_prepare
+}
+
+build() {
+ cd "$builddir"/build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+}
+
+check() {
+ cd "$builddir"/build
+ make test
+}
+
+package() {
+ cd "$builddir"/build
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="bf1a4ffa49fc4a6b7a27e6292981c9c13920712b4cd86759a99976f7e0593a243ea14575c57d664ba7e55d2449b5d83bc3d43a64a9a6972335e52234da79d773 keepassx-2.0.3.tar.gz
+f393ce341eb6941bfb808369f076585536802284ab7ee6034a26284dc70bbf168f4a89dc676357334e30a527a5593cb1b20cabb4e699ae806ca9e229ac6cffdd musl-fixes.patch"
diff --git a/community/keepassx/add_unistd.patch b/community/keepassx/add_unistd.patch
new file mode 100644
index 0000000000..f7d08027b2
--- /dev/null
+++ b/community/keepassx/add_unistd.patch
@@ -0,0 +1,10 @@
+--- a/src/lib/random.cpp
++++ b/src/lib/random.cpp
+@@ -18,6 +18,7 @@
+ * 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. *
+ ***************************************************************************/
+
++#include <unistd.h>
+ #include "random.h"
+
+
diff --git a/community/keepassx/musl-fixes.patch b/community/keepassx/musl-fixes.patch
new file mode 100644
index 0000000000..5afb7ed7c8
--- /dev/null
+++ b/community/keepassx/musl-fixes.patch
@@ -0,0 +1,10 @@
+--- a/src/core/qlockfile_unix.cpp.orig 2015-07-19 00:41:35.000000000 +0200
++++ b/src/core/qlockfile_unix.cpp 2015-07-21 20:01:02.607722077 +0200
+@@ -39,6 +39,7 @@
+ #include <QDebug>
+ #include <QDateTime>
+
++#include <fcntl.h>
+ #include <sys/file.h> // flock
+ #include <sys/types.h> // kill
+ #include <signal.h> // kill