aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2019-05-03 10:02:25 +0300
committerTimo Teräs <timo.teras@iki.fi>2019-05-03 10:17:55 +0300
commit2e0658e7daaf9c01158a887b2dd0ac78100a33a1 (patch)
tree8b725023d4def81734cae23a99614b7adb142b79 /community
parent479d863a996acb02176c4d84d4014cabc319c594 (diff)
downloadaports-2e0658e7daaf9c01158a887b2dd0ac78100a33a1.tar.bz2
aports-2e0658e7daaf9c01158a887b2dd0ac78100a33a1.tar.xz
community/lua-resty-jwt: backport from 3.9-stable
(cherry picked from commit ba0b70fc4c32a54e75beb6266588edd24802ea5d)
Diffstat (limited to 'community')
-rw-r--r--community/lua-resty-jwt/APKBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/community/lua-resty-jwt/APKBUILD b/community/lua-resty-jwt/APKBUILD
new file mode 100644
index 0000000000..8180e29f99
--- /dev/null
+++ b/community/lua-resty-jwt/APKBUILD
@@ -0,0 +1,21 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=lua-resty-jwt
+pkgver=0.2.0
+pkgrel=0
+pkgdesc="JSON Web Token library for OpenResty"
+url="https://github.com/cdbattags/lua-resty-jwt"
+arch="noarch"
+license="BSD2"
+depends="lua-resty-hmac"
+source="$pkgname-$pkgver.tar.gz::https://github.com/cdbattags/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+options="!check"
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir/usr/share/lua/common"
+ cp -r ./lib/resty "$pkgdir/usr/share/lua/common"
+}
+
+sha512sums="17b7a0251392a5e79b74a9c23ab229ab6578336148764fa489ef3add96d6b8211621ccede1c00889836567f2d09aee59f752c0a5247eaa12e2372c83f85efbb9 lua-resty-jwt-0.2.0.tar.gz"