aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-05-16 16:08:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-05-16 16:26:48 +0000
commit3115cc7982e319dc2e97f0b0fc1ec1607b90d998 (patch)
treec8bc27091f5c1d525da3a5f22d9f990a7975c8a3 /community
parent7151ceb8929179657c74ab10712965d39f417c44 (diff)
downloadaports-3115cc7982e319dc2e97f0b0fc1ec1607b90d998.tar.bz2
aports-3115cc7982e319dc2e97f0b0fc1ec1607b90d998.tar.xz
move main/gst-plugins-{good,bad,ugly}* to community
gst-plugins needs qt
Diffstat (limited to 'community')
-rw-r--r--community/gst-plugins-bad/APKBUILD79
-rw-r--r--community/gst-plugins-bad/libressl270-dtsl_method.patch18
-rw-r--r--community/gst-plugins-bad0.10/APKBUILD60
-rw-r--r--community/gst-plugins-bad0.10/libvpx-1.4.0.patch13
-rw-r--r--community/gst-plugins-good/APKBUILD118
-rw-r--r--community/gst-plugins-good0.10/0001-sys-v4l2-Some-blind-compilation-fixes.patch57
-rw-r--r--community/gst-plugins-good0.10/APKBUILD63
-rw-r--r--community/gst-plugins-good0.10/gst-plugins-good-gnome.post-install7
-rw-r--r--community/gst-plugins-good0.10/gst-plugins-good-gnome.post-upgrade7
-rw-r--r--community/gst-plugins-good0.10/gst-plugins-good-gnome.pre-deinstall7
-rw-r--r--community/gst-plugins-ugly/APKBUILD65
-rw-r--r--community/gst-plugins-ugly0.10/APKBUILD55
-rw-r--r--community/gst-plugins-ugly0.10/cdio-cd-text-api.patch183
13 files changed, 732 insertions, 0 deletions
diff --git a/community/gst-plugins-bad/APKBUILD b/community/gst-plugins-bad/APKBUILD
new file mode 100644
index 0000000000..e89fb93348
--- /dev/null
+++ b/community/gst-plugins-bad/APKBUILD
@@ -0,0 +1,79 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gst-plugins-bad
+pkgver=1.14.0
+pkgrel=1
+pkgdesc="GStreamer bad plugins"
+url="https://gstreamer.freedesktop.org/"
+arch="all"
+license="GPL-2.0-or-later LGPL-2.0-or-later"
+replaces="gst-plugins-bad1"
+options="!check" # most fail because: XDG_RUNTIME_DIR not set in the env.
+makedepends="
+ alsa-lib-dev
+ bluez-dev
+ bzip2-dev
+ curl-dev
+ faac-dev
+ faad2-dev
+ flite-dev
+ glib-dev
+ glu-dev
+ gsm-dev
+ gst-plugins-base-dev
+ gstreamer-dev
+ libdc1394-dev
+ libexif-dev
+ libmms-dev
+ libmodplug-dev
+ libressl-dev>=2.7.0
+ librsvg-dev
+ libvdpau-dev
+ libx11-dev
+ mesa-dev
+ neon-dev
+ orc-dev
+ directfb-dev
+ spandsp-dev
+ libwebp-dev
+ x265-dev
+ libass-dev
+ libsrtp-dev
+ orc-compiler
+ "
+subpackages="$pkgname-lang $pkgname-dev $pkgname-doc"
+source="https://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-$pkgver.tar.xz
+ libressl270-dtsl_method.patch"
+ldpath="/usr/lib/gstreamer-1.0"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-experimental \
+ --disable-fatal-warnings \
+ --with-package-name="GStreamer Bad Plugins (Alpine Linux)" \
+ --with-package-origin="http://alpinelinux.org/"
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+doc() {
+ default_doc
+ replaces="${pkgname}1-doc"
+}
+sha512sums="3f64dc428e2c1890f05d2c718215ff4b78a8262255ea61e746b436dc9ce1d3e0671db9cf3640f9a7453434297cac3a134272de7785818dfc5a6011ce8584842f gst-plugins-bad-1.14.0.tar.xz
+82106a8fa7ac01c63c3298c33a3b6177a4115f380d475634ea8ba4c67654f96275ab4b35eb4ea712a997165fefa7e9b65fd6b14ed3cea478c200d7e8d61423c4 libressl270-dtsl_method.patch"
diff --git a/community/gst-plugins-bad/libressl270-dtsl_method.patch b/community/gst-plugins-bad/libressl270-dtsl_method.patch
new file mode 100644
index 0000000000..6ea6085180
--- /dev/null
+++ b/community/gst-plugins-bad/libressl270-dtsl_method.patch
@@ -0,0 +1,18 @@
+--- a/ext/dtls/gstdtlsagent.c
++++ b/ext/dtls/gstdtlsagent.c
+@@ -176,11 +176,11 @@
+
+ ERR_clear_error ();
+
+-#if OPENSSL_VERSION_NUMBER >= 0x1000200fL
+- priv->ssl_context = SSL_CTX_new (DTLS_method ());
+-#else
++//#if OPENSSL_VERSION_NUMBER >= 0x1000200fL
++ // priv->ssl_context = SSL_CTX_new (DTLS_method ());
++//#else
+ priv->ssl_context = SSL_CTX_new (DTLSv1_method ());
+-#endif
++//#endif
+ if (ERR_peek_error () || !priv->ssl_context) {
+ char buf[512];
+
diff --git a/community/gst-plugins-bad0.10/APKBUILD b/community/gst-plugins-bad0.10/APKBUILD
new file mode 100644
index 0000000000..c84e7a301d
--- /dev/null
+++ b/community/gst-plugins-bad0.10/APKBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gst-plugins-bad0.10
+pkgver=0.10.23
+pkgrel=9
+pkgdesc="GStreamer bad plugins"
+url="https://gstreamer.freedesktop.org/"
+arch="all"
+license="LGPL GPL"
+depends=""
+replaces="gst-plugins-bad"
+subpackages="$pkgname-lang $pkgname-dev $pkgname-doc"
+makedepends="gst-plugins-base0.10-dev gstreamer0.10-dev xvidcore-dev bzip2-dev
+ neon-dev faac-dev libexif-dev faad2-dev glib-dev orc-dev
+ alsa-lib-dev libx11-dev sdl-dev libvpx-dev libdc1394-dev
+ libmms-dev gsm-dev flite-dev orc-dev jasper-dev librsvg-dev"
+
+source="https://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-$pkgver.tar.bz2
+ libvpx-1.4.0.patch
+ "
+
+_builddir="$srcdir/gst-plugins-bad-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ update_config_sub || return 1
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static \
+ --disable-modplug \
+ --enable-experimental \
+ --with-package-name="GStreamer Bad Plugins (Alpine Linux)" \
+ --with-package-origin="http://www.alpinelinux.org/" \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="fcb09798114461955260e4d940db5987 gst-plugins-bad-0.10.23.tar.bz2
+3843843f65ce46970c08f90dfcd0003b libvpx-1.4.0.patch"
+sha256sums="0eae7d1a1357ae8377fded6a1b42e663887beabe0e6cc336e2ef9ada42e11491 gst-plugins-bad-0.10.23.tar.bz2
+6088e8935bf9873d75f229675560c7ef134186298074ebdff55b012a1b4056c9 libvpx-1.4.0.patch"
+sha512sums="da73c4dcfcfd5afe8414920d83b6b2d4634daacfca70653e850e9a7ec519275b9b1b76f46aa8b87c0c5dcd8696d5b05b7c54a0f66698725e7f726b81eb367ddb gst-plugins-bad-0.10.23.tar.bz2
+399e4996945a75fa6f1a440dd204b191f1a6386757c62a63c1bd020958d54978b3e97a5cff3d8154ce103b15c7798d6dadb2fd8e049bce7b429459aaa128be70 libvpx-1.4.0.patch"
diff --git a/community/gst-plugins-bad0.10/libvpx-1.4.0.patch b/community/gst-plugins-bad0.10/libvpx-1.4.0.patch
new file mode 100644
index 0000000000..fc4c94098e
--- /dev/null
+++ b/community/gst-plugins-bad0.10/libvpx-1.4.0.patch
@@ -0,0 +1,13 @@
+--- ./ext/vp8/gstvp8utils.h.orig
++++ ./ext/vp8/gstvp8utils.h
+@@ -26,10 +26,6 @@
+ G_BEGIN_DECLS
+
+ /* Some compatibility defines for older libvpx versions */
+-#ifndef VPX_IMG_FMT_I420
+-#define VPX_IMG_FMT_I420 IMG_FMT_I420
+-#endif
+-
+ #ifndef VPX_PLANE_Y
+ #define VPX_PLANE_Y PLANE_Y
+ #endif
diff --git a/community/gst-plugins-good/APKBUILD b/community/gst-plugins-good/APKBUILD
new file mode 100644
index 0000000000..e7423e34f1
--- /dev/null
+++ b/community/gst-plugins-good/APKBUILD
@@ -0,0 +1,118 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gst-plugins-good
+pkgver=1.14.0
+pkgrel=0
+pkgdesc="GStreamer Multimedia Framework Good Plugins"
+url="https://gstreamer.freedesktop.org/"
+arch="all"
+license="GPL-2.0-or-later LGPL-2.0-or-later"
+subpackages="$pkgname-lang $pkgname-doc $pkgname-qt $pkgname-gtk"
+replaces="gst-plugins-good1"
+makedepends="
+ gstreamer-dev
+ gst-plugins-base-dev
+ flac-dev
+ gdk-pixbuf-dev
+ glib-dev
+ jack-dev
+ libavc1394-dev
+ libdv-dev
+ libgudev-dev
+ libice-dev
+ libiec61883-dev
+ libjpeg-turbo-dev
+ libogg-dev
+ libpng-dev
+ libshout-dev
+ libsm-dev
+ libsoup-dev
+ libvpx-dev
+ libxdamage-dev
+ libxext-dev
+ libxv-dev
+ linux-headers
+ orc-dev
+ taglib-dev
+ v4l-utils-dev
+ wavpack-dev
+ zlib-dev
+ mpg123-dev
+ lame-dev
+ gtk+3.0-dev
+ qt5-qtdeclarative-dev
+ qt5-x11extras-dev
+ libcaca-dev
+ cairo-dev
+ orc-compiler
+ "
+ldpath="/usr/lib/gstreamer-1.0"
+source="https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-$pkgver.tar.xz"
+options="!check" # elements/souphttpsrc fails
+
+# secfixes:
+# 1.10.4-r0:
+# - CVE-2017-5840
+# - CVE-2017-5841
+# - CVE-2017-5845
+# - CVE-2016-9634
+# - CVE-2016-9635
+# - CVE-2016-9636
+# - CVE-2016-9808
+# - CVE-2016-10198
+# - CVE-2016-10199
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-experimental \
+ --disable-fatal-warnings \
+ --with-package-name="GStreamer Good Plugins (Alpine Linux)" \
+ --with-package-origin="http://alpinelinux.org/"
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
+ make DESTDIR="$pkgdir" install
+}
+
+_mv() {
+ mkdir -p "$subpkgdir"/"$ldpath"
+ mv "$1" "$subpkgdir"/"$ldpath"
+}
+
+qt() {
+ pkgdesc="Gstreamer Qt plugin."
+ for i in $(find "$pkgdir" -type f ); do
+ if ldd $i 2>/dev/null | grep -q "libQt"; then
+ _mv "$i" || return 1
+ fi
+ done
+}
+
+gtk() {
+ pkgdesc="Gstreamer gtk-3 plugin."
+ for i in $(find "$pkgdir" -type f ); do
+ if ldd $i 2>/dev/null | grep -q "libgtk-3"; then
+ _mv "$i" || return 1
+ fi
+ done
+}
+
+doc() {
+ default_doc
+ replaces="${pkgname}1-doc"
+}
+sha512sums="f8d64978234bcc32fadb203c96b4013943d2cde345eaddcfd28e115e758f6c6ae15ae5ca1f94c4e59e447a7fe0171f10ed2a2c9ca4b6bb6eca2cbf69f8477811 gst-plugins-good-1.14.0.tar.xz"
diff --git a/community/gst-plugins-good0.10/0001-sys-v4l2-Some-blind-compilation-fixes.patch b/community/gst-plugins-good0.10/0001-sys-v4l2-Some-blind-compilation-fixes.patch
new file mode 100644
index 0000000000..e03fdac894
--- /dev/null
+++ b/community/gst-plugins-good0.10/0001-sys-v4l2-Some-blind-compilation-fixes.patch
@@ -0,0 +1,57 @@
+From fa21c0bb253213c9dc48ce72faaf7090dc8a3554 Mon Sep 17 00:00:00 2001
+From: Colin Walters <walters@verbum.org>
+Date: Thu, 2 May 2013 16:16:46 -0400
+Subject: [PATCH] sys/v4l2: Some blind compilation fixes
+
+---
+ sys/v4l2/gstv4l2bufferpool.c | 1 -
+ sys/v4l2/v4l2_calls.c | 12 ++++--------
+ 2 files changed, 4 insertions(+), 9 deletions(-)
+
+diff --git a/sys/v4l2/gstv4l2bufferpool.c b/sys/v4l2/gstv4l2bufferpool.c
+index a0b4c84..3916815 100644
+--- a/sys/v4l2/gstv4l2bufferpool.c
++++ b/sys/v4l2/gstv4l2bufferpool.c
+@@ -182,7 +182,6 @@ gst_v4l2_buffer_new (GstV4l2BufferPool * pool, guint index, GstCaps * caps)
+ GST_LOG_OBJECT (pool->v4l2elem, " MMAP offset: %u",
+ ret->vbuffer.m.offset);
+ GST_LOG_OBJECT (pool->v4l2elem, " length: %u", ret->vbuffer.length);
+- GST_LOG_OBJECT (pool->v4l2elem, " input: %u", ret->vbuffer.input);
+
+ ret->mmap_length = ret->vbuffer.length;
+ data = (guint8 *) v4l2_mmap (0, ret->vbuffer.length,
+diff --git a/sys/v4l2/v4l2_calls.c b/sys/v4l2/v4l2_calls.c
+index 309bfb6..ee3ff9f 100644
+--- a/sys/v4l2/v4l2_calls.c
++++ b/sys/v4l2/v4l2_calls.c
+@@ -53,14 +53,6 @@
+
+ #include "gst/gst-i18n-plugin.h"
+
+-/* Those are ioctl calls */
+-#ifndef V4L2_CID_HCENTER
+-#define V4L2_CID_HCENTER V4L2_CID_HCENTER_DEPRECATED
+-#endif
+-#ifndef V4L2_CID_VCENTER
+-#define V4L2_CID_VCENTER V4L2_CID_VCENTER_DEPRECATED
+-#endif
+-
+ GST_DEBUG_CATEGORY_EXTERN (v4l2_debug);
+ #define GST_CAT_DEFAULT v4l2_debug
+
+@@ -294,8 +286,12 @@ gst_v4l2_fill_lists (GstV4l2Object * v4l2object)
+ break;
+ case V4L2_CID_HFLIP:
+ case V4L2_CID_VFLIP:
++#ifdef V4L2_CID_HCENTER
+ case V4L2_CID_HCENTER:
++#endif
++#ifdef V4L2_CID_VCENTER
+ case V4L2_CID_VCENTER:
++#endif
+ #ifdef V4L2_CID_PAN_RESET
+ case V4L2_CID_PAN_RESET:
+ #endif
+--
+1.7.1
+
diff --git a/community/gst-plugins-good0.10/APKBUILD b/community/gst-plugins-good0.10/APKBUILD
new file mode 100644
index 0000000000..c713182a9c
--- /dev/null
+++ b/community/gst-plugins-good0.10/APKBUILD
@@ -0,0 +1,63 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gst-plugins-good0.10
+pkgver=0.10.31
+pkgrel=1
+pkgdesc="GStreamer Multimedia Framework Good Plugins"
+url="https://gstreamer.freedesktop.org/"
+arch="all"
+license="LGPL"
+subpackages="$pkgname-lang"
+depends=
+replaces="gst-plugins-good"
+depends_dev="gstreamer0.10-dev gst-plugins-base0.10-dev"
+makedepends="linux-headers $depends_dev glib-dev orc-dev
+ libsoup-dev flac-dev libogg-dev taglib-dev libjpeg-turbo-dev zlib-dev
+ wavpack-dev libavc1394-dev libiec61883-dev libshout-dev libdv-dev
+ orc-dev libxext libsm-dev libice-dev libxv-dev"
+
+source="https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-$pkgver.tar.bz2
+ 0001-sys-v4l2-Some-blind-compilation-fixes.patch
+ "
+
+
+_builddir="$srcdir"/gst-plugins-good-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-experimental \
+ --with-package-name="GStreamer Good Plugins (Alpine Linux)" \
+ --with-package-origin="http://www.alpinelinux.org/" \
+ || return 1
+ make
+}
+
+package() {
+ cd "$_builddir"
+
+ export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="24f98a294a2b521e1b29412bdadae2e6 gst-plugins-good-0.10.31.tar.bz2
+50a54d7ad0ce0903e25d7059ccd157e4 0001-sys-v4l2-Some-blind-compilation-fixes.patch"
+sha256sums="7e27840e40a7932ef2dc032d7201f9f41afcaf0b437daf5d1d44dc96d9e35ac6 gst-plugins-good-0.10.31.tar.bz2
+24f615180a99c2034d81d783c3f8ac5493205966e272daaff5cb1d06e08e0a2f 0001-sys-v4l2-Some-blind-compilation-fixes.patch"
+sha512sums="dc81eb37cdd9f656419d967347a9b85ce51ae5733680317ac2c84d82816b6dbd1117ae3ef1a5c7d01e90cdc791d3d27ee9e8355a2793ea381a873809c9566bbe gst-plugins-good-0.10.31.tar.bz2
+de2f1257f2341b01cdf2832a40ed6979c04b86ee89a70f9649ff46bf4255cae5f969a4f8f864d39fed7352edb0184c6b5954ac0f27a20cefce61dde25ad36190 0001-sys-v4l2-Some-blind-compilation-fixes.patch"
diff --git a/community/gst-plugins-good0.10/gst-plugins-good-gnome.post-install b/community/gst-plugins-good0.10/gst-plugins-good-gnome.post-install
new file mode 100644
index 0000000000..35c28f3eba
--- /dev/null
+++ b/community/gst-plugins-good0.10/gst-plugins-good-gnome.post-install
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+for i in gstreamer-0.10.schemas; do
+ echo "Installing GConf2 schema $i."
+ GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
+ /usr/bin/gconftool-2 --makefile-install-rule /etc/gconf/schemas/$i >/dev/null
+done
diff --git a/community/gst-plugins-good0.10/gst-plugins-good-gnome.post-upgrade b/community/gst-plugins-good0.10/gst-plugins-good-gnome.post-upgrade
new file mode 100644
index 0000000000..35c28f3eba
--- /dev/null
+++ b/community/gst-plugins-good0.10/gst-plugins-good-gnome.post-upgrade
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+for i in gstreamer-0.10.schemas; do
+ echo "Installing GConf2 schema $i."
+ GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
+ /usr/bin/gconftool-2 --makefile-install-rule /etc/gconf/schemas/$i >/dev/null
+done
diff --git a/community/gst-plugins-good0.10/gst-plugins-good-gnome.pre-deinstall b/community/gst-plugins-good0.10/gst-plugins-good-gnome.pre-deinstall
new file mode 100644
index 0000000000..5facd9964d
--- /dev/null
+++ b/community/gst-plugins-good0.10/gst-plugins-good-gnome.pre-deinstall
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+for i in gstreamer-0.10.schemas; do
+ echo "Uninstalling GConf2 schema $i."
+ GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
+ /usr/bin/gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/$i >/dev/null
+done
diff --git a/community/gst-plugins-ugly/APKBUILD b/community/gst-plugins-ugly/APKBUILD
new file mode 100644
index 0000000000..6582cd70c4
--- /dev/null
+++ b/community/gst-plugins-ugly/APKBUILD
@@ -0,0 +1,65 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gst-plugins-ugly
+pkgver=1.14.0
+pkgrel=1
+pkgdesc="GStreamer Multimedia Framework Ugly Plugins (gst-plugins-ugly)"
+url="https://gstreamer.freedesktop.org/"
+arch="all"
+license="GPL-2.0-or-later LGPL-2.0-or-later"
+replaces="gst-plugins-ugly1"
+makedepends="
+ a52dec-dev
+ glib-dev
+ gst-plugins-base-dev
+ gstreamer-dev
+ libcdio-dev
+ libdvdread-dev
+ libmpeg2-dev
+ orc-dev
+ x264-dev
+ "
+source="https://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-$pkgver.tar.xz"
+subpackages="$pkgname-lang"
+ldpath="/usr/lib/gstreamer-1.0"
+
+# secfixes:
+# 1.10.4-r0:
+# - CVE-2017-5846
+# - CVE-2017-5847
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-experimental \
+ --enable-a52dec \
+ --enable-cdio \
+ --enable-dvdread \
+ --enable-mpeg2dec \
+ --enable-x264 \
+ --disable-fatal-warnings \
+ --with-package-name="GStreamer Ugly Plugins (Alpine Linux)" \
+ --with-package-origin="http://alpinelinux.org/"
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+doc() {
+ default_doc
+ replaces="${pkgname}1-doc"
+}
+sha512sums="f3a12318536c41fe77efb63ab3d2feba9e586ea3f0da9d4f48b1710236a5932b191fb1e14734be82f7c3855574036baafd3e48fa7ac37091f05a47c37103eefb gst-plugins-ugly-1.14.0.tar.xz"
diff --git a/community/gst-plugins-ugly0.10/APKBUILD b/community/gst-plugins-ugly0.10/APKBUILD
new file mode 100644
index 0000000000..f3567af753
--- /dev/null
+++ b/community/gst-plugins-ugly0.10/APKBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gst-plugins-ugly0.10
+pkgver=0.10.19
+pkgrel=4
+pkgdesc="GStreamer Multimedia Framework Ugly Plugins (gst-plugins-ugly)"
+url="https://gstreamer.freedesktop.org/"
+arch="all"
+license="LGPL"
+depends=
+replaces="gst-plugins-ugly"
+makedepends="lame-dev libmpeg2-dev a52dec-dev libid3tag-dev libmad-dev
+ glib-dev orc-dev gstreamer0.10-dev gst-plugins-base0.10-dev
+ x264-dev libcdio-dev libcdio-paranoia-dev libid3tag-dev orc-dev"
+source="https://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-$pkgver.tar.bz2
+ cdio-cd-text-api.patch"
+subpackages="$pkgname-lang"
+
+_builddir="$srcdir"/gst-plugins-ugly-$pkgver
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-experimental \
+ --with-package-name="GStreamer Ugly Plugins (Alpine Linux)" \
+ --with-package-origin="http://www.alpinelinux.org/" \
+ || return 1
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="1d81c593e22a6cdf0f2b4f57eae93df2 gst-plugins-ugly-0.10.19.tar.bz2
+6c1c665f864387f3a77d32231fedeaab cdio-cd-text-api.patch"
+sha256sums="1ca90059275c0f5dca71d4d1601a8f429b7852baed0723e820703b977e2c8df0 gst-plugins-ugly-0.10.19.tar.bz2
+2a8aa4cd019fab333f1f8377bf7afa426d3038a033361d90fab70c335e9a53e7 cdio-cd-text-api.patch"
+sha512sums="27ae79653f73a143b1dfd864b16b8f1a43d54538a5802d937cb29ce82d5681604c2b3c3fe68c7debf4a319b09bee880a5a95fc48dce83c6cb9753397a1e300d3 gst-plugins-ugly-0.10.19.tar.bz2
+16b65f3140554212bb5454b0bfdc3d5a27627076aabab3ed23e124210a18f41888b488afa1a74ecc9939213cbc61dae1ff6a9055f1929f1803208e2414792de8 cdio-cd-text-api.patch"
diff --git a/community/gst-plugins-ugly0.10/cdio-cd-text-api.patch b/community/gst-plugins-ugly0.10/cdio-cd-text-api.patch
new file mode 100644
index 0000000000..cbd16b8e48
--- /dev/null
+++ b/community/gst-plugins-ugly0.10/cdio-cd-text-api.patch
@@ -0,0 +1,183 @@
+From 649bd92cd2600719862ad5189899212409dd0a67 Mon Sep 17 00:00:00 2001
+From: Leon Merten Lohse <leon@green-side.de>
+Date: Thu, 03 May 2012 22:50:30 +0000
+Subject: cdio: compensate for libcdio's recent cd-text api changes
+
+https://bugzilla.gnome.org/show_bug.cgi?id=675112
+
+Conflicts:
+
+ ext/cdio/gstcdiocddasrc.c
+---
+diff --git a/ext/cdio/gstcdio.c b/ext/cdio/gstcdio.c
+index 2f58d18..483ebf5 100644
+--- a/ext/cdio/gstcdio.c
++++ b/ext/cdio/gstcdio.c
+@@ -30,12 +30,16 @@
+ GST_DEBUG_CATEGORY (gst_cdio_debug);
+
+ void
+-gst_cdio_add_cdtext_field (GstObject * src, cdtext_t * cdtext,
++gst_cdio_add_cdtext_field (GstObject * src, cdtext_t * cdtext, track_t track,
+ cdtext_field_t field, const gchar * gst_tag, GstTagList ** p_tags)
+ {
+ const gchar *txt;
+
++#if LIBCDIO_VERSION_NUM > 83
++ txt = cdtext_get_const (cdtext, field, track);
++#else
+ txt = cdtext_get_const (field, cdtext);
++#endif
+ if (txt == NULL || *txt == '\0') {
+ GST_DEBUG_OBJECT (src, "empty CD-TEXT field %u (%s)", field, gst_tag);
+ return;
+@@ -57,6 +61,12 @@ gst_cdio_add_cdtext_field (GstObject * src, cdtext_t * cdtext,
+ }
+
+ GstTagList *
++#if LIBCDIO_VERSION_NUM > 83
++gst_cdio_get_cdtext (GstObject * src, cdtext_t * t, track_t track)
++{
++ GstTagList *tags = NULL;
++
++#else
+ gst_cdio_get_cdtext (GstObject * src, CdIo * cdio, track_t track)
+ {
+ GstTagList *tags = NULL;
+@@ -67,14 +77,22 @@ gst_cdio_get_cdtext (GstObject * src, CdIo * cdio, track_t track)
+ GST_DEBUG_OBJECT (src, "no CD-TEXT for track %u", track);
+ return NULL;
+ }
++#endif
+
+- gst_cdio_add_cdtext_field (src, t, CDTEXT_PERFORMER, GST_TAG_ARTIST, &tags);
+- gst_cdio_add_cdtext_field (src, t, CDTEXT_TITLE, GST_TAG_TITLE, &tags);
++ gst_cdio_add_cdtext_field (src, t, track, CDTEXT_FIELD_PERFORMER,
++ GST_TAG_ARTIST, &tags);
++ gst_cdio_add_cdtext_field (src, t, track, CDTEXT_FIELD_TITLE, GST_TAG_TITLE,
++ &tags);
+
+ return tags;
+ }
+
+ void
++#if LIBCDIO_VERSION_NUM > 83
++gst_cdio_add_cdtext_album_tags (GstObject * src, cdtext_t * t,
++ GstTagList * tags)
++{
++#else
+ gst_cdio_add_cdtext_album_tags (GstObject * src, CdIo * cdio, GstTagList * tags)
+ {
+ cdtext_t *t;
+@@ -84,11 +102,14 @@ gst_cdio_add_cdtext_album_tags (GstObject * src, CdIo * cdio, GstTagList * tags)
+ GST_DEBUG_OBJECT (src, "no CD-TEXT for album");
+ return;
+ }
++#endif
+
+- /* FIXME: map CDTEXT_PERFORMER to GST_TAG_ALBUM_ARTIST once we have that */
+- gst_cdio_add_cdtext_field (src, t, CDTEXT_TITLE, GST_TAG_ALBUM, &tags);
+- gst_cdio_add_cdtext_field (src, t, CDTEXT_GENRE, GST_TAG_GENRE, &tags);
+-
++ gst_cdio_add_cdtext_field (src, t, 0, CDTEXT_FIELD_PERFORMER,
++ GST_TAG_ALBUM_ARTIST, &tags);
++ gst_cdio_add_cdtext_field (src, t, 0, CDTEXT_FIELD_TITLE, GST_TAG_ALBUM,
++ &tags);
++ gst_cdio_add_cdtext_field (src, t, 0, CDTEXT_FIELD_GENRE, GST_TAG_GENRE,
++ &tags);
+ GST_DEBUG ("CD-TEXT album tags: %" GST_PTR_FORMAT, tags);
+ }
+
+diff --git a/ext/cdio/gstcdio.h b/ext/cdio/gstcdio.h
+index ef31ed0..c6da580 100644
+--- a/ext/cdio/gstcdio.h
++++ b/ext/cdio/gstcdio.h
+@@ -24,22 +24,38 @@
+ #include <gst/gst.h>
+ #include <cdio/cdio.h>
+ #include <cdio/cdtext.h>
++#include <cdio/version.h>
++
++#if LIBCDIO_VERSION_NUM <= 83
++ #define CDTEXT_FIELD_PERFORMER CDTEXT_PERFORMER
++ #define CDTEXT_FIELD_GENRE CDTEXT_GENRE
++ #define CDTEXT_FIELD_TITLE CDTEXT_TITLE
++#endif
+
+ GST_DEBUG_CATEGORY_EXTERN (gst_cdio_debug);
+ #define GST_CAT_DEFAULT gst_cdio_debug
+
+ void gst_cdio_add_cdtext_field (GstObject * src,
+ cdtext_t * cdtext,
++ track_t track,
+ cdtext_field_t field,
+ const gchar * gst_tag,
+ GstTagList ** p_tags);
+
+ GstTagList * gst_cdio_get_cdtext (GstObject * src,
++#if LIBCDIO_VERSION_NUM > 83
++ cdtext_t * t,
++#else
+ CdIo * cdio,
++#endif
+ track_t track);
+
+ void gst_cdio_add_cdtext_album_tags (GstObject * src,
++#if LIBCDIO_VERSION_NUM > 83
++ cdtext_t * t,
++#else
+ CdIo * cdio,
++#endif
+ GstTagList * tags);
+
+ #endif /* __GST_CDIO_H__ */
+diff --git a/ext/cdio/gstcdiocddasrc.c b/ext/cdio/gstcdiocddasrc.c
+index 615a0c8..830839e 100644
+--- a/ext/cdio/gstcdiocddasrc.c
++++ b/ext/cdio/gstcdiocddasrc.c
+@@ -206,6 +206,9 @@ gst_cdio_cdda_src_open (GstAudioCdSrc * audiocdsrc, const gchar * device)
+ GstCdioCddaSrc *src;
+ discmode_t discmode;
+ gint first_track, num_tracks, i;
++#if LIBCDIO_VERSION_NUM > 83
++ cdtext_t *cdtext;
++#endif
+
+ src = GST_CDIO_CDDA_SRC (audiocdsrc);
+
+@@ -232,8 +235,18 @@ gst_cdio_cdda_src_open (GstAudioCdSrc * audiocdsrc, const gchar * device)
+ if (src->read_speed != -1)
+ cdio_set_speed (src->cdio, src->read_speed);
+
++#if LIBCDIO_VERSION_NUM > 83
++ cdtext = cdio_get_cdtext (src->cdio);
++
++ if (NULL == cdtext)
++ GST_DEBUG_OBJECT (src, "no CD-TEXT on disc");
++ else
++ gst_cdio_add_cdtext_album_tags (GST_OBJECT_CAST (src), cdtext,
++ cddabasesrc->tags);
++#else
+ gst_cdio_add_cdtext_album_tags (GST_OBJECT_CAST (src), src->cdio,
+ cddabasesrc->tags);
++#endif
+
+ GST_LOG_OBJECT (src, "%u tracks, first track: %d", num_tracks, first_track);
+
+@@ -250,8 +263,14 @@ gst_cdio_cdda_src_open (GstAudioCdSrc * audiocdsrc, const gchar * device)
+ * the right thing here (for cddb id calculations etc. as well) */
+ track.start = cdio_get_track_lsn (src->cdio, i + first_track);
+ track.end = track.start + len_sectors - 1; /* -1? */
++#if LIBCDIO_VERSION_NUM > 83
++ if (NULL != cdtext)
++ track.tags = gst_cdio_get_cdtext (GST_OBJECT (src), cdtext,
++ i + first_track);
++#else
+ track.tags = gst_cdio_get_cdtext (GST_OBJECT (src), src->cdio,
+ i + first_track);
++#endif
+
+ gst_audio_cd_src_add_track (GST_AUDIO_CD_SRC (src), &track);
+ }
+--
+cgit v0.9.0.2-2-gbebe