aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorSimon Frankenberger <simon@fraho.eu>2020-05-09 11:50:57 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-05-09 20:06:43 +0000
commit739575ba4c9b54d8b43fc7891423f41455bd138b (patch)
tree1262fa93835a1e259203dc2709d9dc78e462f6bb /community
parent04f4314af8b80725a35cb8a14801c63d813f7495 (diff)
downloadaports-739575ba4c9b54d8b43fc7891423f41455bd138b.tar.bz2
aports-739575ba4c9b54d8b43fc7891423f41455bd138b.tar.xz
community/openjdk11: Upgrade to 11.0.7
Diffstat (limited to 'community')
-rw-r--r--community/openjdk11/APKBUILD14
-rw-r--r--community/openjdk11/aarch64.patch11
-rw-r--r--community/openjdk11/build.patch45
-rw-r--r--community/openjdk11/fix-bootjdk-check.patch10
-rw-r--r--community/openjdk11/make-4.3.patch17
-rw-r--r--community/openjdk11/ppc64le.patch7
6 files changed, 52 insertions, 52 deletions
diff --git a/community/openjdk11/APKBUILD b/community/openjdk11/APKBUILD
index 1fca9f82b4..11317dd8f1 100644
--- a/community/openjdk11/APKBUILD
+++ b/community/openjdk11/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Simon Frankenberger <simon-alpine@fraho.eu>
# Maintainer: Simon Frankenberger <simon-alpine@fraho.eu>
pkgname=openjdk11
-pkgver=11.0.6_p10
+pkgver=11.0.7_p10
_pkgver=${pkgver/_p10/-ga}
pkgrel=1
pkgdesc="Oracle OpenJDK 11"
@@ -48,7 +48,6 @@ source="jdk-$_pkgver.tar.gz::https://github.com/openjdk/jdk11u/archive/jdk-$_pkg
build.patch
aarch64.patch
ppc64le.patch
- make-4.3.patch
fix-bootjdk-check.patch
HelloWorld.java
@@ -292,12 +291,11 @@ _jdk() {
mv "$_fromroot/include" "$_toroot"
}
-sha512sums="2a75f9323a242cf8585b06c79594dbd381ad72897e215c7d567819a68559ec6207a73f4aaf26a48de96f9b132148ea2f28ea7171d6642219b60f8cc5c3a6779f jdk-11.0.6-ga.tar.gz
-66a9f2736da87de09d7bcc136771ab760bdba7847f3a23b2aa4efbc2e55ac8b49510c6d7afdf3f8d046c6e3fe9dca0d4cb0b5a38d7a3aebaf86fa0e3cc635eac build.patch
-8c0f1f8d2a78ebb30a8460bc0ea9cd2349cea98819df1577bf7de19a1dd82d06a593f36b4e17c282ed53d23f00163e387e3dd1f3c9e5a092726e78c3aa710370 aarch64.patch
-592bf6c1be99879735f0b2484d7d286be049170f5fb7de8526b452cde732e97f2b9b5b0af0073ec0a525bd52ce9f207a7dcace9d9d83a950eee38b11d6f5ad8d ppc64le.patch
-a819eb321b925d626f26d0095603cf44040edc5e9d7f5d2f51a54ddc544d2933d0fa3c766645e8eea2cbdf57066f677d8c013e8bfea1ae943e4605441703c89f make-4.3.patch
-68cb40368122a6e8c83273cbd81b811546f7986a45260a74f0a9536591a98c78902fe089813963ea0b7fdead178a3d737b421de8883eeff779ab2f702b15bc10 fix-bootjdk-check.patch
+sha512sums="d85ee1047e11ff635c21a1c3a9b4984e4966bf23bb5239cc7d5844253adea5a26749601e8017b829217b65650790e607bd4bb3c9c879f3831e7b72cc5024ffd1 jdk-11.0.7-ga.tar.gz
+90f22a31b166f185bf0f020d10d963789a65bd3dd4d27380ce128c43e2da5169ec404f46847d56c091b0e30cee0e796ec853578d12f84eec353f38d7bed608ae build.patch
+7233c538cfab3eabe01dd4ba3ed59ddc8b60270274230f2e63ddabefd870236289589546cb1a889e03875425702a7c53c8a729c464e8e9b7ce1e8da3458498c2 aarch64.patch
+70befffede4f9e2fd7a7925da190e4feaa37a7b11d1800dadbbe0b14fa723d2f5dea108dc90231b12326b68eeb80b9a7309120bd2c67219f95d6210269a78467 ppc64le.patch
+0a0c7d058eb141c9ca6fe7b94d983df20e01cbe2658b236556b322ce0b3b06e5a0c4de3697d738a71700df48d668194a031d887215bde3f42f47925bf9c27dba fix-bootjdk-check.patch
d1767dddd8e0956e25c0f77ed45c6fc86a1191bae1704a6dc33be490fd20eaa50461fe5c2a3349512059d555651e2eb41437dd3c1096c351e8ee68b4534a2579 HelloWorld.java
27e91edef89d26c0c5b9a813e2045f8d2b348745a506ae37b34b660fa7093da9a4e0e676ea41dc4a5c901bce02e5304d95e90f68d6c99cbf461b2da40a7a9853 TestECDSA.java
b02dff8d549f88317bb4c741a9e269e8d59eef990197d085388fc49c7423a4eb9367dbe1e02bffb10e7862f5980301eb58d4494e177d0e8f60af6b05c7fbbe60 TestCryptoLevel.java
diff --git a/community/openjdk11/aarch64.patch b/community/openjdk11/aarch64.patch
index 26484ca080..c0fa972ae1 100644
--- a/community/openjdk11/aarch64.patch
+++ b/community/openjdk11/aarch64.patch
@@ -1,10 +1,15 @@
+Author: Simon Frankenberger <simon-alpine@fraho.eu>
+Upstream: no
+Reason: This file is not present when building on aarch64 alpine.
+ Furthermore, the build runs just fine without it.
+
--- old/src/hotspot/os_cpu/linux_aarch64/os_linux_aarch64.cpp
+++ new/src/hotspot/os_cpu/linux_aarch64/os_linux_aarch64.cpp
-@@ -77,7 +77,6 @@
+@@ -74,7 +74,6 @@
# include <pwd.h>
# include <poll.h>
# include <ucontext.h>
-# include <fpu_control.h>
- #ifdef BUILTIN_SIM
- #define REG_SP REG_RSP
+ #define REG_FP 29
+ #define REG_LR 30
diff --git a/community/openjdk11/build.patch b/community/openjdk11/build.patch
index 12691fbb65..92ae8ba5e0 100644
--- a/community/openjdk11/build.patch
+++ b/community/openjdk11/build.patch
@@ -1,3 +1,10 @@
+Author: The portola team at https://openjdk.java.net/projects/portola/
+ With modifications by Simon Frankenberger <simon-alpine@fraho.eu>
+Upstream: somewhat
+Reason: This giant patch makes it possible to compile openjdk with musl libc.
+ The base was taken from a diff with the portola project and adjusted
+ for latest musl libc.
+
--- old/make/ReleaseFile.gmk
+++ new/make/ReleaseFile.gmk
@@ -53,6 +53,7 @@
@@ -30,7 +37,7 @@
if test $? = 0; then
--- old/make/hotspot/lib/CompileJvm.gmk
+++ new/make/hotspot/lib/CompileJvm.gmk
-@@ -77,6 +77,7 @@
+@@ -79,6 +79,7 @@
-DHOTSPOT_BUILD_USER='"$(USERNAME)"' \
-DHOTSPOT_VM_DISTRO='"$(HOTSPOT_VM_DISTRO)"' \
-DCPU='"$(OPENJDK_TARGET_CPU_VM_VERSION)"' \
@@ -40,7 +47,7 @@
################################################################################
--- old/make/lib/CoreLibraries.gmk
+++ new/make/lib/CoreLibraries.gmk
-@@ -241,6 +241,7 @@
+@@ -219,6 +219,7 @@
endif
LIBJLI_CFLAGS += $(LIBZ_CFLAGS)
@@ -50,7 +57,7 @@
LIBJLI_EXTRA_FILES += \
--- old/src/hotspot/os/linux/os_linux.cpp
+++ new/src/hotspot/os/linux/os_linux.cpp
-@@ -99,7 +99,6 @@
+@@ -101,7 +101,6 @@
# include <string.h>
# include <syscall.h>
# include <sys/sysinfo.h>
@@ -58,7 +65,7 @@
# include <sys/ipc.h>
# include <sys/shm.h>
# include <link.h>
-@@ -511,6 +510,11 @@
+@@ -594,6 +593,11 @@
// detecting pthread library
void os::Linux::libpthread_init() {
@@ -70,7 +77,7 @@
// Save glibc and pthread version strings.
#if !defined(_CS_GNU_LIBC_VERSION) || \
!defined(_CS_GNU_LIBPTHREAD_VERSION)
-@@ -528,6 +532,7 @@
+@@ -611,6 +615,7 @@
str = (char *)malloc(n, mtInternal);
confstr(_CS_GNU_LIBPTHREAD_VERSION, str, n);
os::Linux::set_libpthread_version(str);
@@ -78,7 +85,7 @@
}
/////////////////////////////////////////////////////////////////////////////
-@@ -2916,20 +2921,36 @@
+@@ -3053,20 +3058,36 @@
extern "C" JNIEXPORT void numa_warn(int number, char *where, ...) { }
extern "C" JNIEXPORT void numa_error(char *where) { }
@@ -135,7 +142,7 @@
#define REG_SP REG_RSP
--- old/src/hotspot/share/gc/shared/genCollectedHeap.cpp
+++ new/src/hotspot/share/gc/shared/genCollectedHeap.cpp
-@@ -1147,7 +1147,7 @@
+@@ -1144,7 +1144,7 @@
static ScratchBlock *removeSmallestScratch(ScratchBlock **prev_ptr) {
bool first = true;
size_t min_size = 0; // "first" makes this conceptually infinite.
@@ -146,7 +153,7 @@
assert(*prev_ptr == cur, "just checking");
--- old/src/hotspot/share/runtime/vm_version.cpp
+++ new/src/hotspot/share/runtime/vm_version.cpp
-@@ -272,7 +272,7 @@
+@@ -284,7 +284,7 @@
#endif
#define INTERNAL_VERSION_SUFFIX VM_RELEASE ")" \
@@ -215,7 +222,7 @@
#include <math.h>
--- old/src/java.base/unix/native/libjli/java_md_solinux.c
+++ new/src/java.base/unix/native/libjli/java_md_solinux.c
-@@ -235,6 +235,39 @@
+@@ -236,6 +236,39 @@
char *dmllp = NULL;
char *p; /* a utility pointer */
@@ -278,7 +285,7 @@
#include <jvm.h>
#include <jni.h>
-@@ -786,26 +783,6 @@
+@@ -790,26 +787,6 @@
}
return ret;
}
@@ -359,7 +366,7 @@
void *run_java_overflow (void *p) {
JNIEnv *env;
jclass class_id;
-@@ -254,13 +269,19 @@
+@@ -258,13 +273,19 @@
exit(7);
}
@@ -380,7 +387,7 @@
pthread_join (thr, NULL);
printf("Testing stack guard page behaviour for initial thread\n");
-@@ -273,7 +294,7 @@
+@@ -277,7 +298,7 @@
printf("\nTesting NATIVE_OVERFLOW\n");
printf("Testing stack guard page behaviour for other thread\n");
@@ -391,7 +398,7 @@
printf("Testing stack guard page behaviour for initial thread\n");
--- old/test/jdk/java/lang/ProcessBuilder/Basic.java
+++ new/test/jdk/java/lang/ProcessBuilder/Basic.java
-@@ -389,8 +389,8 @@
+@@ -396,8 +396,8 @@
if (failed != 0) throw new Error("null PATH");
} else if (action.equals("PATH search algorithm")) {
equal(System.getenv("PATH"), "dir1:dir2:");
@@ -402,7 +409,7 @@
String[] cmd = {"prog"};
ProcessBuilder pb1 = new ProcessBuilder(cmd);
ProcessBuilder pb2 = new ProcessBuilder(cmd);
-@@ -431,13 +431,13 @@
+@@ -438,13 +438,13 @@
checkPermissionDenied(pb);
// continue searching if EACCES
@@ -418,7 +425,7 @@
equal(run(pb).exitValue(), True.exitValue());
// Check empty PATH component means current directory.
-@@ -453,10 +453,10 @@
+@@ -460,10 +460,10 @@
pb.command(command);
File prog = new File("./prog");
// "Normal" binaries
@@ -431,7 +438,7 @@
equal(run(pb).exitValue(),
False.exitValue());
prog.delete();
-@@ -511,12 +511,12 @@
+@@ -518,12 +518,12 @@
new File("dir2/prog").delete();
new File("prog").delete();
new File("dir3").mkdirs();
@@ -448,7 +455,7 @@
equal(run(pb).exitValue(), False.exitValue());
} finally {
-@@ -613,6 +613,13 @@
+@@ -620,6 +620,13 @@
new File("/bin/false").exists());
}
@@ -462,7 +469,7 @@
static class UnicodeOS {
public static boolean is() { return is; }
private static final String osName = System.getProperty("os.name");
-@@ -651,6 +658,45 @@
+@@ -658,6 +665,45 @@
}
}
@@ -508,7 +515,7 @@
static class EnglishUnix {
private static final Boolean is =
(! Windows.is() && isEnglish("LANG") && isEnglish("LC_ALL"));
-@@ -1954,7 +2000,7 @@
+@@ -1961,7 +2007,7 @@
//----------------------------------------------------------------
try {
new File("suBdiR").mkdirs();
diff --git a/community/openjdk11/fix-bootjdk-check.patch b/community/openjdk11/fix-bootjdk-check.patch
index 04a1c94ff9..18cd4624d2 100644
--- a/community/openjdk11/fix-bootjdk-check.patch
+++ b/community/openjdk11/fix-bootjdk-check.patch
@@ -1,6 +1,8 @@
-The alpine builders print out a warning about sched_getaffinity() not working.
-This causes the version check for the boot jdk to fail.
-Patch the command to determine the version number to ignore any errors and warnings.
+Author: Simon Frankenberger <simon-alpine@fraho.eu>
+Upstream: no
+Reason: The alpine builders print out a warning about sched_getaffinity() not working.
+ This causes the version check for the boot jdk to fail.
+ Patch the command to determine the version number to ignore any errors and warnings.
--- old/make/autoconf/boot-jdk.m4
+++ new/make/autoconf/boot-jdk.m4
@@ -12,4 +14,4 @@ Patch the command to determine the version number to ignore any errors and warni
+ BOOT_JDK_VERSION=`"$BOOT_JDK/bin/java" -version 2>&1 | $GREP version | $HEAD -n 1`
# Extra M4 quote needed to protect [] in grep expression.
- [FOUND_CORRECT_VERSION=`$ECHO $BOOT_JDK_VERSION | $EGREP '\"10([\.+-].*)?\"|\"9([\.+-].*)?\"'`]
+ [FOUND_CORRECT_VERSION=`$ECHO $BOOT_JDK_VERSION \
diff --git a/community/openjdk11/make-4.3.patch b/community/openjdk11/make-4.3.patch
deleted file mode 100644
index b15238cc75..0000000000
--- a/community/openjdk11/make-4.3.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-upstream report: https://bugs.openjdk.java.net/browse/JDK-8237879.
-
-diff --git a/make/common/MakeBase.gmk b/make/common/MakeBase.gmk
-index 170c3ed..697f9d2 100644
---- a/make/common/MakeBase.gmk
-+++ b/make/common/MakeBase.gmk
-@@ -981,7 +981,9 @@ DependOnVariableHelper = \
- $(info NewVariable $1: >$(strip $($1))<) \
- $(info OldVariable $1: >$(strip $($1_old))<)) \
- $(call WriteFile, $1_old:=$(call DoubleDollar,$(call EscapeHash,$($1))), \
-- $(call DependOnVariableFileName, $1, $2))) \
-+ $(call DependOnVariableFileName, $1, $2)) \
-+ $(eval $(call DependOnVariableFileName, $1, $2): ) \
-+ ) \
- $(call DependOnVariableFileName, $1, $2) \
- )
-
diff --git a/community/openjdk11/ppc64le.patch b/community/openjdk11/ppc64le.patch
index c3f7165bd8..6c684c663f 100644
--- a/community/openjdk11/ppc64le.patch
+++ b/community/openjdk11/ppc64le.patch
@@ -1,3 +1,8 @@
+Author: Simon Frankenberger <simon-alpine@fraho.eu>
+Upstream: no
+Reason: Musl libc offers a different structure for context_t*,
+ so we need a patch to access the structure fields correctly.
+
--- old/src/hotspot/cpu/ppc/macroAssembler_ppc.cpp
+++ new/src/hotspot/cpu/ppc/macroAssembler_ppc.cpp
@@ -1290,7 +1290,11 @@
@@ -60,7 +65,7 @@
}
--- old/src/hotspot/cpu/ppc/vm_version_ppc.cpp
+++ new/src/hotspot/cpu/ppc/vm_version_ppc.cpp
-@@ -768,7 +768,7 @@
+@@ -893,7 +893,7 @@
unsigned long auxv = getauxval(AT_HWCAP2);
if (auxv & PPC_FEATURE2_HTM_NOSC) {