aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-05-08 19:06:39 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-05-09 07:27:24 +0000
commitd8a1ac9973640d6e90e245091f2902b4bf34e2fa (patch)
treee1002b841a62bbe5e729f806a84e9be7ba009e53 /community
parentfc43d775341ea12369800f36bee6efe75f7f0010 (diff)
downloadaports-d8a1ac9973640d6e90e245091f2902b4bf34e2fa.tar.bz2
aports-d8a1ac9973640d6e90e245091f2902b4bf34e2fa.tar.xz
community/gnome-software: depend on gnome-software-plugin-apk on supported arches
That package enables APK integration for GNOME Software
Diffstat (limited to 'community')
-rw-r--r--community/gnome-software/APKBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/community/gnome-software/APKBUILD b/community/gnome-software/APKBUILD
index f369f7c0e4..903dd54ba1 100644
--- a/community/gnome-software/APKBUILD
+++ b/community/gnome-software/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=gnome-software
pkgver=3.36.0
-pkgrel=4
+pkgrel=5
pkgdesc="Software lets you install and update applications and system extensions"
url="https://wiki.gnome.org/Apps/Software"
arch="all !s390x !mips !mips64"
@@ -22,6 +22,12 @@ case "$CARCH" in
x86*) makedepends="$makedepends fwupd-dev" ;;
esac
+# gnome-software-plugin-apk is only a runtime dependency and unfortunately
+# not available on other arches yet due to LDC.
+case "$CARCH" in
+ x86_64|aarch64) depends="$depends gnome-software-plugin-apk" ;;
+esac
+
build() {
case "$CARCH" in
x86*) conf="-Dfwupd=true" ;;