aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-07-08 13:18:17 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-07-08 13:11:12 +0200
commit2a0feee39134d45699f08e45057e5ca832938ba1 (patch)
treebb42cebdc5f70b40eda0078ef4faa5417bcae0e8 /community
parent18d6aeb55d768dd3405059c12a15528d05c4bdd6 (diff)
downloadaports-2a0feee39134d45699f08e45057e5ca832938ba1.tar.bz2
aports-2a0feee39134d45699f08e45057e5ca832938ba1.tar.xz
main/libuv: upgrade to 1.21.0 and rebuild dependent packages
Diffstat (limited to 'community')
-rw-r--r--community/captagent/APKBUILD2
-rw-r--r--community/cassandra-cpp-driver/APKBUILD7
-rw-r--r--community/cassandra-cpp-driver/libuv-1.21-compat.patch25
-rw-r--r--community/h2o/APKBUILD2
-rw-r--r--community/libcouchbase/APKBUILD2
-rw-r--r--community/neovim/APKBUILD2
-rw-r--r--community/nodejs-current/APKBUILD2
7 files changed, 35 insertions, 7 deletions
diff --git a/community/captagent/APKBUILD b/community/captagent/APKBUILD
index d636a1a676..7cd26fde05 100644
--- a/community/captagent/APKBUILD
+++ b/community/captagent/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
pkgname=captagent
pkgver=6.3.0
-pkgrel=3
+pkgrel=4
pkgdesc="HEP Capture Agent for HOMER"
url="https://github.com/sipcapture/captagent"
arch="all"
diff --git a/community/cassandra-cpp-driver/APKBUILD b/community/cassandra-cpp-driver/APKBUILD
index 07b8d8bc17..cf00d30a25 100644
--- a/community/cassandra-cpp-driver/APKBUILD
+++ b/community/cassandra-cpp-driver/APKBUILD
@@ -12,7 +12,9 @@ options="!check" # FIXME: cassandra_integration_tests won't link
depends=""
makedepends="cmake make libressl-dev libuv-dev"
subpackages="$pkgname-dev"
-source="$_pkgreal-$pkgver.tar.gz::https://github.com/datastax/cpp-driver/archive/$pkgver.tar.gz"
+source="$_pkgreal-$pkgver.tar.gz::https://github.com/datastax/cpp-driver/archive/$pkgver.tar.gz
+ libuv-1.21-compat.patch
+ "
builddir="$srcdir/$_pkgreal-$pkgver"
build() {
@@ -31,4 +33,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="1b303e874d6b24cb429ec92d6030880ad7d7b28b167a25c62060626c206f623863ecf58eab33e89b0efea4a474ca9500e1701b719ac203c76b0875c2b5d0a1c8 cpp-driver-2.8.1.tar.gz"
+sha512sums="1b303e874d6b24cb429ec92d6030880ad7d7b28b167a25c62060626c206f623863ecf58eab33e89b0efea4a474ca9500e1701b719ac203c76b0875c2b5d0a1c8 cpp-driver-2.8.1.tar.gz
+5932f13a666b95a40d938f2cc6f3b6eb2107d5d569ff67be470913275816109f7a32426cf1e39ef950b9ba1c7f78063c388805b4106368f9f1527ff15c422241 libuv-1.21-compat.patch"
diff --git a/community/cassandra-cpp-driver/libuv-1.21-compat.patch b/community/cassandra-cpp-driver/libuv-1.21-compat.patch
new file mode 100644
index 0000000000..f2070c985e
--- /dev/null
+++ b/community/cassandra-cpp-driver/libuv-1.21-compat.patch
@@ -0,0 +1,25 @@
+From 0edf3d2eff88d7594ed7dc070f889b1bcacb677f Mon Sep 17 00:00:00 2001
+From: "Tobias C. Berner" <tcberner@FreeBSD.org>
+Date: Sun, 24 Jun 2018 08:25:53 +0200
+Subject: [PATCH] CPP-616 - Use uv/version.h as version file for libuv v1.21.0+
+
+libuv v1.21.0+ changed where the version file is located.
+
+Patch-Source: https://github.com/datastax/cpp-driver/commit/0edf3d2eff88d7594ed7dc070f889b1bcacb677f
+---
+ cmake/modules/CppDriver.cmake | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/cmake/modules/CppDriver.cmake b/cmake/modules/CppDriver.cmake
+index 92c243d5..098374f9 100644
+--- a/cmake/modules/CppDriver.cmake
++++ b/cmake/modules/CppDriver.cmake
+@@ -372,6 +372,8 @@ macro(CassUseLibuv)
+
+ if (EXISTS "${LIBUV_INCLUDE_DIR}/uv-version.h")
+ set(LIBUV_VERSION_HEADER_FILE "${LIBUV_INCLUDE_DIR}/uv-version.h")
++ elseif (EXISTS "${LIBUV_INCLUDE_DIR}/uv/version.h")
++ set(LIBUV_VERSION_HEADER_FILE "${LIBUV_INCLUDE_DIR}/uv/version.h")
+ else()
+ set(LIBUV_VERSION_HEADER_FILE "${LIBUV_INCLUDE_DIR}/uv.h")
+ endif()
diff --git a/community/h2o/APKBUILD b/community/h2o/APKBUILD
index 3b30d5e417..11faa6cbf8 100644
--- a/community/h2o/APKBUILD
+++ b/community/h2o/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bennett Goble <nivardus@gmail.com>
pkgname=h2o
pkgver=2.2.5
-pkgrel=0
+pkgrel=1
pkgdesc="An optimized HTTP/1, HTTP/2 server written in C"
url="https://h2o.examp1e.net"
arch="all"
diff --git a/community/libcouchbase/APKBUILD b/community/libcouchbase/APKBUILD
index ba4f4243de..c0e40b1718 100644
--- a/community/libcouchbase/APKBUILD
+++ b/community/libcouchbase/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Nathan Johnson <nathan@nathanjohnson.info>
pkgname=libcouchbase
pkgver=2.8.7
-pkgrel=0
+pkgrel=1
pkgdesc="C client library for Couchbase"
url="https://developer.couchbase.com/community"
arch="all"
diff --git a/community/neovim/APKBUILD b/community/neovim/APKBUILD
index 579eacf22f..9bffe72f44 100644
--- a/community/neovim/APKBUILD
+++ b/community/neovim/APKBUILD
@@ -13,7 +13,7 @@
# NOTE: ignore-st-cursor-shape.patch will be in neovim 0.2.3
pkgname=neovim
pkgver=0.3.0
-pkgrel=0
+pkgrel=1
pkgdesc="Vim-fork focused on extensibility and agility"
url="https://neovim.io"
# s390x: needs luajit
diff --git a/community/nodejs-current/APKBUILD b/community/nodejs-current/APKBUILD
index 898d4bb075..9b926ba6d8 100644
--- a/community/nodejs-current/APKBUILD
+++ b/community/nodejs-current/APKBUILD
@@ -13,7 +13,7 @@
pkgname=nodejs-current
# The current stable version, i.e. non-LTS.
pkgver=9.11.1
-pkgrel=2
+pkgrel=3
pkgdesc="JavaScript runtime built on V8 engine - current stable version"
url="https://nodejs.org/"
arch="all"