aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2018-09-17 15:17:48 +0000
committerTimo Teräs <timo.teras@iki.fi>2018-09-17 15:17:48 +0000
commitca2ab7494bbf96fe25d3828eada7db926c190fa3 (patch)
treeeef68e69590d6b0790c5d5150f3f3e20a3fc01cb /community
parent1e57eb02118c44d627d93e78b1188861f30d98cf (diff)
downloadaports-ca2ab7494bbf96fe25d3828eada7db926c190fa3.tar.bz2
aports-ca2ab7494bbf96fe25d3828eada7db926c190fa3.tar.xz
community/chromium: more armhf fixes
Diffstat (limited to 'community')
-rw-r--r--community/chromium/APKBUILD2
-rw-r--r--community/chromium/musl-fixes.patch11
2 files changed, 12 insertions, 1 deletions
diff --git a/community/chromium/APKBUILD b/community/chromium/APKBUILD
index 493ecf044d..12850e1813 100644
--- a/community/chromium/APKBUILD
+++ b/community/chromium/APKBUILD
@@ -355,7 +355,7 @@ e182c998a43d22d1c76a86c561619afd1fca8c2be668265ad5e2f81a3806f7a154272cc027a2f8b3
05fb6d9434565a7a73f5c18d470ae600bf4afbe15d0e4a7c2770bf2596a0bd2788cdfeb37e0b566fc3d26ff2d0791b70488b2c184e3286cff5a1fa25e17582cd default-pthread-stacksize.patch
46e141a932860c6db1f655c8b188b8c41bce0dbb1654c066379fa53063ce6cc3bf8be156bd8e73e103c7d9e956e436732e2f7db0653f9847eb26cbfebc441a10 gn_bootstrap.patch
8fbfd67a0b6bbdf08364e810bd85b4a80dda9af73fefe3aba8010d9b33022d458a785c628515bbda9c743b8a0293d57cfe18fcc5aa2313c845c6fb948c2335f9 last-commit-position.patch
-245a5bf4c0881851482561830d9241ad8b3061d2e2596916c2efbdeaf41b96f5a6181183442b3a33aac53fefb3faf7c327258e051141d778ae6fa5b48b98969c musl-fixes.patch
+9cd1defffb55cd1290e82b233a623e962775e19f001b26ae8f74330f3467499fd16067d607ca8e2b0b9b8d8988cd7ea2af93df65d7cc3d9299b8bc2b472c712e musl-fixes.patch
90efbc89151c77f32434364dcbaabaf9d9a207f4a77f147cd51b3fe100832fbfb3a9fb665303a79a3d788e400f4f41890de202ccbb7bd1fc6252e33c6e74e429 musl-fixes-breakpad.patch
507a8db2317f1f6ec18dec6cb5894b716e9b2542b58887bab9319bc6d4c66fe4a4d09b200ca8e3f11b32e380b282442a27e7a1b358d3c25eef0fa7655e9dc134 musl-hacks.patch
95ead57f7338649351948d100e32e5ec1eeadb02bffa136ff15c6c515eceb8013c444be092d777c1b62b945bfb83b97778ba4d3a0ccc2d7c2c9a0a8cd8ee0f01 musl-libc++.patch
diff --git a/community/chromium/musl-fixes.patch b/community/chromium/musl-fixes.patch
index 84dbc3825d..30334dcbf8 100644
--- a/community/chromium/musl-fixes.patch
+++ b/community/chromium/musl-fixes.patch
@@ -204,3 +204,14 @@ index 10f1c0d..8e86a2e 100644
namespace crashpad {
+--- third_party/crashpad/crashpad/util/linux/thread_info.h.orig
++++ third_party/crashpad/crashpad/util/linux/thread_info.h
+@@ -232,7 +232,7 @@
+ "Size mismatch");
+ #elif defined(ARCH_CPU_ARMEL)
+ static_assert(sizeof(f32_t::fpregs) == sizeof(user_fpregs), "Size mismatch");
+-#if !defined(__GLIBC__)
++#if !defined(__linux__)
+ static_assert(sizeof(f32_t::vfp) == sizeof(user_vfp), "Size mismatch");
+ #endif
+ #elif defined(ARCH_CPU_ARM64)